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xii
Preface
This manual provides the information you need to configure and use CompassLearning Odyssey®, the 
instructional management system with browser‐based curriculum and assessment tools.

About CompassLearning

CompassLearning is a melting pot of ideas and innovation. Our curriculum and assessment experts are some of 
the brightest in their fields. As they develop research‐based instruction, our designers, writers, and engineers 
bring their ideas to life in our Austin, Texas Learning Studio.

Together, we are dedicated to the idea that technology, combined with superior support and professional 
development, can help students reach their highest potential. The result is our flagship product, Odyssey—its 
name is a perfect reflection of our own journey as a company.

Documentation

The Odyssey User’s Guide provides detailed instructions for using Odyssey Manager. This guide is provided online 
in Adobe® Acrobat® PDF format. To be able to read the PDF file, you will need Adobe® Reader® installed on your 
system. Adobe makes its Reader available for a free download from the Adobe Web site at www.adobe.com

NOTE    Cross‐references to other sections in the manual are clickable in the online PDF. 
Links are formatted in green. Also, with bookmarks displayed in the online PDF, the book’s 
table of contents is available to the left of the reading window.

Release Notes

The Release Notes for Odyssey Manager outlines features new to the release and provides important information 
that was not included elsewhere.

Online Help 

Comprehensive help is available by clicking the Help button in the product.

Knowledge Center 

Online access for all of our product manuals.
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Preface xiii
Typographic Conventions
Typographic Conventions

The following conventions are observed throughout this guide:

• Bold text designates file and folder names, dialog titles, names of buttons, icons, and menus; and terms that 
are objects of a user selection. 

• Italic text is used for emphasis and book titles.

Alert Statements

Alert statements highlight information as follows:

NOTE    Information that is incidental to the main text flow, or to an important point or tip 
provided in addition to the previous statement or instruction.

TIP    Advice to help you work with Odyssey Manager. 

BEST PRACTICE    Recommended practice.

CAUTION    Advises of machine or data error that could occur should the user fail to take 
or avoid a specified action.

WARNING    Requires immediate action by the user to prevent actual loss of data or 
where an action is irreversible, or when physical damage to the machine or devices is 
possible.

Support

Visit us on the web at www.compasslearning.com

To obtain assistance, offer feedback or request enhancements: 

Sales and Customer Service 512.478.9600

Technical Support 800.678.1412

Product and Services 800.232.9556

Internet www.compasslearning.com/customersite

Postal Mail CompassLearning, Inc.
203 Colorado Street
Austin, Texas 78701
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Preface xiv
Support
Before You Call

In order to expedite your call and save you time, please have the following information ready when you call:

• Lab number or previous incident number.

• Curriculum Manager Version number.

• Error message and/or description of abnormal condition.

• Steps already taken to solve the problem.
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1 Introduction
CompassLearning® Odyssey® is a sophisticated instructional management system offering browser‐based 
curriculum, comprehensive assessment, and broad‐based reporting. CompassLearning Odyssey includes exciting 
graphics, interactive animation, creative sound design, and hands‐on activities that engage students and envelop 
them in a unique learning experience.

Odyssey Manager coordinates all of the components contained in the suite. When you build assignments for 
students in your school, you will draw from curriculum aligned to state standards. Assessment options include 
testing objectives that are based on state and national standards for each subject area. As students start using 
Odyssey, you will be able to measure results in numerous ways with Odyssey’s reporting module. Reports may be 
run at the district, school, class, or individual student level. With Test Translator as part of your suite of 
components, you will import tests that have been conducted externally and let Odyssey assign learning paths 
based on those test results.

Odyssey Manager provides administrators and teachers with the information they need—based on valid, real‐
time data—to make informed decisions about classroom instruction and curriculum. 

Feature Description

Identification of 
students’ strengths 
and weaknesses

Formative assessments pinpoint specific knowledge gaps and assist teachers with 
instructional planning at the individual student level.

Differentiated 
instruction

Based on initial assessments, Odyssey automatically assigns a learning path for each 
student. Teachers can adjust that learning path based on the results of regular progress 
monitoring. While Odyssey guides students through the activities in their learning paths, 
teachers can work with small groups of students with similar needs.

School District**Assignment Builder

School A

School B

School C

Teacher 1

Teacher 2

Teacher 3

Class

Class

Class
Students

Assignment
Curriculum

Assessment
Assignment

Assignment

AssignmentTest
Translator*

Reporting
partial list

Attendance

*Requires special 
licensing

ODYSSEY MANAGER

District, school, class, and 
student Odyssey data

NWEA and state external 
assessment scores

Enrollment

Student 
Progress

**Schools are not required to and may 
not be in a district.

State 
Standards
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Introduction 2
The Odyssey system is based on user role, meaning that access to an area in the product depends on your user 
login. The following primary roles are defined within the Odyssey system. 

NOTE    Although Odyssey limits user roles to certain functionality, an individual may log 
into Odyssey with a different user name. For example, if a school administrator serves 
also as a teacher, the individual will have two separate logins for these two roles.

Browser‐based 
curriculum

Colorful, dynamic and age‐appropriate graphics and audio are combined with explicit 
instruction and examples to create a student‐friendly learning environment. Students have 
multiple opportunities to grasp a concept.

Ongoing assessment Quizzes and other assessments embedded in the activities provide ongoing feedback into 
student progress, helping the teacher make changes to a student’s learning path, if 
necessary.

Reporting A variety of reports can be generated, including aggregated and disaggregated data reports, 
multi‐school administration reports, pre‐test versus post‐test comparisons, and individual 
student progress reports.

Alignment with state 
standards

Odyssey curriculum for elementary, middle, and high school students is a comprehensive 
solution aligned to state standards.

User Description Tasks

District 
Administrator

Performs administrative functions for the 
school district, which may include 
multiple schools. Administrative 
permission allows users to work with 
school information at the district level.

• Maintains the district or school accounts.

• Creates and maintains teacher records.

• Imports student and teacher records.

• Transfers student records.

• Performs end‐of‐year tasks.

• Imports NWEA and state data.

• Generates district‐wide or school‐wide reports.

School 
Administrator

Performs administrative functions for the 
school. Similar to the district 
administrator, the school administrator 
manages information at the school level.

District Reports 
Administrator

Generates district‐wide reports. This user accesses the Reports module only in the Odyssey system. 

Teacher Manages one or multiple classes with 
students, including maintaining class and 
student account information, assigning, 
customizing and previewing activities, 
and viewing reports on student progress.

• With permission, creates and maintains class and 
student records.

• Builds assignments and assigns them to students.

• Monitors class progress and grades writing projects.

• Generates reports for the class(es) a teacher manages.

Student Accesses personal activities and assignments and views progress to date.

Parent Monitors their student’s progress and previews activities.

Feature Description
CompassLearning® Odyssey User’s Guide



3

2 Getting Started
When you navigate to your site’s Odyssey Manager login screen, you will see many useful links, including the 
User Name and Password fields you will use for accessing Odyssey Manager.

Log in here 
with your user 
name and 
password. 
Type a school 
name if your 
site uses a 
unique district 
or school 
name.

Clicking Support displays the Customer Support 
page for you to log in.

To display information about the curriculum available 
through Odyssey, click Solutions and Educators.

Launches Sample Activities.

Take a Tour of Odyssey. 

Displays the Privacy Policy (and Terms) and the Universal Access Policy.

Displays System Requirements for running Odyssey Manager and lets you run a 
check of your current system.

Displays alliances in curriculum development.

Provide feedback.

Navigates to the CompassLearning home page.

Our contact information.
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At login, a launch pad corresponding to Odyssey role—district administrator, school administrator, or teacher—
displays the Odyssey home page. The following example screen displays the launch pad for a teacher. 

Odyssey Manager includes the following modules. Module access depends on your user role. 

Module User Tasks

Setup District and school 
administrators

• Maintain district and school accounts.

• Create and maintain teacher accounts.

• Import student and teacher records. 

• Transfer students, assignments, and assessments.

• Perform end‐of‐year procedures.

Teachers Create and maintain student and class accounts.

Assignments District and school 
administrators

• Review assignment status for students.

• Manage assignments, including editing properties, deleting assignments 
from the Assignment Archive, and unassigning students and 
assignments.

Teachers • Build, edit, and delete assignments.

• Assign quizzes, chapter tests, and objective‐based tests to classes and 
individual students.

• View class and individual student progress.

Assessment
(available if 
purchased at 
your site)

District and school 
administrators

Use Objective Builder and Item Builder to create standard sets and test 
items. 

Teachers • Use Test Builder to build objective‐based tests. 

• With permission, use Objective Builder and Item Builder to create 
standard sets and test items.

Use these buttons to navigate to Odyssey modules—Setup, 
Assignments, Assessment, Reports, and Content.

Click Log Out to 
log out of 
Odyssey. Use 
this logout 
method instead 
of clicking the 
browser 
window’s X 
button.

Returns to the launch pad for the user—
teacher, school administrator, or district 
administrator.

These links 
navigate to 
Odyssey 
modules also.

To launch a 
learning 
activity, type 
the activity 
number and 
then Go.

Click Help to 
access 
Odyssey 
resources.
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Logging into Odyssey Manager
Logging into Odyssey Manager

1 Navigate to the URL for your Odyssey installation.

2 Enter your user name and password.

3 If a unique district or school name was created when your account was set up, enter that name in the School 
field. 

OR

Use the default ODYSSEY school name.

4 Click Log In.

5 When you first log in, you will see a Terms and Conditions Agreement screen. Carefully review this page and 
the Privacy Policy.

6 When finished, click Accept.

The Odyssey launch pad is displayed.

To log into Odyssey without displaying the Terms, check Do not show again. 

Reports All users Display and print a variety of reports.

Content All users • Browse available Odyssey curriculum and Explorer tests.

• Generate the Curriculum and State Correlation reports.

• Access Knowledge Center.

• Link to the CompassLearning Support page, from which you can initiate 
an online help session. During business hours, you can have a live online 
discussion and be logged into Odyssey at the same time.

Module User Tasks
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Navigation
Navigation

Odyssey presents much information—including class and student records and curriculum—in a tree structure, 
which you will navigate by opening folders. Selecting the desired item displays additional information. The 
following sample screen displays teachers in one school—County Training Lab. 

The grid displays the contents of the selected item in the tree. In the following sample screens, the trees display 
teacher Sandy Pasch’s two classes. In the top sample screen, Sandy Pasch is highlighted in the tree, and the grid 
displays her two classes. In the bottom screen, her MA5Pasch‐Lakeview class is highlighted in the tree, and the 
grid displays the students in the class. 

The school icon is 
expanded to display 
teachers.

This teacher has one 
class named 3rd grade.

Click the plus sign (+) 
to display a teacher’s 
classes.

With the school selected in the tree, the grid displays the school’s teachers.

Tree

Grid

Teacher Sandy Pasch 
is selected in the 
tree, displaying 
Sandy Pasch’s 
classes in the grid.

Available buttons 
reflect the selection 
you make in the 
tree.

Selecting a class name in the 
tree displays students in the 
class in the grid.
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Navigation
Similarly, Odyssey uses a tree and a grid to display curriculum contents. 

The level and 
subject icon 
is expanded 
to display 
the chapter 
folders.

The Whole 
Numbers 
chapter 
folder is 
expanded to 
display 
lesson 
folders for 
the chapter.

With the Whole Numbers 
chapter folder selected in the 
tree, the tree and grid display 
the lesson folders.

With the Whole Numbers without Place Value lesson folder selected in the tree, the grid 
displays the learning activities in the lesson. Clicking an activity name launches the activity.
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Icons
Icons

Odyssey makes extensive use of icons to denote resources in the application. To quickly learn an icon’s type, from 
the grid, position your cursor over the icon. Additionally, the icon key is a valuable help. Look for the link to the 
icon key when you build an assignment and browse curriculum. 
CompassLearning® Odyssey User’s Guide
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Search
Search

Performing a search—for students, teachers, or assignments—will precede many of your tasks with Odyssey 
Manager. For example, you may use the Student Index to locate student records. Selecting Setup>Student Index 
opens the following screen: 

District administrators search all schools in the district; school administrators search all classes in the school; and 
teachers search their own classes. 

Search by Student 
Name or Student 
ID. Click Name or 
ID and then enter 
the text to locate. 

Enter student name 
(or partial name); 
student user name (or 
partial user name); 
or entire ID.

After you have 
selected the desired 
filters, click Search. Odyssey Manager returns student names in the 

grid that match the criteria you entered.
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Student Users
Student Users

When students log into Odyssey, they will see a student’s launch pad that corresponds to the grade level that is 
set in their student profile. The following examples display launch pads for four students in four different grade 
levels: PreK, third, sixth, and ninth. Note how the interface, while including the same elements, changes in design 
depending on the student’s grade level. A student’s launch pad may display assignments (circled in orange) and 
other available activities (circled in blue). 

Levels PreK through 2

Levels 3 through 5

Levels 6 through 8

Levels 9 through 12
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Student Users
Student’s Launch Pad

The Odyssey student’s launch pad includes these icons and navigation options: 

From the student’s launch pad, a student can navigate to an assignment—denoted by an orange ring around the 
icon—within a subject area. Any additional subject icons depend on the student’s profile defined when the 
student’s record was created. Depending on your site’s licensing, a student may see these subject areas:

Odyssey Writer

Odyssey Writer, when enabled for a student, is a tool for writing projects. Students may launch Odyssey Writer 
through an assignment; or students may start the tool by clicking the launch pad icon. When a teacher returns a 
graded Odyssey Writer assignment to a student, the icon below the Odyssey Writer icon is animated. 

NOTE    The Odyssey Writer icons differ depending on the grade level of the student user.

For grades PreK–2: Odyssey Writer is available on the student launch pad only after the teacher has evaluated 
and returned the student’s first Odyssey Writer project. 

Algebra I English I Honors Algebra Physical Science Thematic Projects

Algebra II  English II LA Extensions Physics Trigonometry

Biology English III  Language Arts PlayBox Theme Time US Government

Brain Buzzers English IV Macroeconomics Public Speaking US History I

Chemistry Focus Algebra Matematicas Science US History II

ELL Elementary Focus Math Math Social Studies World History

ELL Secondary Geometry Microeconomics  

Click to view the portfolio.

Click to open Odyssey Writer.

Click to view graded Odyssey 
Writer papers. If the icon is not 
animated, there are no papers to 
view.

Click to open the toolkit.

Type an activity code and Go to go 
directly to the learning activity.

Icons ringed in orange indicate an assignment. 
Click the assignment icon to view the learning 
activities in the assignment and begin work. 

Additional subject areas may be 
available. Click the subject icon 
to view chapters and lessons.

Click the X to log 
out of Odyssey. 
Use this logout 
method instead 
of clicking the 
browser 
window’s X 
button.
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Student Users
Toolkit

The Odyssey toolkit includes student resources for the following subject areas (depending on your site’s 
licensing). Students with access to these subject areas will see the toolkit on their launch pad and will be able to 
access the full toolkit at any time during an Odyssey session.

Toolkit resources depend on the subject area and include, among others, glossary, Odyssey Writer templates, 
calculator, algebra tiles, base ten blocks, counters, conversion chart, periodic table, formula chart, and postulates 
and theorems. Opening the toolkit from the student launch pad displays the full set of resources. Opening the 
toolkit from within an assignment displays the toolkit based on the assignment’s subject. 

Algebra I English I Focus Algebra Physical Science US History I

Algebra II  English II  Focus Math  Physics  US History II

Honors Algebra  English III Geometry Trigonometry World History

Chemistry English IV Math US Government

Toolkit available from the 
student’s launch pad

Toolkit available from a math 
assignment

Resources in the math toolkit
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Student Users
Assignments on the Student’s Launch Pad

Navigating to a subject area with an assignment displays one or multiple assignment folders. The Suffixes 
assignment in the following example includes one assignment folder.  

NOTE    Ensure that students use the back, forward, and logout buttons from within the 
Odyssey application. Using the browser controls may cause students to lose assignment 
or test data.

The Suffixes assignment includes four learning activities. 

Odyssey presents activities to students in one of three modes:

• Sequential mode presents tasks to a student in the defined order, returning to the student’s launch pad after 
each task.

• Self‐select mode lets a student perform tasks in any order. 

• Auto‐launch mode presents tasks to a student in the defined order, without returning to the student’s launch 
pad after each task.

When a student has completed a learning activity, a 
checkmark is displayed over the icon. The example at 
right displays a student’s launch pad after the student 
has completed one learning activity in a sequential or 
self‐select mode assignment. In a sequential assignment, 
the student will be able to select only the next activity; 
Quiz 1 in the example. In a self‐select assignment, the student may choose a different activity. 

Click the X to log 
out of Odyssey.

The window’s title is the assignment name. 
The owner for this assignment is Pasch.

Return to the 
launch pad.

Go back one screen.

Flashing arrow indicates which chapter, lesson, or learning activity the student should complete next. 

Click an activity name to launch the activity.
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Student Users
A learning path folder includes activities Odyssey identifies to teach the objectives a student has not mastered in 
an objective‐based test.

In the example at right, the assignment begins with an 
objective‐based test, a test that evaluates an objective 
against the passing score to diagnose a student’s strengths 
and weakness. In the example (right), the learning path 
folder is dimmed (unavailable) because the student has not 
yet taken the test. Odyssey uses the test results to build 
the learning path with appropriate activities.  

The following screen displays the learning path folder after the student has taken the test. Opening the learning 
path folder may display additional folders. 

Clicking the Explorer 3 Operations Learning Path folder 
(left) displays two subfolders (below left). The Std3MA.2.1: 
Operations folder includes three subfolders (below right). 
Clicking the EX3MA.2.1.12: Operations on numbers folder 
displays learning activities, as shown in the bottom screen 
below.

Because the student mastered this objective in the test, the 
corresponding activity in the learning path folder is dimmed.
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Student Users
As students complete learning activities, their launch pad reflects their progress by displaying checkmarks over 
completed activities. If a student masters an objective in the test, the corresponding activity in the learning path 
folder will remain dimmed. The following sample learning path displays activities in various stages of completion 
and mastery. 

NOTE    To learn more about types of assignments and building assignments, see 
Assignments on page 37.
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Student Users
Subject Area Activities for Students

Navigating to a subject area that is not an assignment displays a screen with learning activities that are not 
assigned. 

NOTE    The additional levels available to a student depend on the level set in a student’s 
profile. Additionally, a student will see a level above and below the current level only if 
the curriculum is available and the school is licensed for the levels.

When a student completes a learning activity, a star or a green check mark is displayed over the activity icon. A 
Mastered icon indicates that the student has mastered that chapter in the chapter test. 

Student Portfolio

The student’s individual portfolio displays a student’s recent work, assignments, and scores, organized in the 
following tabs:

• Recent Work displays activities the student has worked on the current day, the current day plus the past week, 
or the current day plus the past 31 days.

Log out of Odyssey.

Click an activity name to launch the activity.

The window’s title is 
the subject area.

Return to the student’s 
launch pad.

Go back one screen.

Levels 
available to 
the student 
within the 
subject area. 
Click a 
different level 
to navigate to 
different 
activities in 
the same 
subject area.
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Student Users
• Assignments displays the student’s assignments in progress, completed, and not started for today plus the 
past 365 days.

• Reports displays the Student Score Report.

NOTE    Recent Work displays student status for activities; Assignments displays student 
status for assignments.

To access the portfolio, a student clicks the backpack icon from the launch pad. 

Recent Work

The following sample portfolio displays Recent Work for John Adams.

Click X to 
log out.

Click to 
display the 
icon key.

Status icons 
display 
progress.

Click a score to display the 
summary.

Click a 
column 
heading to 
sort.

Icons denote the type of 
learning activity.

Click to display 
student’s work 
on activities 
from:
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Student Users
Assignment Status

With the Assignments tab selected, assignment status is displayed. 

NOTE    An assignment’s status is shown as not started (blank page icon) until a minimum 
of one task in the assignment is completed. 

Student Score Report

The Student Score Report displays results for all completed activities, including:

• Learning activities

• Quizzes

• Chapter tests

• Objective‐based tests

• Odyssey Writer projects 

Click to display 
status for 
assignments.

Click Details to 
display more 
information 
about the 
assignment.
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Parent Access
Choose to report on activity for 1 Week, 1 Month, or another Date Range. 

Parent Access

With Odyssey, schools can encourage parents to access their child’s Odyssey accounts. With a parent user name 
and password defined, parents have access to the student’s individual portfolio of a student’s recent work, 
assignments, and scores, organized in the same tabs as the student portfolio. Access to their student’s Odyssey 
portfolio lets parents view recent work, assignments, and attendance within Odyssey, helping meet Title IV 
requirements.

NOTE    Parents who have questions about using Odyssey or require a login to access the 
Odyssey system can contact their child’s teacher. Parents with multiple students using the 
Odyssey system require separate logins for each student. 

Recent Work—Parent View

Selecting the Recent Work tab displays activities the student has worked on the current day, the current day plus 
the past week, or the current day plus the past 31 days. 

• To preview an activity, click the activity name. 

1. Select a subject.

2. Select an
activity type.

3. Select a date 
range.

4. Click Generate.

Print from the PDF view.

At the end of the report, you will 
see a summary.
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• To display the questions and answers to a quiz or chapter test, click the score (not shown in the following 
example). 

• To display the objectives tested and the score on an objective‐based test, click the score.

When parents log into Odyssey, they are taken directly to the student portfolio, with Recent Work displayed.

Click to preview the activity.

Display the 
student’s work 
on activities 
from:

Click to 
display the 
icon key.

Status icons 
display 
progress.

Click a score to display questions 
and answers for quizzes and chapter 
tests; or objectives tested and the 
score for an objective‐based test.

Click a column 
heading to 
sort.

Click X to log out.
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Assignments—Parent View

Selecting the Assignments tab displays the student’s assignments in progress, completed, and not started for 
today plus the past 365 days. Clicking Details for an assignment displays information about all of the activities in 
the assignment.

NOTE    Recent Work displays student status for activities; Assignments displays student 
status for assignments. 

Reports—Parent View

Reports lets parent users generate three reports: 

• Attendance

• Duration

• Student Score

Clicking Details 
for the desired 
assignment 
displays more 
information in the 
lower portion of 
the screen.

Status icons 
display 
student 
progress on 
individual 
activities.

Click a score for an objective‐based test, lesson quiz, or 
chapter test to display the summary.

Click the activity name to preview 
the activity.

Click X to 
log out.

Display the 
student’s work on 
assignments:
CompassLearning® Odyssey User’s Guide



Getting Started 22
Parent Access
When parents first click the Reports tab, they will see the welcome screen.

Attendance Report

The Attendance report displays—for each session—the number of logins and total time the student has worked 
in the system. 

Select a 
report type 
from this 
dropdown.

Click Close to return to the 
Reports welcome screen.

1. Select the
report.

2. Select a
time period.

3. Click Generate.

Print from the PDF view.
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Duration Report

The Duration report displays—for a time period you select—all the activities the student has completed and the 
time spent on each. You can view the activities and the student’s answers on quizzes and tests. To focus the 
information displayed, select a specific subject.

Click an activity name to preview the activity.

Click Close to return to the 
Reports welcome screen.

1. Select the
report.

2. Select a subject.

3. Select a time
period.

4.  Click Generate.

Print from the PDF view.
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Student Score Report

The Student Score report displays—for a time period you select—scores for all of the activities the student has 
completed, along with the time spent on each. You can view the student’s answers on quizzes and tests. To focus 
the information displayed, select a specific subject and activity. 

Status is displayed as a horizontal bar that is proportional in length 
to the score. The bar’s color denotes mastery status.

Click Close to return to the 
Reports welcome screen.

Print from the PDF view.

1. Select the
report.

2. Select a 
subject.

3. Select an 
activity.

4. Select a time
period.

5.  Click Generate.

Click an activity name to 
preview the activity.

Click a score for an objective‐based test, lesson quiz, 
or chapter test to display the summary.

A summary is displayed at the end of the report. 
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FAQs

Logging in and out

I see a blank browser window after logging into Odyssey.

After clearing cookies, cache, or history on your workstation, you may see a blank browser window when you log 
into Odyssey. Minimize the blank window and look for a prompt similar to the following: 

When you send information to the Internet, it might be possible for others to see that information. Do you 
want to continue?

Click Yes and restore the browser window.

Pop‐up blockers may also cause a browser window to be blank. Watch for the yellow information bar to see if the 
browser prevented the site from opening a pop‐up window. Also see this FAQ  on page 26: My pop‐up blocker is 
preventing Odyssey from opening windows.

I logged into Odyssey, but I don’t see the launch pad.

If the launch pad does not appear after you log in, it may be hidden behind the login screen. Minimize the login 
screen or select the launch pad from the taskbar at the bottom of the screen.

How do I log out of Odyssey?

When exiting, click the launch pad X   button; do not click the browser close (X)   button.

To close the student portfolio, click the portfolio X   button. 

Using Odyssey

How does a student complete a test or quiz?

Use the Odyssey Stop, Exit, Turn In, and Continue buttons after completing tests and quizzes. If you use the 
browser window’s X button to close a completed test or quiz window, you may see unexpected results when you 
next log into Odyssey.

Browsers

May I adjust the text size in my browser?

Adjusting the text size to Largest in Internet Explorer may result in less than optimal screen display. Set the text 
size to Medium in Internet Explorer.

The taskbar is in front of my Odyssey screen.

The Windows XP taskbar may partially obscure Odyssey screens. To auto‐hide the taskbar, right‐click the taskbar 
and click Properties. In the Properties dialog box, check Auto‐hide the taskbar, and click OK. The taskbar 
remains hidden but pops up when you move the cursor to the bottom of the screen.
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The control strip is in front of my Odyssey screen.

On Mac machines, it is recommended that you minimize the control strip on the desktop.

May I maximize Odyssey screens?

You can maximize or resize most Odyssey screens. CompassLearning recommends that you leave the screens at 
their default and original size.

My pop‐up blocker is preventing Odyssey from opening windows.

Disable any third‐party pop‐up blocker installed on a workstation. The pop‐up blocker in Windows XP SP2 must 
also be disabled. Odyssey requires the capability to have at least two browser windows open simultaneously.

Shortcuts and Key Combinations

May I use keyboard shortcuts?

When you are using Odyssey, avoid browser keyboard shortcuts, such as F11, F3 (find), and F5 (refresh). Instruct 
students to use the Odyssey navigation buttons instead of the function keys (keys across the top of the 
keyboard). One exception to this is using the F8 function key for displaying closed captions in the Language Arts 
3‐8 activities.

Does Odyssey offer closed captions?

Yes, for Odyssey Language Arts 3‐8 activities in these chapters: 

• Vocabulary Skills

• Process Skills: Think Alouds

• Comprehension

• State Simulation Assessments

To display closed captions for these activities, students may press the F8 function key.

May I use the Delete key?

When you are using Odyssey, do not press the Delete key. Use Odyssey’s back buttons instead.

Does Odyssey use right‐click or Control‐click shortcuts?

When you are using Odyssey, do not use right‐click (Windows) or Control‐click (Mac) shortcuts. Use Odyssey’s 
buttons and menu items instead.

Does Odyssey respond to double‐clicks?

Avoid multiple clicking in Odyssey. All Odyssey functions are initiated by single mouse clicks.
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3 Classes and Students

Student Index

Use the Student Index to locate student records, filtering by class, grade level, name, student ID, and student 
attributes. District administrators search all schools in the district; school administrators search all classes in the 
school; and teachers search their own classes. The following sample screen displays the Student Index search 
screen for a teacher.

Searching the Student Index

1 In the navigation bar, click Setup>Student Index.

2 Select the desired filters and then Search. 

The grid displays student records matching your search criteria.

Student Records

When you create a new student record, you will provide the following types of information:

• Personal information

Search by Student Name or 
Student ID. Click Name or 
ID and then enter the text 
to locate. 

Enter student name 
(or partial name); or student 
user name (or partial user 
name); or (entire) ID. 

Use the Student Index to 
add a student to a class; 
attach attributes to a 
student record; or create a 
new student record.
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• Student attributes

• Subject‐level access

As a student uses Odyssey, the system collects information related to the student’s activity: scores on learning 
activities, tests, and quizzes; number and dates of logins; amount of time spent in the system, among other data. 
This information is used in reports and also to populate the student’s backpack. For this reason, it is important for 
each student to have a unique login. Updating a student record so that another student can use the login does 
not update the assignment history. That is, progress reports and the student backpack will still include status 
from the original student.

Your user profile determines the student profile information you can view and edit. A district administrator sets 
permission for school administrators and teachers. A school administrator sets permissions for teachers. See 
User Accounts on page 209.

Creating a new student record launches a wizard for you to enter information about the student in the following 
screens: 

Enter a student’s personal 
information in this screen. The 
Grade, User Name, Password, 
and Confirm Password fields are 
required.

Use the Attributes screen to attach 
student attributes to the student’s 
record. Attributes are useful when 
filtering data for reports.

By default, subject‐level 
access is defined based on 
the grade specified in the 
Personal Information screen. 
Students can access content 
one level above and one level 
below the specified level (if 
there is curriculum at that 
level).

Depending on content your 
site has purchased, your 
subject‐level access may 
include different content.
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Student User Profiles

The following table describes the personal information you will provide when creating a new student record.

BEST PRACTICE    Avoid using special characters in user names, first names, and last 
names. Special characters include @  ‘  ”  %  $  ~  !  _  ~  . (period). 

Student Attributes

The following table describes optional student attributes: 

Student Information Description

First Name
Last Name

Strongly recommended for generating meaningful reports. Also, when a student is 
inactive—through graduation, transfer, or deletion—the first and last name are an 
important means of identifying the student. First and last names can be up to 30 
characters in length. 

Middle Initial Optional one‐character field.

Grade Required field. From the dropdown list, select one value from PreK through High School.

User Name Required field. The student uses the User Name to log into Odyssey.
User names can be up to 30 characters in length and must be unique. Consider using the 
Student School ID for the user name.
Simple user names—such as first initial and last name (e.g., jsmith)—are more likely to 
cause problems (because of duplicates) during the import than full names (e.g., 
josephdsmith).

Password Required field. Passwords can be as short as one character and up to 30 characters in 
length. 
Passwords cannot contain special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  etc.; periods. 
Although passwords are not required to be unique, setting up unique passwords helps to 
ensure that the account is not accessed by someone other than the user. 

Student School ID Optional field. Each student’s Student School ID must be unique and can be up to 256 
characters in length. An example of a common value is the student’s social security 
number. No special formatting is required.
NOTE: For sites using the Test Translator, the Student School ID is required.

(Parent) User Name
(Parent) Password

Unique user name and password that lets parents monitor their child’s portfolio. For 
security, each parent use name connects to only one student.

Student Attributes Description

Gender Select Male or Female.

Nationality Select one ethnicity from these options:
• American Indian/Alaska Native

• Asian/Pacific Islander

• Hispanic

• Black/Non‐Hispanic

• White/Non‐Hispanic

• Other Race or Ethnicity
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Creating a New Student Record

1 In the navigation bar, select Setup>Student Index.

2 From the Student Index search screen, click New Student.

3 The New Student wizard displays the Personal Information screen. Enter the student’s login information, 
remembering that User Name, Password, and Grade are required. Also, First Name and Last Name are 
strongly recommended for generating meaningful reports. 

4 When finished, click Next.

5 From the Attach Attributes screen, check the appropriate student attributes and then Next.

6 From the Subject Level Access and Class Information screen, review the default access available to the 
student, making changes as desired.

7 When finished, click Save.

NOTE    With Autofill or AutoComplete turned on in your browser, student information 
may be completed incorrectly. Consider turning off Autofill and AutoComplete in your 
browser settings.

Special Needs Select one or more attributes these options:
• Speech

• Learning Disabled (LD)

• Physically Challenged

• Exceptional Student Education (ESE)/Special Education—includes all categories of 
children with special needs

• Hearing Impaired

• Gifted

Sociological/Economic Select one or more attributes these options:
• English Second Language (ESL)/English for Speakers of Other Languages (ESOL)/
English Language Learners (ELL)/Limited English Proficiency (LEP) 

• Title I Math

• Title I Reading

• Free or Reduced Lunch

• Economically Disadvantaged

• Migrant

Intervention Select one intervention level from these options:
• Tier 1

• Tier 2

• Tier 3

Other Select one or more attributes from these options:
• Attendance Concern

• Continuous Enrollment—Indicates student enrollment from the previous year. 
Applying end‐of‐year changes automatically sets this attribute. The attribute is not 
transferable. 

• After School Programs

Student Attributes Description
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Deleting a Student Record

For District Administrators

NOTE    District administrators may grant school administrators and teachers permission 
to delete student records from the school roster. See User Accounts on page 209.

1 In the navigation bar, select Setup>Student Index.

2 From the Student Index search screen, select the desired search criteria and then Search.

The grid displays student records matching your search criteria.

3 Check one or multiple student records that you want to delete.

4 When finished, click Delete.

A dialog box requests confirmation to delete the student records.

5 To delete the student records, click OK.

NOTE    The maximum number of student records you can delete in one operation is 
1000. To delete more than 1000 student records, perform the operation multiple times.

Updating a Student Record

CAUTION    Do not reuse a login by changing the student’s name and user name. Instead, 
create a new student record. Updating a student record for another student retains 
assignment history associated with the previous student. This means that progress 
reports and the student backpack will still include status from the previous student. 

1 In the navigation bar, select Setup>Student Index.

2 From the Student Index search screen, select the desired search criteria and then Search.

The grid displays student records matching your search criteria.

3 Click the desired student’s user name. The user name is displayed as a link in the User Name column.

The selected student’s profile displays the Personal Information screen.

4 Make changes to this screen and then Next.

5 From the Attach Attributes screen, check or uncheck the desired student attributes and then Next.

6 From the Subject Level Access and Class Information screen, make changes to the content that is available to 
the student, remembering that available content is determined by content purchased by your site.

7 When finished, click Save. 
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Classes

A class includes one or multiple students and belongs to a teacher, who teaches in a school. The following sample 
screens display Teacher Sandy Pasch’s classes:

With the class record displaying the student names, the command buttons function as follows: 

Creating a New Class

1 Navigate to the teacher’s Setup screen. 

District administrators: In the navigation bar, select Setup>My Schools and then select the teacher’s name in 
the tree, opening the appropriate school in the tree.

OR

School administrators: In the navigation bar, select Setup>My School and then select the teacher’s name in 
the tree.

OR

Teachers: In the navigation bar, select Setup>My Classes.

2 Click New Class.

Button Description

Delete Deletes the student record from Odyssey.
NOTE: District administrators may grant school administrators and teachers permission to 
delete student records from the school roster. See User Accounts on page 209.

Remove Removes the student record from the class. The student record remains in Odyssey and is 
available to be added to another class.

Add Student Adds an existing student record to the current class.

Add New Student Lets you create a new student record and add it to the current class.

Edits the teacher’s profile.

Teacher 
Sandy Pasch 
has two 
classes. 

To display 
students in a 
class, click the 
class name 
in the grid 
or in the tree. Edits the class name.

Displays the student’s profile.Use these buttons to manage students in the class.

Creates a new class for this teacher.
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3 With the New Class dialog box displayed, enter a unique class name.

BEST PRACTICE    To ensure that the entire class name is displayed in reports, limit the 
name to no more than 35 characters.

4 When finished, click Next.

5 From the Attach Attributes screen, check the appropriate student attributes and then Next.

6 From the Subject Level Access and Class Information screen, review the default access available to the 
student, making changes as desired.

7 When finished, click Save.

Adding an Existing Student Record to a Class

1 Navigate to the teacher’s Setup screen. 

District administrators: In the navigation bar, select Setup>My Schools and then select the teacher’s name in 
the tree, opening the appropriate school in the tree.

OR

School administrators: In the navigation bar, select Setup>My School and then select the teacher’s name in 
the tree.

OR

Teachers: In the navigation bar, select Setup>My Classes.

2 Click Add Student.

3 The Student Index displays the search screen for you to locate the student record that you want to add to the 
class. Select the desired filters and then Search. 

The grid displays student records matching your search criteria.

4 Check one or multiple students and then Add Selected Students.

Odyssey displays the class account, including the newly added student.

Adding a New Student Record to a Class

BEST PRACTICE    Limit the number of students in each class to 150.

1 Navigate to the teacher’s Setup screen. 

District administrators: In the navigation bar, select Setup>My Schools and then select the teacher’s name in 
the tree, opening the appropriate school in the tree.

OR

School administrators: In the navigation bar, select Setup>My School and then select the teacher’s name in 
the tree.

OR

Teachers: In the navigation bar, select Setup>My Classes.
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2 Click Add New Student.

3 The New Student wizard displays the Personal Information screen. Enter the student’s login information, 
remembering that User Name, Password, and Grade are required. Also, First Name and Last Name are 
strongly recommended for reporting. 

4 When finished, click Next.

5 From the Attach Attributes screen, check the appropriate student attributes and then Next.

6 From the Subject Level Access and Class Information screen, review the default access available to the 
student, making changes as desired.

7 When finished, click Save.

Removing a Student Record from a Class

1 Navigate to the teacher’s Setup screen. 

District administrators: In the navigation bar, select Setup>My Schools and then select the teacher’s name in 
the tree, opening the appropriate school in the tree.

OR

School administrators: In the navigation bar, select Setup>My School and then select the teacher’s name in 
the tree.

OR

Teachers: In the navigation bar, select Setup>My Classes.

2 Check one or multiple students and then Remove.

3 At the displayed confirmation dialog box, click OK.

A second confirmation dialog box is displayed.

4 To unassign class assignments this student has received, click OK.

OR

For the student to working on the assignments, click Cancel.

Odyssey displays remaining student records in the class account.
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Updating a Class Name

1 Navigate to the teacher’s Setup screen. 

District administrators: In the navigation bar, select Setup>My Schools and then select the teacher’s name in 
the tree, opening the appropriate school in the tree.

OR

School administrators: In the navigation bar, select Setup>My School and then select the teacher’s name in 
the tree.

OR

Teachers: In the navigation bar, select Setup>My Classes.

2 In the tree, click the class name and above the grid, click Edit.

3 The Edit Class dialog box is displayed. Enter the new class name and then Save. 

Deleting a Class

1 Navigate to the teacher’s Setup screen. 

District administrators: In the navigation bar, select Setup>My Schools and then select the teacher’s name in 
the tree, opening the appropriate school in the tree.

OR

School administrators: In the navigation bar, select Setup>My School and then select the teacher’s name in 
the tree.

OR

Teachers: In the navigation bar, select Setup>My Classes.

2 Check one or multiple classes and then Delete.

3 At the displayed confirmation dialog box, click OK.

A second confirmation dialog box is displayed.

Displays the Edit Class 
dialog box.
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4 To unassign class assignments this student has received, click OK.

OR

For the student to continue working on the assignments, click Cancel.
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4 Assignments
An assignment is a collection of one or multiple learning activities, quizzes, and tests. 

Creating and assigning activities is a key component of a teacher’s work with Odyssey Manager. Tasks include:

• Becoming familiar with available curriculum.

• Assigning learning activities, quizzes, chapter tests, and objective‐based tests.

• Building, assigning and maintaining assignments.

• Monitoring class progress and assignment status.

The Assignment Archive manages assignments for district and school administrators and teachers. Access to 
Assignment Archive features depends on your user role. All users can access all assignments in the system, 
viewing the name, subject, level, owner, and modification date. Administrators can edit assignment properties 
and delete assignments. Teachers can edit and delete their own assignments and give assignments to their 
students.

Learning Paths

Some assignments may include a learning path, a set of activities Odyssey identifies to cover the objectives a 
student has not mastered in an objective‐based test, an exit exam (for high‐school level curriculum), or a test 
external to Odyssey Manager. The objective‐based test may be administered by the teacher through the Explorer 
curriculum, or the test may be created with custom assessment objectives. Also, a teacher may administer an exit 
exam as part of an Odyssey high school course. Alternatively, in schools that have purchased support for 
Odyssey’s Test Translator, the test is administered outside of Odyssey Manager. Administrators use Test Translator 
to import test results into Odyssey Manager and a learning path is automatically created based on the results of 
the NWEA or state test. 

NOTE    A learning path that Odyssey creates may include curriculum or curriculum levels 
that a school has not purchased. Students have access to the curriculum, but you can edit 
only those assignments with curriculum and curriculum levels that your school has 
purchased. 

Consider this example: A school has purchased level 4‐8 language arts. Students in grade 4 take an NWEA test, 
the results of which are imported into Odyssey. Based on the NWEA test results imported with Test Translator, 
Odyssey prescribes a learning path with grade 3 language arts activities. Although the students have access to 
the grade 3 language arts curriculum, neither the learning path nor the assignments at the grade 3 level can be 
edited. 

For more information about objective‐based tests and Odyssey assessment solutions, see Assessments on page 
74. For more information about Test Translator, see Test Translator on page 272.
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Curriculum

To gather information before you build an assignment, you may browse the Curriculum Index by selecting 
Content>Curriculum Index. Additionally, you may generate the following reports, also available in the Content 
area of Odyssey Manager: Content>Resources>Reports. 

• Curriculum Report on page 178

• State Correlation Report on page 182

Browsing the Curriculum Index

For Teachers and Administrators

Use the Curriculum Index to browse Odyssey curriculum and assessment material before you create an 
assignment. Browse curriculum by sequences, skills, or state standards. As you plan your assignment, use the 
index to view the contents of prescriptive folders and learning paths and preview specific learning activities, 
lesson quizzes, and chapter tests.

To browse the Curriculum Index, select Content>Curriculum Index.

NOTE    The Curriculum Index is ordered by curriculum set. Your site’s licensing 
determines the available curriculum.

The following example Curriculum Index displays learning activities for Level 4 Math. The curriculum tree is 
opened to display chapter folders, and the Number Theory and Systems chapter folder is opened to display 
assignment folders. With the Standard and Expanded Form lesson folder selected in the tree, you can see the 
activities contained in the folder in the grid.

Chapter
Lesson

Quiz

Lesson Plan 
(with key)

Scored learning activity Learning activity

Search the 
index by 
sequences, 
skills, or 
standards.

Student 
Resource 
Page

Available 
curriculum 
sets 
determined 
by your site’s 
licensing.
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Browsing by Keywords

When you are browsing curriculum, you can search broadly by subject and level and then by chapter and lesson, 
or you can use a keyword to narrow your search to specific objectives. View the contents of prescriptive folders 
and learning paths and preview specific learning activities, lesson quizzes, and chapter tests. 

To search for specific objectives in a selected subject and grade level, type a keyword in the keyword field, and 
click Search.

To search the entire selected subject, click Reset—to remove the grade‐level restriction—enter a different 
keyword if desired, and click Search. Results are limited to 25 pages.

Depending on the category, searching on keywords examines the following:

Browsing the Curriculum Index by Sequences

A sequence is the ordered collection of lesson folders, each containing one or multiple learning activities, 
quizzes, and tests.

The following example displays learning activities by sequences for Level 3 Science. The curriculum tree is 
opened to display chapter folders, and the Life/Environment Interact chapter folder is opened to display 

Category Search behavior

Curriculum • Activity titles or descriptions

• Lesson titles and descriptions

• Chapter titles and descriptions

State standards • State standard keys or descriptions 

• Activity codes, titles or descriptions

• Lesson titles and descriptions

• Chapter titles and descriptions

Odyssey Explorer • Explorer test names

• Strand codes and descriptions

• Content standard codes and descriptions

• Performance standard codes and descriptions
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assignment folders. With the Organisms & Animals Interact lesson folder selected in the tree, you can see the 
activities contained in the folder in the grid.

1 In the navigation bar, select Content>Curriculum Index.

2 Select the desired curriculum set.

3 Select the desired subject and level.

A folder tree and a grid appear, displaying the chapters for the selected subject and level.

4 With the default Sequences mode selected, click a chapter title to view lessons in the chapter.

5 To view a lesson’s learning activities, click the lesson title.

6 To preview the activity, click the activity’s title.

7 To focus your search, type a keyword or activity code in the keyword field, and click Search. 

The grid displays activities matching your keyword.

Browse by 
sequences.
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Browsing the Curriculum Index by Skills

The following example displays learning activities by skills for Level 7 Math. The curriculum tree is opened to 
display topic folders, and the Probability topic folder is opened to display skills. With the Odds skill selected in 
the tree, you can see the activities associated with the skill in the grid.

NOTE    Browsing by skills is available only for curriculum with defined skills.

1 In the navigation bar, select Content>Curriculum Index.

2 Select the desired curriculum set.

3 Select the desired subject and level.

A folder tree and a grid appear, displaying the chapters for the selected subject and level.

4 Select the radio button for the Skills browse mode.

The tree and grid display skill topics for the selected subject and level.

5 To view a topic’s skills, click the topic’s title.

6 To view a skill’s learning activities, click the skill’s title.

7 To preview the activity, click the activity’s title.

8 To focus your search, type a keyword or activity code in the keyword field, and click Search. 

The grid displays activities that match your search request.

Browse by 
skills.
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Browsing the Curriculum Index by State Standards

Standards are objectives that are grouped together based on instructional content.

The following example displays learning activities by state standards for Level 6 Social Studies in Nevada. The 
curriculum tree is opened to display lesson folders. With the C6.5.1 lesson folder selected in the tree, you can see 
the activities associated with the state standard in the grid.

NOTE    Browsing by standards is available only for curriculum correlated to the state 
standards of the account.

1 In the navigation bar, select Content>Curriculum Index.

2 Select the desired curriculum set.

3 Select the desired subject and level.

A folder tree and a grid appear, displaying the chapters for the selected subject and level.

4 To display standards topics for the selected subject and level, click the Standards radio button.

The tree and grid display lessons by standard for the selected subject and level.

Browse by 
state 
standards.
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5 To focus your search, specify a keyword or standard code as follows: 

To search for specific standards in the selected grade level, type a keyword in the keyword field, and click 
Search. 

OR

To search the entire grade level selected in step 3, clear the keyword field, and click Search. Results are 
limited to 25 pages.

OR

To search the entire subject selected in step 3, click Reset (removes the grade level restriction), clear the 
keyword field, and click Search. Results are limited to 25 pages.

NOTE    If Odyssey does not find an exact match, a message will inform you that a partial 
match was found.

6 From the displayed grid, click an activity title to preview learning activities or lesson quizzes. If available, click 
the icons to view student worksheets and lesson plans.

Building Assignments

For Teachers

Assignment Builder is available only to teachers. However, if you are an administrator and want to build an 
assignment, create a new teacher user that you can use for this purpose.

Building an assignment involves three general tasks:

Task 1: Select Curriculum and Activities below

Task 2: Refine the Assignment on page 50

Task 3: Finalize the Assignment on page 53

Task 1: Select Curriculum and Activities

Selecting the curriculum for your assignment involves these general steps:

1 Launch Assignment Builder by selecting Assignments>Assignment Builder.

2 Search for curriculum:

• Browsing Odyssey Curriculum by Sequences below

• Browsing Odyssey Curriculum by Skills on page 45

• Browsing Odyssey Curriculum by State Standards on page 46

NOTE    Browsing Odyssey curriculum within Assignment Builder uses the same process 
as browsing Odyssey curriculum in the Curriculum Index. 

• Browsing Explorer Objective‐based Tests and Learning Paths on page 47

• Browsing NWEA RIT Range Learning Paths on page 48
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3 Create a custom activity:

• Creating an Authentic Task on page 49

• Creating an Odyssey Writer Project on page 50

NOTE    Ensure that all folders include at a minimum one activity. Odyssey will not save 
assignments containing empty folders.

Browsing Odyssey Curriculum by Sequences

The following example displays learning activities by sequences for Level 6 Language Arts. The curriculum tree is 
opened to display chapter folders, and the Comprehension chapter folder is opened to display lesson folders. 
With the Summarizing lesson folder selected in the tree, you can see the activities contained in the folder in the 
grid. 

1 From the navigation bar, select Assignments>Assignment Builder.

2 With Odyssey Curriculum selected, select the desired subject and level.

A folder tree and a grid appear, displaying the chapters for the selected subject and level.

3 With the default Sequences mode selected, click a chapter title in the grid to view lessons in the chapter.

4 To view a lesson’s learning activities, click the lesson title.

5 To preview the activity, click the activity’s title in the grid.

6 To focus your search, type a keyword or activity code in the keyword field, and click Search. 

The grid displays activities matching your keyword.
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7 Click the check boxes in front of desired items to select the items for your assignment, and then click Add 
Selected Tasks. 

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment on page 50.

Browsing Odyssey Curriculum by Skills

The following example displays learning activities by skills for Level 8 Math. The curriculum tree is opened to 
display topic folders, and the Three‐Dimensional Geometry topic folder is opened to display skills. With the 
Angle Measure skill selected in the tree, you can see the activities associated with the skill in the grid. 

NOTE    The following subjects let you view the contents in a hierarchical order grouped 
by skills: Algebra I, Algebra II, Biology, Chemistry, English I, English II, English III, English IV, 
Geometry, Language Arts, Math, Physical Science, Physics, Trigonometry, 
US Government, US History I, US History II, and World History.

1 From the navigation bar, select Assignments>Assignment Builder.

2 With Odyssey Curriculum selected, select the desired subject and level.

A folder tree and a grid appear, displaying the chapters for the selected subject and level.

3 Select the radio button for the Skills browse mode.

The tree and grid display skill topics for the selected subject and level.

4 To view a topic’s skills, click the topic’s title.

5 To view a skill’s learning activities, click the skill’s title.

6 To preview the activity, click the activity’s title.
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7 To focus your search, type a keyword or activity code in the keyword field, and click Search. 

The grid displays activities that match your search request.

8 Check the activities to include in your assignment and then click Add Selected Tasks. 

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment on page 50.

Browsing Odyssey Curriculum by State Standards

The following example displays learning activities by state standards for Level 8 Language Arts in Nevada. The 
curriculum tree is opened to display lesson folders. With the 3.8.1.a lesson folder selected in the tree, you can 
see the activities associated with the state standard in the grid. 

1 From the navigation bar, select Assignments>Assignment Builder.

2 With Odyssey Curriculum selected, select the desired subject and level.

A folder tree and a grid appear, displaying the chapters for the selected subject and level.

3 To display standards topics for the selected subject and level, click the Standards radio button.

The tree and grid display lessons by standard for the selected subject and level.
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4 To focus your search, specify a keyword or standard code as follows: 

To search for specific standards in the selected grade level, type a keyword in the keyword field, and click 
Search. 

OR

To search the entire grade level selected in step 3, clear the keyword field, and click Search. Results are 
limited to 25 pages.

OR

To search the entire subject selected in step 3, click Reset (removes the grade level restriction), clear the 
keyword field, and click Search. Results are limited to 25 pages.

5 From the displayed grid, click an activity title to preview learning activities or lesson quizzes. If available, click 
the icons to view student worksheets and lesson plans.

6 Check the activities to include in your assignment and then click Add Selected Tasks. 

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment on page 50.

Browsing Explorer Objective‐based Tests and Learning Paths

The following example displays the objective‐based test and learning path for the Level 8 English Language Art’s 
standard 3.1 for Writing Strategies. 

1 From the navigation bar, select Assignments>Assignment Builder.

2 Click Explorer (above the subject dropdown).

3 Select the desired subject and level.

A folder tree and a grid display folders containing objective‐based tests and learning paths for the selected 
subject and level.

Explorer 
curriculum 
set is 
selected.
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4 To focus your search, type a keyword in the keyword field, and click Search. 

5 To display a test and learning path, click the desired folder.

6 To preview an objective‐based test, click the test’s title.

7 To display items in a learning path and preview learning path activities and lesson quizzes, click the learning 
path’s title.

8 Check the tests and learning paths to include in your assignment and then click Add Selected Tasks. 

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment on page 50.

NOTE    For instruction on building a custom objective‐based test, see Assessments on 
page 74.

Browsing NWEA RIT Range Learning Paths

Northwest Evaluation Association (NWEA) assessments measure the academic growth of a student or group over 
time using the RIT scale. The following sample displays learning paths for language arts. 

1 From the navigation bar, select Assignments>Assignment Builder.

2 Click NWEA and select the desired subject.

3 To display learning paths grouped by RIT range folders, select the desired assessment folder.

4 To view a learning path’s learning activities and your state standards to which they correlate, do the 
following:

• From the right pane, click the desired learning path. The Assignment View displays learning activities, 
scored and unscored, with their respective grade levels and detailed descriptions of the correlated 
standards for your state.
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• From the Assignment View window, click the desired activity’s title.

5 Check the activities to include in your assignment and then click Add Selected Tasks. 

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment on page 50.

Creating an Authentic Task

An authentic task links to an outside Web site. For example, in an assignment about the digestive system, a 
teacher may include an authentic task that links the student to an external site with a virtual tour of the digestive 
system. Another example might be to enhance an assignment about inventions: the authentic task might link to 
an external site with a list of inventors and inventions. The student may then continue research on inventions 
with the names on the list. 

NOTE    Ensure that you review the Terms and Conditions regarding student privacy and 
connections to outside web sites (available as a link from the Create an Authentic Task 
dialog box).

1 From the navigation bar, select Assignments>Assignment Builder.

2 Click Create Custom Activity.

3 From the Create Custom Activity dialog box, select Authentic Task and click Next to display the Create 
Authentic Task dialog box.

4 From the Subject dropdown, select a subject.

5 In the Title field, type a title for the authentic task.

6 In the Link Text field, type the text that serves as the link in the assignment. 

7 Enter the URL and then click Add Link.

The Description field displays the link text.

8 If desired, add one or multiple links by repeating steps 6 and 7.

9 To include a previously added link in the Description, select the link from the Existing Links dropdown.

10 To explain the task, you can type instructions in the Description field, along with your links.

11 When finished, click Save.

12 At the prompt, click OK. 

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment on page 50.
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Creating an Odyssey Writer Project

Odyssey Writer is a tool within Odyssey Manager that students can use to improve their writing skills. Teachers 
may use Odyssey Writer to create a new writing project or to copy an existing project to use as a template. For 
more information, see Odyssey Writer on page 184.

1 From the navigation bar, select Assignments>Assignment Builder.

2 With the Curriculum tab selected, click Create Custom Activity.

3 In the Create Custom Activity dialog box, select Odyssey Writer Activity and click Next.

The Odyssey Writer tool opens for you to create a project.

4 Create the Odyssey Writer project. See Creating an Odyssey Writer Project on page 187.

Assignment Builder displays the Assignment tab, where you will continue building the assignment. See 
Task 2: Refine the Assignment below.

Task 2: Refine the Assignment

You will use the Assignment tab in Assignment Builder to refine the assignment. The following sample displays a 
math assignment that includes 6 assignment folders, each containing assignment folders with learning activities.

Displays assignment activities and correlated state standards.
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Adding Curriculum to an Assignment

1 From the Assignment tab in Assignment Builder, click Add Curriculum.

2 Search for activities to add to the assignment and click Add Selected Tasks. When finished, click Complete 
Assignment to display the Complete Assignment dialog box, where you will finalize the assignment. See 
Task 3: Finalize the Assignment on page 53.

OR

To create an authentic task or Odyssey Writer project, click Create Custom Activity. See Creating an 
Authentic Task on page 49 or Creating an Odyssey Writer Project above. 

Removing Curriculum from an Assignment

1 From the Assignment tab in Assignment Builder, check the activity in the grid that you want to delete. To 
locate the activity, you may need to open one or multiple folders displayed in the tree.

2 Click Remove.

3 At the prompt, click OK.

4 When finished, click Complete Assignment to display the Complete Assignment dialog box, where you will 
finalize the assignment. See Task 3: Finalize the Assignment on page 53.

Creating a New Folder

BEST PRACTICE    If you create a folder within another folder, consider limiting the 
number of folder levels to a maximum of four. Typically, Odyssey curriculum uses only 
two levels of folders. 

1 From the Assignment tab in Assignment Builder, click New Folder.

2 Click the new folder’s untitled folder link.

3 In the Folder field, type a name for the folder.

4 To add activities or folders to the newly created folder, follow the steps in Moving an Activity to a Folder 
below.

Moving an Activity to a Folder

1 From the Assignment tab in Assignment Builder, select the desired activity in the grid. To locate the activity, 
you may need to open one or multiple folders displayed in the tree.

2 Click Move to Folder.

3 From the Move to Folder dialog box, click the desired destination folder and then Move.

4 At the prompt, click OK.

NOTE    To move an assignment folder, locate the folder so that it is displayed in the grid; 
select the folder in the grid; and click Move to Folder.

5 When finished, click Complete Assignment to display the Complete Assignment dialog box, where you will 
finalize the assignment. See Task 3: Finalize the Assignment on page 53.
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Specifying the Order of Activities in a Folder

Activities in an assignment’s folder can be presented to a student in three modes:

• Sequential presents tasks to students in the defined order, returning to the student’s launch pad after each 
task.

• Self‐Select lets students perform tasks in any order they choose.

• Auto‐Launch presents tasks to students in the defined order, without returning to the student’s launch pad 
after each task.

NOTE    Each folder’s order is independent of another folder in the same assignment.

To change a folder’s mode and assignment order, complete these steps:

1 From the Assignment tab in Assignment Builder, select the desired assignment folder in the grid. To locate 
the activity, you may need to open one or multiple folders displayed in the tree.

2 To change the folder’s mode, select Sequential, Self‐Select or Auto‐Launch.

3 Sequential and Auto‐Launch modes only: To change the order in which the activities are presented to 
students, underneath Update, enter a new value for each activity. When finished, click Update.

4 When finished, click Complete Assignment to display the Complete Assignment dialog box, where you will 
finalize the assignment. See Task 3: Finalize the Assignment below.

Adding a Decision Point to an Activity

1 From the Assignment tab in Assignment Builder, select the desired assignment folder in the grid. To locate 
the activity, you may need to open one or multiple folders displayed in the tree.

2 Select the desired scored activity and click Add Decision Point, remembering that the folder’s order must be 
Sequential or Auto‐Launch.

3 From the Decision Point Options dialog box, specify the new decision point’s configuration. For more details, 
see Decision Points on page 60.

4 When finished, click Save Decision Point.

5 Click Complete Assignment. Assignment Builder displays the Complete Assignment dialog box, where you 
will finalize the assignment. See Task 3: Finalize the Assignment below.
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Task 3: Finalize the Assignment

Clicking Complete Assignment from within Assignment Builder opens the Complete Assignment dialog box. 
Depending on the type of assignment you are building, you may see different options in the dialog box.  

The Complete Assignment dialog box includes these settings:

Item Description

Assignment Name Name of the assignment. A unique assignment name is required.

Description Description of the assignment. Include keywords that might be useful when searching for 
the assignment in the Assignment Archive.

Availability Defines who can access the assignment. To share the assignment across the school, select 
My School. To share the assignment across the district, select My District. Otherwise, 
select the default My Assignments folder.
NOTE: You must be granted permission to save assignments to the My School and My 
District folders.
For tests that use school standards: Do not save to the My District folder. Because an 
account must have all of the curriculum in the assignment to access it from My District, all 
schools may not be able to use the assignment.

Subject Selecting Math, Mathematicas, or the High School curriculum enables student access to 
the toolkit.

Level Select the appropriate grade level.

Assignment Order • Sequential presents tasks to students in the defined order, returning to the student’s 
launch pad after each task.

• Self‐Select lets students perform task in any order they choose.

• Auto‐Launch presents activities to students in the defined order, without returning to 
the student’s launch pad after each task.

Apply assignment order 
to all folders

Enforces the Assignment Order for all of an assignment’s folders.

Suppress Duplicate 
Activities

Ensures that a student does not have to complete the same activity multiple times within 
an assignment. See Suppression on page 68.
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Assigning and Saving the Assignment

1 With the Complete Assignment dialog box displayed, give the assignment a name and description.

2 Specify the assignment’s availability—My Assignments, My School or My District (if available).

3 Select the Subject and Level for the assignment.

4 Select the assignment order—Sequential, Self‐Select or Auto‐Launch—and whether to apply this order to all 
the folders in the assignment.

5 If desired, turn suppression of duplicate activities off. The default setting is on.

6 Optional for offline processing: if available, specify offline processing for an objective‐based test.

7 To save the assignment for further review, set Draft Mode to Yes.

8 To make Odyssey Writer available, set Show Odyssey Writer to Yes.

9 To make the toolkit available, set Show Tool Kit to Yes.

10 For NWEA assignments: If available, set Show Non‐core Activities to Yes.

11 Specify whether you will assign to students now or later.

12 When finished, click Next.

13 If you specified Yes to assign to students, select one or multiple classes or individual students and then Finish. 
At the confirmation prompt, click Close.

OR

If you specified No, I’ll assign it later, you will see a confirmation prompt. Click Close.

Make objective‐based 
test offline

(Available for teachers at licensed sites only.) Objective‐based tests meeting certain 
requirements can be printed and administered offline. The results are imported into 
Odyssey. 
BEST PRACTICE: After completing the assignment, do not edit it to make the objective‐
based test online. Instead, make a copy of the assignment. 
For more information, see Offline Tests on page 268.

Show Resources On the student’s launchpad, displays a link to any student resources (or worksheets) 
associated with an activity. Activities that include student resources are denoted in the 
curriculum by a page icon with the letter S.

Draft Mode Specifies that the assignment is for review only. To administer the assignment, turn off 
Draft mode. 

Show Odyssey Writer Makes Odyssey Writer available from within the assignment.

Show Tool Kit Makes the toolkit available from within the assignment.

Show Non‐core 
Activities

Makes non‐core activities available. Non‐core assignments originate by importing an 
assignment or creating an assignment with the RIT range folders in Assignment Builder. 

Item Description
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Deleting an Assignment

District and school administrators can delete all assignments. Teachers can delete only their own assignments.

NOTE    If a student has started an assignment that you later delete, reports filtered by 
assignment will not display results for that student’s progress on the assignment. Filter 
reports instead by type.

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment and click Delete.

5 At the confirmation prompt, click OK.

Building an Assignment from a Copy

Any assignment available school‐ or district‐wide can be used as a template for a new assignment that you build.

CAUTION    If you copy an assignment that includes an objective‐based test, and then edit 
the test, your edits are applied to the original objective‐based test. 

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment and click Open a Copy.

5 Assignment Builder displays the activities in the assignment. To add curriculum or create a custom task—
Odyssey Writer activity or authentic task—click Add Curriculum. See Task 1: Select Curriculum and Activities 
on page 43.

6 If desired, remove or reorder activities. Also, use this screen to add a decision point to a scored activity. See 
Task 2: Refine the Assignment on page 50.

NOTE    Ensure that all folders include at a minimum one activity. Odyssey will not save 
assignments containing empty folders.

7 Click Complete Assignment.

8 With the Complete Assignment dialog box displayed, rename the assignment and select Availability, Subject 
and Level. For details on additional settings, see Task 3: Finalize the Assignment on page 53.

9 When finished, click Next.

10 Select one or multiple classes or individual students and then Finish. At the confirmation dialog box, click 
Close.
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Building an Objective‐based Post‐Test

To display student progress on objectives, the most recent instance of an assignment test must be a copy of the 
original test.

1 In the navigation bar, select Assignments>Assignment Archive.

2 Locate the pre‐test: under Assignment Search, select the search criteria for locating the pre‐test—
Availability, Subject, Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment and click Open a Copy.

Assignment Builder displays the objective‐based test and learning path in the assignment. 

Do not make any changes to the test properties or test name. 

5 If desired, you may delete the learning path.

6 You may edit the assignment name to include Post or Post‐Test in the name, distinguishing this test from the 
pre‐test.

NOTE    Change only the assignment name. Do not change the test name or any of the 
test properties.

7 Click Complete Assignment.

8 With the Complete Assignment dialog box displayed, select Availability, Subject and Level. 

9 When finished, click Next.

10 Select one or multiple classes or individual students and then Finish. At the confirmation dialog box, click 
Close.

Assigning and Unassigning Assignments

Assigning Saved Assignments from the Archive

TIP    When an assignment is built, it is categorized by grade level and subject. When you 
search for an assignment, search for these categories, not the level or subjects of the 
activities within the assignment.

Teachers can assign their own or others’ saved assignments from the Assignment Archive.

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment or assignments and click Assign to Students.

5 With the Assign Students dialog box displayed, check one or multiple classes or individual students and then 
Finish.
CompassLearning® Odyssey User’s Guide



Assignments 57
Assigning and Unassigning Assignments
6 At the confirmation dialog box, click Close.

Unassigning by Assignment

1 In the navigation bar, select Assignments>Assignment Status.

2 Ensure that the default Assignment radio button is selected.

3 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade. To refine your search, use a keyword.

4 Click Search.

5 Select the desired assignment and then click View Status.

6 With the status grid displayed, check one or multiple students and click Unassign.

7 At the confirmation, click OK.

The status grid is refreshed and no longer displays the student or students you selected.

NOTE    If a student has started an assignment that you later unassign, reports filtered by 
assignment will not display results for that student’s progress on the assignment. Filter 
reports instead by type.

Unassigning by Student

1 In the navigation bar, select Assignments>Assignment Status.

2 From the Search page, click the Student radio button.

3 Under Student Search, select the search criteria for locating the student—Class, Grade and other student 
attributes. To refine your search, type the student’s name or a portion of it.

4 Click Search.

5 Select the desired student and then click View Status.

6 With the Status page displayed, check one or multiple assignments and click Unassign.

7 At the confirmation, click OK.

The status grid is refreshed and no longer displays the assignment or assignments you selected.

NOTE    If a student has started an assignment that you later unassign, reports filtered by 
assignment will not display results for that student’s progress on the assignment. Filter 
reports instead by type.
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Editing Assignments

NOTE    A learning path that Odyssey creates automatically may include curriculum or 
curriculum levels that a school has not purchased. You can edit only those assignments 
with curriculum and curriculum levels that your school has purchased. 

CAUTION    If you copy an assignment that includes an objective‐based test, and then edit 
the test, your edits are applied to the original objective‐based test. 

For School and District Administrators

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

District assignments are available to all schools in the district. If a district administrator selects School A, Any 
owner, and District availability, all district‐level assignments, without school or ownership limitations, are 
displayed. If a district administrator selects School A, Teacher 1, and District availability, all district‐level 
assignments available to School A and owned by Teacher 1 are displayed.

3 Click Search.

4 Select the desired assignment and click Edit. 

5 With Assignment Properties displayed, make the desired changes, remembering that checking Draft Mode 
will make the assignment unavailable to assign. If the assignment is already assigned, Draft Mode is 
unavailable.

NOTE    To change the assignment’s owner, select a different name from the Owner 
pulldown list.

6 When finished, click Save Changes.

For Teachers

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment and click Edit. 

NOTE    You can view all assignments, but you can edit only your own assignments. To 
change an assignment that is not your own, open a copy.

5 With Assignment Properties displayed, make the desired changes, remembering that checking Draft Mode 
will make the assignment unavailable to assign. If the assignment is already assigned, Draft Mode is 
unavailable.
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6 When finished, click Save Changes to return to the search results screen.

OR

To edit the assignment content, click Edit Tasks.

7 You are prompted to apply your edits to all or selected students. Click All Students or Selected Students.

• All Students changes assignments that may be in progress.

• Selected Students creates a copy of the assignment.

CAUTION    Exercise care when editing assignments. Deleting or moving an activity in an 
assignment that has been assigned already may cause data loss. 

8 Assignment Builder opens for you to make changes to the assignment content. 

• To add curriculum or create a custom task—an Odyssey Writer activity or authentic task—click Add 
Curriculum. See Task 1: Select Curriculum and Activities on page 43.

• To edit an authentic task, click the Edit link by the authentic task’s title.

9 If desired, remove or reorder activities. Also, use this screen to add a decision point to a scored activity. See 
Task 2: Refine the Assignment on page 50.

NOTE    Clicking New Assignment cancels your edits and creates a new, empty 
assignment. 

10 Click Complete Assignment.

11 With the Complete Assignment dialog box displayed, rename the assignment and select Availability, Subject 
and Level. For details on additional settings, see Task 3: Finalize the Assignment on page 53.

12 When finished, click Next.

13 Select one or multiple classes or individual students and then Finish. At the confirmation dialog box, click 
Close.

NOTE    If you start to edit an objective‐based test on which students have already begun 
work, the system makes a copy of the test, and it is this copy that you will be editing. This 
test will then be a custom test that you own.
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Modes

Odyssey modes allow an educator team to follow an iterative development process for school‐wide or 
district‐wide assignments.

Additionally, each assignment is owned by an Odyssey user, and typically, teachers own and edit their 
assignments. To manage ownership changes resulting from student transfers and teacher personnel changes, 
school and district administrators can edit an assignment’s owner. District administrators can edit assignment 
owners in their district, and school administrators can edit assignment owners in their school.

Decision Points

A decision point defines a custom set of activities for a student who does not meet the mastery level for a scored 
activity. Decision points enhance learning paths by giving a teacher an opportunity to intervene in the learning 
cycle and by providing opportunities for students to master all activities in the assignment. A decision point is 
added to a scored activity, creating a branching activity with two conditions—mastery and non‐mastery—to 
determine the student’s next activity. The activity a student works on after the branching activity depends on the 
student’s score for the branching activity. 

NOTE    For guidelines on using decision points effectively, see Rules for Decision Points 
on page 64.

The following diagram illustrates an assignment folder with a decision point on Activity #3. Students mastering 
the activity continue to the next activity in the folder—Activity #4. Students who do not master Activity #3 return 

Mode Functional area Description

Draft Assignments Draft mode enables peer review and editing of assignments and 
assessments before district‐wide implementation. Assignments in Draft 
mode are stored in the Assignment Archive but cannot be assigned to 
students or used for reporting. 
NOTE: Any part of an assignment marked Draft causes the entire 
assignment to be in Draft mode.

Objectives 
and standard sets

Draft objectives and standards are available for review but cannot be 
associated with test items.

Test items Draft test items are available for review but cannot be included in an 
objective‐based test.

Active Assignments Active assignments are ready for use and may be assigned to students. 
Active mode is the default for any material created in Assignment Builder 
or Test Builder.

Objectives 
and standard sets

Active objectives are ready to associate with test items. Active mode is the 
default for new material created in Objective Builder.

Test items Active test items are ready to be included in an objective‐based test. 
Active mode is the default for new material created in Test Builder.

Lock Objectives 
and standard sets

Locked standard sets or individual objectives cannot be edited. 
After a standard set (or individual objectives with their corresponding test 
items) has been reviewed and approved, a district administrator may lock 
the standard set so that the approved items are not changed during the 
time a test is administered. 
NOTE: Teachers cannot lock objectives.
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to the first activity in the folder—Activity #1. They repeat Activity #1 and Activity #2 in succession and have 
another opportunity to master the Activity #3. Then they continue to the next activity in the folder—Activity #4.  

NOTE    You can add decision points to Sequential or Auto‐Launch folders only. Because 
decision points depend on a defined order of activities, you cannot add a decision point 
to a Self‐Select folder. 

Teachers will use the Decision Point Options dialog box to add decision points to an activity.

Activity #1 Activity #3 (Scored)  Activity #4 Activity #5 (Scored

ASSIGNMENT FOLDER

Activity #2 Decision
Point

Mastery: Continue 
Non‐Mastery: Cycle Once and Continue

Mastery Score defines 
the Met/Not Met condition for 
the decision point. 
The mastery score must be a 
numeric value between 1 and 
100. The default is 70.

The decision point is defined for 
this scored activity.
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Use the following options to define a decision point:

NOTE    The Continue, Progress Alert and Restart Folder options can each follow a Cycle 
option to allow for additional configuration of decision points. For example, one 
combination might be Cycle once and then Continue to the next activity in the sequence.

When you set a decision point, the icon displayed next to the activity denotes the decision point’s configuration. 
Because each decision point is configured for mastery and non‐mastery scores, the icon reflects both conditions. 
The following table describes the most frequently used decision points. 

Name Action

Exit The student exits the folder.

Cycle The student returns to the specified activity—the target—and repeats it and any activities between 
the target activity and the activity with the decision point. Accepted values for Cycle are 1–4.
With a maximum value of 4 entered for Cycle, it is possible for the student to repeat the activities up 
to five times: one time as the decision point triggers the cycle and then four more times. 

Continue The student continues to the next activity, if any, in the folder.

Progress Alert The folder is locked and the student is instructed to contact the teacher. Using a progress alert is an 
opportunity for a teacher to provide one‐on‐one instruction to the student.
Teachers can unlock the progress alert in two ways:
• At the student’s workstation. For instructions, see Unlocking a Progress Alert at the Student 
Workstation on page 66. When Odyssey is initially installed, the password to unlock a progress 
alert is unlock99. If you are unable to unlock the progress alert with this password, check with your 
district or school administrator. 

• When logged in as a teacher user: in the navigation bar, selecting Assignments>Assignment 
Status. For instructions, see Unlocking a Progress Alert through Assignment Status on page 67.

When you unlock the progress alert, you can direct the student in these ways:
• Continue lets the student work on additional material, if any, in the folder.

• Restart Folder starts the folder one time from the beginning. Note that decision points are not 
applied when a folder is restarted. That is, after completing a branching activity, a student will 
continue to the next activity, regardless of the student’s mastery score.

• Exit folder takes the student out of the current folder and moves to the next folder, if any.

Restart Folder Decision point and cycling history for the folder are cleared. The student returns to the first activity 
in the folder and repeats the entire folder, one time only, with previously set conditions.

Icon Name If student meets mastery score If student does not meet mastery score

Next activity & 
Cycle and then 
continue

The student continues to the 
next activity, if any, in the folder.

The student returns to the target activity and 
completes it and any intervening activities a number of 
times you specify. Then, the student continues to the 
next activity, if any, in the folder.

Exit & Cycle and 
then progress 
alert

The student exits the folder. The student returns to the target activity and 
completes it and any intervening activities a number of 
times you specify. Then, a progress alert is displayed.

Cycle to self and 
then continue 

The student continues to the 
next activity, if any, in the folder.

The student repeats the activity a number of times you 
define. Then, the student continues to the next 
activity, if any, in the folder.

Exit & Cycle and 
then continue

The student exits the folder. The student returns to the target activity and 
completes it and any intervening activities a number of 
times you specify. Then the student continues to the 
next activity, if any, in the folder.
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The following table describes all of the decision point icons and Odyssey actions when the mastery score is both 
met and not met.

In the following example, a folder includes two decision points: Exit & Continue and Continue & Cycle and 
Continue. 

Exit & Continue The student exits the folder. The student continues to the next activity, if any, in the 
folder.

Cycle to self and 
then progress 
alert 

The student continues to the 
next activity, if any, in the folder.

The student repeats the activity a number of times you 
define. Then, a progress alert is displayed.

Continue to next activity when 
mastery score is met or not met.

Continue to next activity.
Restart folder.

Continue to next activity.
Progress alert.

Continue to next activity.
Cycle and then continue to next 
activity.

Continue to next activity.
Cycle and then restart folder.

Continue to next activity.
Cycle and then progress alert.

Exit.
Continue to next activity.

Exit.
Restart folder.

Exit.
Progress alert.

Exit.
Cycle and then continue to next 
activity.

Exit.
Cycle and then restart folder.

Exit.
Cycle and then progress alert.

Continue or exit.
Cycle to the same activity and 
then continue.

Continue or exit.
Cycle to the same activity and 
then restart folder.

Continue or exit.
Cycle to the same activity and 
then progress alert.

Icon Name If student meets mastery score If student does not meet mastery score

Decision point #1
Mastery: Exit folder.
Non‐mastery: Continue 
to next activity.

Decision point #2
Mastery: Continue to 
next activity.
Non‐mastery: Cycle to 
target and then continue 
to next activity.

Target
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The following diagram illustrates how the decision points in the preceding example guide the student’s activities. 

Rules for Decision Points

BEST PRACTICE    Consider carefully the number and placement of decision points—use 
decision points only with an assignment’s key skills and standards. Avoid overusing 
decision points in a single assignment, so that students are able to make progress with 
the assignment. 

• Because a progress alert stops a student from working on the assignment, ensure that you are available to 
respond if students are working on assignments with progress alerts.

• Ensure that students do not have access to the progress alert password.

• When you select the target for a decision point, note that the dropdown list for the cycle is in reverse order, 
with the same activity at the top of the list and the first available activity at the end of the list.

• When you select the target for a decision point, note that you are unable to return to an activity that already 
has a decision point.

• When you select the target for a decision point, note that you are unable to return to an activity that precedes 
an activity with a decision point. Intervening decision points are not permitted. 

Quiz 1: 
Order of Operations

Reteach:
Order of Operations

FOLDER

Exit or Continue:

Target for 
Decision Point #2

Did the student reach the mastery score?

If there is another folder 
in the assignment, the 
student may work on 
activities in it.

Yes: Stop work and exit the folder. The student 
may start work in another folder, if available.

No: Continue to the next activity.

Decision
Point #1

FOLDER

Yes: Continue to the next activity. Because this is the last activity in the 
folder, the student may start an activity in another folder, if available.

Show Me: Order of 
Operations

Let Me Try: Order of 
Operations

Quiz 2:
Order of Operations

Let Me Practice: 
Order of Operations

Did the student reach the mastery score?Continue or Cycle Once and Continue:
No: If this is first time the student has taken the quiz, 
return to the target. Repeat the cycle once and then 
continue to the next activity, if available.

Decision
Point #2
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• If you remove an activity that is the target of a decision point, Odyssey automatically redefines the decision 
point without a target. For example, if a decision point is defined as Next activity & Cycle and then continue, 
and you remove the target, the decision point is redefined as Next activity & Continue.

• Decision points take precedence over suppression. That is, if a student’s performance results in an activity 
being suppressed (and marked as complete), but a decision point results in a student being presented with the 
activity, the student will see the suppressed activity.

Adding a Decision Point to an Activity

1 In the navigation bar, select Assignments>Assignment Builder.

2 Select activities to include in the assignment and click Add Selected Tasks. For details, Task 1: Select 
Curriculum and Activities on page 43.

3 From the Assignment tab in Assignment Builder, select the desired assignment folder in the grid. To locate 
the activity, you may need to open one or multiple folders displayed in the tree. 

4 Set the folder Order to Sequential or Auto‐Launch.

5 Select the desired scored activity and click Add Decision Point.

6 From the Decision Point Options dialog box, specify the mastery score or accept the default score of 70.

7 Select mastery options: Continue to Next Activity or Exit Folder.

8 To allow the student to repeat an activity, check Cycle; select the beginning activity; and specify the number 
of times the student will repeat the cycle, remembering that the maximum number is 4.

9 Select non‐mastery options: Continue or Progress Alert.

10 When finished, click Save Decision Point.

11 To add another decision point to a different activity, repeat steps 2–7, remembering that you cannot add a 
decision point before an existing decision point.

12 Complete changes to the assignment. See Task 3: Finalize the Assignment on page 53.

Editing a Decision Point

Many learning paths provided by Odyssey include decision points on scored activities. Before making the 
assignment, ensure that you preview the assignment and evaluate any decision points. You are able to edit a 
copy of any assignment, including any decision points that may be applied to a scored activity.

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment and click Edit.

5 With the Assignment Properties page displayed, click Edit Tasks.

6 You are prompted to apply your edits to all or selected students. Click All Students or Selected Students.

CAUTION    Checking All Students updates the in‐progress assignment. Checking Selected 
Students creates a copy of the assignment for you to assign to students you select.
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7 Locate the activity with the decision point. To locate the activity, you may need to open one or multiple 
folders displayed in the tree.

8 With the desired activity displayed, click the decision point icon on the right.

9 With the Decision Point Options dialog box open, make your changes.

10 When finished, click Save Decision Point and then Complete Assignment.

11 At the confirmation prompt, click OK.

Deleting a Decision Point

1 In the navigation bar, select Assignments>Assignment Archive.

2 Under Assignment Search, select the search criteria for locating the assignment—Availability, Subject, 
Grade, Status. To refine your search, use a keyword or enter the author’s name.

3 Click Search.

4 Select the desired assignment and click Edit.

5 With the Assignment Properties page displayed, click Edit Tasks.

6 You are prompted to apply your edits to all or selected students. Click All Students or Selected Students.

7 Locate the activity with the decision point. To locate the activity, you may need to open one or multiple 
folders displayed in the tree.

8 With the desired activity displayed, click the decision point icon.

9 With the Decision Point Options dialog box open, click Delete Decision Point and then Complete 
Assignment.

10 At the confirmation prompt, click OK.

Unlocking a Progress Alert at the Student Workstation

The following example shows a progress alert displayed on the student’s screen:
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To unlock the progress alert, complete these steps:

1 At the student workstation: From the student’s lesson screen, click Unlock.

The Unlock Progress Alert dialog box is displayed.

2 Enter the account password.

NOTE    When Odyssey is initially installed, the password to unlock a progress alert is 
unlock99. If you are unable to unlock the progress alert with this password, check with 
your district or school administrator. 

3 Select an option—Continue, Restart Folder, or Exit Folder.

4 To display student performance for the assignment, click View Student Progress.

5 When finished, click OK.

Unlocking a Progress Alert through Assignment Status

1 Log into Odyssey with your teacher user name and password.

2 In the navigation bar, select Assignments>Assignment Status and click Student.

3 Select the desired search filters—Class, Grade, Name Keyword, Student Attributes—and click Search.

4 Select the desired student (radio button below Select) and click View Status.

The Status screen displays assignments for the selected student.
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5 Click the Progress Alert icon for the desired assignment.

The Unlock Progress Alert dialog box is displayed. 

6 Select an option—Continue, Exit Folder, or Restart Folder.

7 To display student performance for the assignment, click View Student Progress. To display the Assignment 
View, click the assignment title.

8 To respond to additional, if any, unaddressed progress alerts, click Next.

9 When finished, click Save.

Suppression

Activity suppression is an assignment option that controls the activities assigned to a student. With Suppress 
Duplicate Activities set to Yes, Odyssey ensures that students are not required to complete the same activity 
multiple times in an assignment. 

For example, if a student passes a scored activity or completes a non‐scored activity, all duplicates of the activity 
within the same assignment are marked as complete. If a student does not pass a scored activity, the student will 
do the activity again when the activity comes up again in the assignment.

NOTE    Activity suppression applies to learning activities, chapter tests, and quizzes—
non‐scored activities are always suppressed after the student has completed the activity 
one time. By default, Odyssey suppresses duplicate activities.

Changes to an assignment’s suppression setting after the assignment has been assigned will not affect activities 
that have already been completed. That is, if an assignment’s configuration is set to suppress duplicate activities 
after the student has completed objectives, any completed objectives the student did not master will not be 
suppressed.
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Class Progress
Class Progress

For Teachers

Class Progress contains detailed information and an overview of assignment status for a class. Teachers can view 
the status of their class assignments, see how the entire class is doing, or view the status for an individual 
student. You can view scores and completion dates, preview learning activities, and open quizzes and tests to 
view specific responses. In the following example, Sandy Pasch’s Pasch Math 6.3 class has three assignments, 
none of which are completed by the entire class. Emma Brode and Nicholas Ralfs have completed the Probability 
Pre‐Test, and Lucy Brode has not yet started the assignment.

Depending on the assignment type, you can view the following information:

Assignment Type Click Name to: Click Score to:

Learning Activity Preview the activity. Not applicable. 

Lesson Quiz Display the answer key. Display student answers.

Chapter Test Display the answer key. Display student answers.

Objective‐based Test Preview the test. Open the objective‐based test summary.

Odyssey Writer Project Display the teacher instruction/prompt 
window.

Display the student workpad and teacher 
comments (when available).

Clicking Details displays more 
information in the bottom grid.

With the class selected, the 
grids display information for 
the entire class.

Clicking the assignment name 
displays details about the 
assignment.

Clicking the objective‐based test 
name lets you preview the test.

Clicking the 
score displays 
the objective‐
based test 
summary.
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Class Progress
Viewing Class Progress for an Assignment

1 In the navigation bar, select Assignments>Class Progress.

2 To view assignments assigned to students in a class, click the desired class in the tree.

The Class Assignments grid displays class assignments, along with status, assignment name, and assigned 
and created date for each assignment. The Status column shows whether an assignment has been completed 
by all of the students who received the assignment.

The following example displays assignments for one of Sandy Pasch’s sixth grade classes. The Status column 
shows that the class as a whole has not completed any of the assignments.

3 To display progress by student for an assignment, click the Details link for the desired assignment. 

In the following example, Emma Brode and Nicholas Ralfs have completed the Probability Pre‐Test, and Lucy 
Brode has not yet started the assignment.

4 To print Class Assignments or the Assignment Detail, click Printable Version for the desired grid.

5 From the new window, click Print. 
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Online Assignment Status
Viewing Student Progress

1 In the navigation bar, select Assignments>Class Progress.

2 To view assignment details for an individual student, click the student’s name from the tree.

The Student History grid displays all assignment for the individual student, along with status, assignment 
name, and assigned and created dates.

3 To view details about an assignment for the individual student, click Details for the desired assignment. If a 
student has not started an assignment, Details are unavailable.

The Assignment Detail grid displays the type, task, score and completion date for each completed task.

4 To print the Student History or Assignment Detail, click Printable Version for the desired grid.

5 From the new window, click Print. 

Online Assignment Status

For Teachers and Administrators

Use the online Assignment Status to view a list of all assignments, organized by assignment or by student. 

NOTE    Online Assignment Status presents a different status view than the Assignment 
Status report generated through the Reports module. See Assignment Status on page 
119.
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Online Assignment Status
The following example displays the status of the Explorer Math 6 assignment for the three assigned students.

Viewing Assignment Status by Assignment

1 In the navigation bar, select Assignments>Assignment Status and ensure that the default Assignment radio 
button is selected.

2 Select the desired search filters—Availability, Subject, Grade, Keyword—and click Search.

For each assignment, your search results display the assignment’s order (self‐select, sequential or auto‐
launch), assignment name, subject, level, owner, date created and last modified, and number of students 
assigned. The following example displays assignments in Sandy Pasch’s My Assignments folder.

For teachers only: Clicking Edit 
Assignment launches 
Assignment Builder for a 
teacher to make changes.

The Status column displays icons 
representing not started, started, or 
completed for each assignment.

Selecting one or multiple students 
and clicking Unassign unassigns 
the assignment.

Clicking the assignment name 
displays details about the 
assignment.
CompassLearning® Odyssey User’s Guide



Assignments 73
Online Assignment Status
3 To view the students who have been assigned the assignment, select the assignment (radio button below 
Select) and click View Status.

The Students Assigned grid displays student names, assignment status, grade, assigned date, and name of 
the teacher.

4 For teachers only: To edit the assignment for all of the students, click Edit Assignment. You are prompted to 
apply your changes to all or selected students, and then Assignment Builder launches. See Task 2: Refine the 
Assignment on page 50.

5 To unassign the assignment, check the desired student or students and click Unassign. At the confirmation 
prompt, click OK.

Viewing Assignment Status by Student

1 In the navigation bar, select Assignments>Assignment Status and click Student.

2 Select the desired search filters—Class, Grade, Name Keyword, student Attributes—and click Search.

For each student, your search results display the student’s user name, grade and number of assignments.

3 To view assignments for a student, select the student (radio button below Select) and click View Status.

The Assignments grid displays the student’s assignment names, status, level, assigned date and the name of 
the assigning teacher. The following example displays the three assignments assigned to Emma Brode. Emma 
has started one assignment.

4 For teachers only: To edit the assignment, check the assignment and click Edit Assignment. You are prompted 
to apply your changes to all or selected students, and then Assignment Builder launches. See Task 2: Refine 
the Assignment on page 50.

5 To unassign one or multiple assignments, check the desired assignment or assignments and click Unassign. At 
the confirmation prompt, click OK.

Clicking the assignment name displays 
details about the assignment.
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5 Assessments
Odyssey assessment solutions assess student performance, diagnose strengths and weaknesses, and prescribe 
specific instruction. They also provide formative assessment strategies, allowing the teacher to monitor progress 
and provide summative feedback to measure growth. State‐specific assessments pinpoint student strengths and 
weaknesses on learning standards and identify prerequisites needed before a student can meet state objectives.

An assessment is a basis for measuring the skill, knowledge, intelligence, capabilities, or aptitudes of a student or 
group. 

An objective‐based test is an assessment that evaluates each objective against the passing score to diagnose a 
student’s strengths and weaknesses. 

Odyssey Manager provides these objective‐based assessment options: 

• Odyssey Explorer is an online assessment tool that delivers standards‐aligned assessments for K‐8 reading/
language arts and math. Explorer diagnoses and provides immediate feedback on student progress toward 
mastery of state and national standards and objectives and then automatically prescribes the appropriate 
learning path containing learning activities for remediation, reinforcement, and enrichment.

When you use the Explorer curriculum to create an assignment, you can choose to include an objective‐based 
test and associated learning path in the assignment. Learning paths identify activities that reinforce the 
objectives in the test. When you assign a learning path in conjunction with an Explorer test, students are 
automatically assigned activities related to the objectives they did not master. If the student masters all of the 
objectives in the test, no activities are included on the student’s launch pad.  

Explorer correlates to the National Assessment of Educational Progress (NAEP) subject frameworks in reading/
language arts and math for grades four and eight. 

• Test Builder allows you to build and customize assessments to align with local, state, and national standards. 
When you create a custom objective‐based test, you can select a standard set and specific objectives to 
include in the test. Odyssey objectives are linked to test items. Additionally, you have the option of 
customizing learning paths built for your custom test. 

Assignment Builder

Assignment

Explorer

Math

Language Arts

Test BuilderStandard Set

Subject/Level Test

Assignment Builder

Assignment
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Custom Objective‐based Tests
• Objective Builder allows you to create custom standard sets, including objectives that you link to test items. 
You can use test items that are already in Odyssey’s Item Bank, or create new test items with Item Builder. A 
custom test item can start out as a copy of an existing test item in the Item Bank.

NOTE    For access to the Assessment module, your school must be licensed for Explorer. 
For access to the Item Bank and Objective Builder, your school must be licensed for 
custom assessment tools.

Custom Objective‐based Tests

Teachers can use Test Builder to create custom objective‐based tests using objectives from CompassLearning 
Explorer, your state, or your own custom district or school objectives.

CAUTION    If you copy an assignment that includes an objective‐based test, and then edit 
the test, your edits are applied to the original objective‐based test. 

Consider the following scenario: the pre‐test mastery score is set to 100%, so that all students are assigned a 
learning path. The mastery score for the post‐test assessment—which is a copy of the pre‐test assessment—is set 
to 70%. Changing the mastery score for the post‐test assessment also changes the mastery score for the pre‐test 
assessment. 

Building a Custom Objective‐based Test

For Teachers

Building a custom objective‐based test includes the following general tasks:

Task 1: Select Objectives below

Task 2: Select Test Properties on page 76

Task 3: Include the Test in an Assignment on page 77

Test Builder

Item Bank

Test

Assignment Builder

Assignment

Objective Builder

Standard Set

Strand

Substrand

Objective

Item Builder

Custom Test 
Items

Odyssey 
Practice Items

School and 
District Items
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Custom Objective‐based Tests
Task 1: Select Objectives

1 In the navigation bar, select Assessment>Test Builder. 

2 From the Select Criteria screen, select a Standard Set.

Based on the standard set you selected, subjects are made available from the Subject dropdown.

NOTE    For district tests, do not use your school’s standard set. 

3 Select a Subject.

Based on the subject you selected, levels are made available from the Level dropdown.

4 Select a Level. 

5 Optional: to further focus your search for objectives, enter a keyword.

6 When finished, click Next. 

The Select Objectives screen displays objectives that match your search criteria. 

7 Check the objectives you want to include in your custom test, noting the following:

If you include in a custom test an objective that cannot be printed, the test cannot be administered offline. 
Objectives that cannot be printed are marked with the following icon:

If you include in a custom test a draft objective, the entire test is marked draft and cannot be assigned. Draft 
objectives are marked with the following icon: 

8 When finished, click Next. 

The Review Selected Objectives and Items screen prompts you to review your selections. To make changes, 
click Back. 

BEST PRACTICE    Each CompassLearning objective represents a minimum of four test 
items. Your custom objectives may differ. To ensure that the test is a manageable length, 
consider building small tests of five to eight objectives.

9 When finished, click Next. 

Test Builder displays the Select Test Properties screen, where you will continue to build the test. See 
Task 2: Select Test Properties below.

Task 2: Select Test Properties

The Select Test Properties screen includes the following options for defining a custom objective‐based test. 

Test property Description

Test name Assigns a test name. This test property is required. 

Message Displays a message for students on the test title page. This test property is optional. 
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Custom Objective‐based Tests
To select the test properties, complete these steps:

1 From the Select Test Properties screen, enter a name for the test.

NOTE    The test name is limited to 46 alphanumeric characters.

2 Optional: enter a message that your students will see on the test title page. The test message is limited to 100 
characters. 

3 Review the defaults, making changes as necessary.

4 When finished, click Next. 

5 From the Confirmation screen, review the test definition. To make changes, click Back. To save the test, click 
Save. 

Assignment Builder launches, displaying your test as part of a new assignment. See Task 3: Include the Test in 
an Assignment below.

Task 3: Include the Test in an Assignment 

With your custom objective‐based test displayed in a new assignment in Assignment Builder, you can complete 
the assignment or make further changes. See these topics in Assignments:

Task 2: Refine the Assignment on page 50.

Task 3: Finalize the Assignment on page 53.

Draft mode Sets the test to Draft mode, so that you may conduct a review before administering the 
test. A Draft test can be viewed, but neither the test nor any assignment that includes 
the test can be assigned.

Multiple Sessions Allows students to return to an unfinished test at a later time. Note that students are 
unable to return to questions already viewed in the previous session. 

Allow Early Turn In Available only when Multiple Sessions is set to Yes. Allows students to turn in the 
objective‐based test before they have viewed all of the test items. Setting Allow Early 
Turn In to No prevents students from accidentally turning in an uncompleted test and 
receiving an unrepresentative score.

Mastery Score Minimum score a student must achieve to master each objective in the test. 

Build Learning Path Creates a learning path to correspond with the objectives in a custom objective‐based 
test. If you want to customize learning paths in the assignment, you must select this 
option.

Navigation Allowed Enables students to navigate sequentially—forward and backward—or non‐sequentially 
through the test. 
NOTE: if Multiple Sessions is set to Yes, and navigation is allowed, students cannot 
return to questions already viewed in a previous session. 

Randomize Items Varies the order of the test items. 
NOTE for Explorer tests: Explorer tests have been developed by testing experts and 
validated in the standard order. It is recommended that you do not randomize the order 
of an Explorer test. 

Minutes Allowed Sets a time limit on students’ testing sessions. The default setting of 0 (zero) specifies 
unlimited time allowed for the test. 
If multiple sessions are allowed, the value defined applies to all test sessions. 

Test property Description
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Test Items
Printing an Assessment for Review

1 With your objective‐based test displayed in Assignment Builder, click the Details link next to the test name. 

A new window displays the test summary. 

2 To open the test in PDF format, click View PDF. 

A new window opens the PDF version of the test. 

3 From the PDF window, print the test, and then click the window’s X button to close the PDF window.

4 From the Test Summary window, click Close. 

Test Items

When you build a custom standard set, you will link objectives to test items from Odyssey’s Item Bank. You can 
choose to include test items that have been created, or you can use Item Builder to create new test items. 

Item Bank below

Item Builder on page 82

Clicking Details opens the test summary.

Clicking View PDF displays 
the PDF version of the test 
to print.
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Test Items
Icons

Item Bank and Objective Builder use a special set of icons. 

Item Bank

Item Bank stores test items you can use to create custom objective‐based tests. The Odyssey Practice Items bank 
contains test items created by CompassLearning. You can use these test items as is, or you can paste a copy of a 
test item into School Items or District Items and make changes to the copied test item. Initially, the School Items 

To open the Assessment Icon Key, click Icon Key.
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Test Items
and District Items banks will not contain test items. These repositories are populated with test items that district 
and school administrators and teachers create. 

NOTE    Teachers must be granted permission to access school and district custom 
assessment features. See User Accounts on page 209.

Browsing Odyssey Test Items

1 In the navigation bar, select Assessment>Item Bank.

2 Click Odyssey Practice Items.

Repository User Description

School Items Teacher
School administrator

Stores test items that are available to teachers and 
administrators at your school.

District Items Teacher
School administrator
District administrator

Stores test items that are available for users at other schools 
in the district.

Odyssey Practice Items Teacher
School administrator
District administrator

Stores test items created by CompassLearning. Use a test 
item as is or copy and change it before using it in a custom 
objective‐based test.

Copy an item 
from Odyssey 
Practice Items 
and paste it into 
the School 
Items bank.

School Items bank

Odyssey Practice 
Items bank

Click to view the 
test item.

Click to edit the 
test item.

Denotes an 
active test item.

Level

Topic

Skill
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Test Items
3 From the subject dropdown, select a subject.

Available levels are displayed for the selected subject.

4 Click the desired level.

Available topics are displayed for the selected level.

5 To view a topic’s skills, click the plus sign next to the topic’s name in the tree.

Available skills are displayed for the selected topic. In the grid to the right, each skill is listed, along with the 
number of associated questions.

6 To view a skill’s questions, click the skill’s name in the tree.

Questions are displayed in the grid.

7 To view a test item, click the icon next to the test item’s title in the grid.

Copying an Odyssey Practice Test Item

1 In the navigation bar, select Assessment>Item Bank.

2 Click Odyssey Practice Items.

3 From the subject dropdown, select the desired subject.

4 Click the desired level.

5 From the tree, click the desired topic.

6 From the tree, click the desired skill.

Questions are displayed in the grid.

7 Check one or multiple questions and then click the Copy button. 

NOTE    To view a test item, click the icon next to the test item’s title in the grid.

8 Click the target item bank—School Items or District Items. 

The target item bank displays the corresponding subject and level. 

9 Click the Paste button. 

The copied test items are pasted into the target item bank. When copied to the school or district bank, you 
can make changes to the test item.

10 Click Save Changes. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 
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Editing a Test Item

NOTE    You are unable to edit test items that are in use—in a test or being edited by 
another Odyssey user.

1 In the navigation bar, select Assessment>Item Bank.

2 Click School Items or District Items.

3 Locate the test item by first selecting the subject and level. 

4 From the tree, click the desired topic and then the skill.

Test items are displayed in the grid.

5 To edit a test item, launch Item Builder by clicking the Edit button for the desired test item. 

See Item Builder below.

Deleting a Test Item

NOTE    You are unable to delete test items that are in use—in a test or being edited by 
another Odyssey user.

1 In the navigation bar, select Assessment>Item Bank.

2 Click School Items or District Items.

3 Locate the test item by first selecting the subject and level. 

4 From the tree, click the desired topic and then the skill.

Test items are displayed in the grid.

5 Check the test item you want to delete and then click the Delete button. 

You are prompted to confirm the deletion.

6 To delete the test item, click OK. 

Item Builder

Item Builder is an Odyssey tool that lets you create custom, multiple‐choice test items to add to a custom 
objective‐based test. Each test item can include images, sound, and equations and present two to four 
distractors, potential answers. 

BEST PRACTICE    If you participated in an implementation planning meeting, use the 
naming conventions developed at this meeting when you name your test items.
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When you first launch Item Builder, you will see the following screen: 

You will use the Equation Editor to create an equation to insert into a test item. 

Lets you add an image, 
sound file, or equation.

Opens the equation 
editor.

Test item title 
that is displayed 
in the Item Bank.

Sets the text alignment 
of the current section 
of the test item.

Adds a box surrounding 
the section. Fixed Size 
adds a scroll bar if the 
section is larger than 
the box.

Specifies how the 
distractors are arranged.

Click View to preview the test item.

Define a minimum of two distractors for 
each test item. Click the radio button of 
the correct answer.

Saves the test item.

If a test includes a 
test item marked 
Draft, the test 
cannot be 
assigned.
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Odyssey saves equations as JPG files and makes them available through the Insert Equation screen. Use this 
screen also to edit and delete equation files. Clicking New launches the Equation Editor. 

Creating a New Test Item

1 In the navigation bar, select Assessment>Item Bank.

2 Click the target item bank—School Items or District Items. 

3 From the subject dropdown, select the desired subject.

4 Click the desired level.

5 From the tree, click the desired topic.

The tree displays skills associated with the topic.

6 From the tree, click the desired skill.

Existing questions, if any, are displayed in the grid.

7 Click the Create new test item button. 

8 Odyssey Manager launches Item Builder, a tool for you to create the new test item.

9 In the Title field, give the test item a name. The test item’s title will be displayed in the Item Bank.

Optional: To provide additional information about the test item, click Properties and enter information in the 
Test Item Properties dialog box. 

10 Starting with Section 1, enter the test question. Your question may include text, graphics, sound, and 
equations. Additionally, the test question may be framed by a box and be a fixed size. If you select Fixed Size 
and the question requires more space than the size of the box, a scroll bar is displayed at the side of the box.

For instructions on including images, sound, and equations, see:

• Inserting an Image into a Test Item below

• Attaching a Sound File to a Test Item on page 86

• Creating an Equation on page 87

Launches Equation Editor to 
build a new equation. 
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• Inserting an Equation into a Test Item on page 88

11 Define a minimum of two distractors, and select the radio button of the correct answer.

12 To preview the test item. click View. If necessary, make changes.

BEST PRACTICE    Preview the test item before making the item available.

13 When finished, click Save.

14 To create another test item, click the New Item button. 

OR

To return to the Item Bank, click the window’s Exit button (X).

15 From Item Bank, click Save Changes. 

NOTE    Tests that use Draft test items cannot be assigned. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 

Inserting an Image into a Test Item

For School Administrators and Teachers

Item Builder supports JPG, GIF, TIF, and BMP images that are 100 KB or smaller. Odyssey converts images to the 
JPG format as part of the upload process. 

1 Open the test item in Item Builder. 

2 Click the Insert graphic toolbar button. 

The Insert Image dialog box is displayed. Available images, if any, are listed.

3 Click Upload.

The Upload Image dialog box is displayed.

4 Browse to the desired image file, and from the Windows File Upload dialog box, click Open. 

The path and file name are displayed in the Upload Image dialog box. 

5 Click Upload. 

You are prompted to refresh the list of images. 

6 Click OK and from the Insert Image dialog box, click Refresh. 

7 Click the name of the desired image, and then Insert. 

The Item Builder screen displays the test item. Notice that your cursor is an image icon.

8 Position your cursor in the desired test item section and click. 
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9 To preview the image, click the image icon. You can resize the image in this screen. 

10 To preview the image in the test item, click View. 

NOTE    If you place text and images on the same line, ensure that a space precedes and 
follows the image. When editing test items with images, save often.

11 When finished, click Save and X (Exit).

12 From Item Bank, click Save Changes. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 

Removing an Image from a Test Item

1 Open the test item in Item Builder. 

2 Position your cursor to the immediate right of the image icon and then backspace to delete the image.

Attaching a Sound File to a Test Item

For School Administrators and Teachers

Item Builder supports .swf and .mp3 files that are 100 KB or smaller. 

1 Open the test item in Item Builder. 

2 Click the Insert Sound File toolbar button. 

The Attach Sound File dialog box is displayed. Available sound files, if any, are listed.

3 Click Upload.

The Upload Sound File dialog box is displayed.

4 Browse to the desired sound file, and from the Windows File Upload dialog box, click Open. 

The path and file name are displayed in the Upload Sound File dialog box. 

5 Click Upload. 

You are prompted to refresh the list of sound files. 

6 Click OK. 

The Attach Sound File dialog box is displayed.

7 To play the sound file, in the Uploaded Sound Files box, select the file name and then click Play. (Ensure that 
you click the Play button located to the right of the Uploaded Sound Files box.)

8 To attach the sound file to the test item, select the file name and then click Attach. 

9 The sound file name is displayed under Attached Sound. 

10 To return to Item Builder, click OK.

The Item Builder screen displays Sound: Attached. 
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11 To preview the test item, including the sound file, click View. 

12 When finished, click Save and X (Exit).

13 From Item Bank, click Save Changes. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 

Removing a Sound File from a Test Item

1 Open the test item in Item Builder. 

2 Click the Insert Sound File toolbar button. 

The Attach Sound File dialog box is displayed. If the test item includes a sound file, the file name is listed in 
the Attached Sound box. 

3 Click Detach and then OK. 

The Item Builder screen displays Sound: None. 

4 When finished, click Save and X (Exit).

5 From Item Bank, click Save Changes. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 

Creating an Equation

1 In Item Builder, open the test item. 

2 Click the Equation Editor toolbar button. 

The Equation Editor is displayed. 

3 Using symbols from the symbol catalog and keyboard letters, numerals, and symbols, build your equation.

4 When finished, click Save. 

The Save dialog box prompts you for a name.

5 Type a name for the equation and then OK. 

6 With the Saving Equation dialog box displayed, click OK. 

The Insert Equation dialog box is displayed. 
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7 To insert the newly created equation into the test item, click Insert.

OR

Click Cancel.

NOTE    Saved equations are available to insert in more than one test item.

The Item Builder screen displays the test item.

8 If you chose to insert the equation, notice that your cursor is an image icon. Position your cursor in the 
desired test item section and then click. 

9 To preview the equation, click the image icon. You can resize the image in this screen. 

10 To preview the equation in the test item, click View. 

NOTE    If you place text and images, including equations, on the same line, ensure that a 
space precedes and follows the equation. When editing test items with equations, save 
often.

11 When finished, click Save and X (Exit).

12 From Item Bank, click Save Changes. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 

Inserting an Equation into a Test Item

For School Administrators and Teachers

1 In Item Builder, open the test item. 

2 Click the Insert Equation toolbar button. 

The Insert Equation dialog box lists available equations. 

3 Select the desired equation file and then Insert.

The Item Builder screen displays the test item.

4 If you chose to insert the equation, notice that your cursor is an image icon. Position your cursor in the 
desired test item section and then click. 

5 To preview the equation, click the image icon. You can resize the image in this screen. 

6 To preview the equation in the test item, click View. 

NOTE    If you place text and images, including equations, on the same line, ensure that a 
space precedes and follows the equation. When editing test items with equations, save 
often.

7 When finished, click Save and X (Exit).
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8 From Item Bank, click Save Changes. 

CAUTION    Remember to save your changes. Closing Item Bank without saving changes 
locks that area of the Item Bank to all other users. 

Editing an Equation

1 Open the test item in Item Builder. 

2 Position your cursor over the equation icon and click.

The equation is displayed in a new window.

3 Click Equation Editor.

Equation Editor launches.

4 Make changes to the equation and when finished, save the equation file.

Removing an Equation from a Test Item

1 Open the test item in Item Builder. 

2 Position your cursor to the immediate right of the equation icon and then backspace to delete the equation.

Objectives

An objective is a measurable educational task that students should be able to complete after having received 
instruction. Objectives belong to standard sets that include three levels of hierarchy—strand, substrand, and 
objective.

With Odyssey’s Objective Builder you can create custom standard sets, including strands, substrands, and 
objectives.

• A strand is a high‐level goal. Examples are Reading Analysis and Reading Comprehension.

• A substrand is a more detailed version of the high‐level goal. A Reading Analysis strand might include two 
substrands: Informational Texts and Poetry. 

• An objective in the Informational Texts and Poetry substrands might be Analyze word choice.

The standard set fits together as follows:

Strand: Reading Analysis

Substrand: Informational Texts

Substrand: Poetry

Objective: Analyze word choice

Objective: Analyze word choice
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The following screen displays the standard set for Level 5 English Language Arts in Nevada. Notice that the 
Objective Builder window is divided into two panes. With the level and subject highlighted in the upper pane, the 
strands are listed in the lower pane and available to copy. 

Similarly, with the strand highlighted in the upper pane, the substrands are listed in the lower pane and available 
to copy. 

Level and subject in 
the standard set. 

Strand.

Substrand.

Strands in the Level 5 English Language Arts 
standard set are displayed in the lower pane. 
To copy a strand, check it and then click Copy. 
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With the substrand highlighted in the upper pane, the objectives for that substrand are listed in the lower pane 
and available to copy. 

State standards are available to copy but cannot be edited. To customize a state standard, first copy a strand, 
substrand, and accompanying objectives into the school or district standards bank. The following screen displays 
the School Standards set that includes standards that have been copied from the State Standards set. Notice 
that the editing buttons are visible for the items in the lower pane. 

Click Edit to change the name or set the 
standard set to Active or Inactive. 

Edit buttons for the contents of the 
lower pane. The Paste button is 
unavailable because nothing has 
been copied.

Objectives can 
be reordered by 
changing the value 
and then clicking 
Update. 

Draft objective. 

Active objective. 

Click to edit the objective.

Locked and 
active objective. 
CompassLearning® Odyssey User’s Guide



Assessments 92
Objectives
Linking test items to an objective is the last step in creating a custom standard set. The following screen displays 
four test items linked to Objective 1.5.5.b. 

Naming Conventions for Standard Sets

BEST PRACTICE    If you participated in an implementation planning meeting, use the 
naming conventions developed at this meeting when you name strands, substrands, and 
objectives in your standard set.

Numbering strands and substrands and adding a subject code to the objective are recommended. You can use a 
similar format to your state standards or develop a new convention based on custom district curriculum. 
Consider using the following format to name an objective:

Subject.Grade Level_Strand.substrand code.objective number_ Shortened Objective

Using this naming convention, the standard set is written as follows: 

Click to preview the test item.

Test items can 
be reordered by 
changing the value 
and then clicking 
Update. 

Strand: 1 Reading Analysis

Substrand: 1.1 Informational Texts

Substrand: 1.2 Poetry

Objective: RLA.7_1.1.01_Analyze word choice

Objective: RLA.7_1.2.01_Analyze word choice
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Custom Standard Sets

NOTE    To share a test across the district, you must use objectives from the district 
standard set.

Copying a Strand

1 In the navigation bar, select Assessment>Objective Builder.

2 To copy standards from the state, click the State Standards bank. 

3 From the subject dropdown, select the desired subject.

4 Click the desired level.

Objective Builder displays available strands.

5 With the level and subject highlighted in the upper pane and the strands displayed in the lower pane, check 
one or multiple strands that you want to copy.

6 Click the Copy button. 

7 Click the target standards bank—School Standards or District Standards. 

The standard set for the selected bank displays available strands, if any.

8 Click the Paste button. 

The strand and its associated substrands and objectives are pasted into the target standards bank and are 
available to edit.

9 When finished, click Save Changes. 

CAUTION    Remember to save your changes. Closing Objective Builder without saving 
changes locks that area of Objective Builder to all other users. 

Creating a Strand

1 In the navigation bar, select Assessment>Objective Builder.

2 Click the target standards bank—School Standards or District Standards. 

3 From the subject dropdown, select the desired subject.

4 Click the desired level.

Objective Builder displays available strands, if any.
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5 To create a new strand, click the Create a new strand button. 

The New Strand dialog box prompts you for a title.

6 Enter a title and then Save. 

The new strand is displayed in the standards bank for the selected level and subject. 

7 When finished, click Save Changes. 

CAUTION    Remember to save your changes. Closing Objective Builder without saving 
changes locks that area of Objective Builder to all other users. 

Creating a Substrand

1 In the navigation bar, select Assessment>Objective Builder.

2 Click the target standards bank—School Standards or District Standards. 

3 From the subject dropdown, select the desired subject.

4 Click the desired level.

Objective Builder displays available strands.

5 Click the desired strand. 

Objective Builder displays available substrands, if any.

6 To create a new substrand, click the Create a new substrand button. 

The New Substrand dialog box prompts you for a title.

7 Enter a title and then Save. 

The new substrand is displayed in the standards bank for the selected level, subject, and strand. 

8 When finished, click Save Changes. 

CAUTION    Remember to save your changes. Closing Objective Builder without saving 
changes locks that area of Objective Builder to all other users. 
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Creating an Objective

You will use the New Objective dialog box to create an objective. 

1 In the navigation bar, select Assessment>Objective Builder.

2 Click the target standards bank—School Standards or District Standards. 

3 From the subject dropdown, select the desired subject.

4 Click the desired level.

Objective Builder displays available strands.

5 Click the desired strand and then substrand. 

Objective Builder displays available objectives, if any.

6 To create a new objective, click the Create a new objective button. 

The New Objective dialog box is displayed.

7 Enter a key, title, and description. 

BEST PRACTICE    Define a key when you create an objective. The Test Summary by 
Objective report uses objective keys for displaying class data. To see examples of keys, 
browse the Explorer curriculum set.

8 When finished, click Save. 

The new objective is displayed in the standards bank for the selected substrand. 

9 When finished, click Save Changes. 

CAUTION    Remember to save your changes. Closing Objective Builder without saving 
changes locks that area of Objective Builder to all other users. 

Adding Test Items

1 In the navigation bar, select Assessment>Objective Builder.

2 Click the target standards bank—School Standards or District Standards. 

A locked objective can be viewed and assigned but not edited. 
District and school administrators can lock and unlock 
objectives.

Descriptions are limited to 1,000 characters or fewer (including spaces and punctuation).

If a test includes a draft objective, the test cannot be assigned. 
Turn Draft mode to No before including the objective in a test. 
CompassLearning® Odyssey User’s Guide



Assessments 96
Objectives
3 From the subject dropdown, select the desired subject.

4 Click the desired level.

Available strands are displayed.

5 Click the desired strand, substrand, and objective. 

Linked test items, if any, are displayed in the lower pane.

6 To link one or multiple test items, click the Link Items button. 

The Item Bank opens in a separate window. 

7 Click the desired item bank.

8 From the dropdown, select the desired subject; and select the desired level.

9 From the tree, first select a topic, and next, a skill.

10 With test items displayed in the grid, check the desired items to link to the objective. 

CAUTION    Exercise care if you make changes to test items. Changing a test item makes 
the change globally. That is, if the same test item is linked to more than one objective, the 
test item is changed for all objectives. 

11 When finished, click Add Items. 

The test items are added to the objective in Objective Builder. 

12 To reorder an item, click the up or down arrow and then Update. To preview a test item, click the blue icon to 
the left of the title.

NOTE    To preview a test item, click the icon to the left of the title.

13 When finished, click Save Changes. 

To make your custom standard set available to Test Builder, the standard set must be Active. 

14 From within Objective Builder near the top of the window, click Edit. 

The Edit Standard Set dialog box is displayed. 

15 Set the Status to Active.

16 When finished, click Save. 

CAUTION    Remember to save your changes. Closing Objective Builder without saving 
changes locks that area of Objective Builder to all other users. 
CompassLearning® Odyssey User’s Guide



97
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Odyssey Manager provides a wide variety of reports for teachers and administrators to create detailed and 
summary snapshots of student achievement, both in the classroom and on state‐mandated testing. Options 
include using aggregated and disaggregated data, multi‐school administration data, pre‐test versus post‐test 
comparisons, and individual student progress data.

For all reports, Odyssey offers these report formats: 

• HTML. With Odyssey’s wizard, you will generate a report that is displayed in a browser window—either 
immediately or from the Reporting Queue window. Many reports offer hot links to activities and test scores. 
From all HTML reports, you can generate PDF and CSV files (with the same report data). In the following 
example, the report is displayed in HTML. 

NOTE    Odyssey processes all reports generated by school and district administrators 
offline, making the HTML report available at a later time. When a report is processed 
successfully, you can display the HTML version of the report from the Reporting Queue 
window. See Offline Report Processing on page 103.

Use the 
controls to 
navigate 
the HTML 
report.

Choose to display and print the report in 
PDF format or export the report data into a CSV file.

Learning activity (LA) name and LA 
code link to the learning activity.

Quiz name 
links to the 
answer 
key. 
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Reports by Category
• PDF. If you are required to print the report, the PDF version provides more consistent formatting than printing 
the HTML screens. Additionally, you can easily distribute the PDF version of the report to others in your 
organization. 

• CSV. CSV files are ASCII text files with one record per line and a comma separating the fields. With report data 
exported to a CSV file, you can import and then manipulate the data in Excel, Access, or another data 
warehouse tool.

Reports by Category

The following table summarizes Odyssey reports by category. Access to a specific report depends on your 
Odyssey user role—Teacher, School Administrator, District Administrator, Parent, or Student.

Category Users Report title Description Read more

Administration School 
Administrators
District 
Administrators

Utilization Summarizes student time on activities for a school and for a 
district. Define up to five time intervals to display the number of 
students per duration.

page 106

Teachers
School 
Administrators
District 
Administrators

Attendance Displays the following types of session attendance data for a 
specified date range:
• Completed session times

• Incomplete sessions

• All sessions

• No sessions

• Session times

• Teacher login

• Student login

The attendance reports can help you evaluate how the Odyssey 
system is being used in your classes, schools, and district.

page 108

Duration Displays amount of time each student spends on activities 
within a specified date range. Activities may be part of an 
assignment or completed when the student is navigating 
Odyssey outside of an assignment. Use the duration report to 
analyze how students use Odyssey.

page 113

Enrollment Displays student enrollment information grouped by class or 
grade level. 

page 116

Assignment 
Status

Displays usage and completion status of assignments within 
your district for a specified date range. Use the assignment 
status report to review usage of the Odyssey system.

page 119

Progress Teachers
School 
Administrators
District 
Administrators

Student 
Progress

Displays individual student progress on completed activities 
within a specified date range. Includes summaries by activity 
type or (for teachers) by assignment.

page 125

Progress 
Summary

Displays individual student summaries on completed activities. 
Teachers can also sort by activity type.

page 130

Learning Path 
Status

Displays status of activities in a learning path, including 
information on objectives associated with each activity. View 
details by student for individual objectives or a summary of the 
entire learning path.

page 134
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 Assessment Teachers
School 
Administrators
District 
Administrators

Objective‐
based Test 
Results

Displays student performance and progress on objective‐based 
tests. Generate the report by test or objective. View results in 
data or graphical format.

page 138

Test Item 
Summary

Summarizes number and percentage of student responses by 
item in a specified objective‐based test.

page 144

Test Summary 
by Objective

Summarizes student performance on objective‐based tests by 
objective.

page 147

School 
Administrators
District 
Administrators

Objective Score Summarizes class or school performance on a specified objective 
for a specified date range.

page 150

Test Translator Teachers
School 
Administrators
District 
Administrators

Goal‐based Test 
Results

Displays student, class, or school performance by objective on a 
specified external test.

page 153

Test Summary 
by Goal

Summarizes student or class results by goal on a specified test 
administered externally.

page 156

Goal Score Displays number—by external goal—of students tested in each 
class or grade level.

page 158

Test Translator 
Import Log

Summarizes the import results of goal‐based tests administered 
externally.

page 161

Longitudinal 
Goal Score 
Analysis

Displays student performance over time on goal‐based tests 
administered externally.

page 164

NWEA Learning 
Path Status

Displays status of activities in a learning path, including 
information on objectives associated with each activity. View 
details for individual objectives or a summary of the entire 
learning path.

page 168

State Learning 
Path Status

Displays status of activities in a learning path, including 
information on objectives associated with each activity. View 
details for individual objectives or a summary of the entire 
learning path.

page 170

Odyssey Writer Teachers
School 
Administrators
District 
Administrators

Student 
Writing 
Portfolio

Displays Odyssey Writer project evaluations for one or multiple 
projects by one or multiple students.

page 172

Writing 
Summary

Displays Odyssey Writer project evaluations for a single project 
by one or multiple students.

page 175

Resources Teachers
School 
Administrators
District 
Administrators

Curriculum Displays relationships among chapters, lessons, and learning 
activities for a specified subject and grade level.

page 178

State 
Correlation

Displays learning activities and quizzes grouped by strand for a 
specified state, subject, and level.

page 182

Student 
Portfolio

Parents Attendance Displays how often and for how long the student has worked in 
the system.

page 22

Duration For a specified time period, displays activities completed by the 
student. Also displays time the student spent on each activity.

page 23

Parents
Students

Student Score For a specified time period, displays activities completed by the 
student. Also displays time the student spent on each activity 
and the student’s score.

page 24

Category Users Report title Description Read more
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Reports by Education Strategy

Odyssey reports list and summarize a wide variety of student information. Options available within each report 
allow educators to tailor data presentation to address specific issues and education strategies. 

The following table lists Odyssey reports by education strategy. 

Issue Guiding question Reports

Student motivation How do I encourage and 
empower individual students?

• Learning Path Status on page 134

• Student Progress on page 125

• Objective‐based Test Results on page 138

• Student Writing Portfolio on page 172

Parent motivation How do I show student 
progress at and between 
parent‐teacher conferences?

• Learning Path Status on page 134

• Progress Summary on page 130

• Objective‐based Test Results on page 138

• Reports—Parent View on page 21

• Student Writing Portfolio on page 172

Community presentations How do I share school success 
stories with the school board 
and other community 
members?

• Progress Summary on page 130

• Attendance on page 108 
(options to report on number of student, parent, and 
teacher logins)

• Objective‐based Test Results on page 138

• Objective Score on page 150

• Writing Summary on page 175

• Utilization on page 106

Implementation review How do I know Odyssey is 
being fully utilized?

• Utilization on page 106

• Attendance on page 108 
(options to report on number of student, parent, and 
teacher logins)

• Assignment Status on page 119

• Progress Summary on page 130

• Test Item Summary on page 144

• Enrollment on page 116

Monitoring student 
achievement

How do I analyze student 
performance?

• Duration on page 113

• Student Progress on page 125

• Learning Path Status on page 134

• Objective‐based Test Results on page 138

• Test Summary by Objective on page 147

• Student Writing Portfolio on page 172

• Writing Summary on page 175

Standardized test 
preparation

How do I efficiently prepare 
each student and entire 
student populations for 
successful performance on 
standardized tests?

• Objective‐based Test Results on page 138

• Learning Path Status on page 134

• Test Summary by Objective on page 147

• Student Writing Portfolio on page 172

• Writing Summary on page 175
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The No Child Left Behind (NCLB) Act dramatically changed the landscape of education. Increased accountability, 
more rigorous assessment, demand for high quality educators, and mandates for research‐based practices send 
this message to the nation's educators: every child in the United States should and will be given the same 
opportunities to learn and achieve.

Odyssey report capabilities address the NCLB requirements for accountability in two ways: showing progress 
throughout the year and disaggregation of data.

Adequate yearly progress (AYP) is a statewide accountability system mandated by the NCLB Act. An individual 
state’s AYP measures progress toward a goal of 100 percent of students achieving state academic standards in a 
minimum of reading/language arts and math.

The Student Progress, Learning Path Status, and Objective‐based Test Results reports all demonstrate student 
progress throughout the year and can gather this information for the teacher, principal, or district administrator.

Disaggregation of data is available when student 
records are defined according to individual 
subgroups, such as race/ethnicity, gender, 
economic status, special educational services, 
disability, or a combination of these. Odyssey 
reports can be run for these individual subgroups 
to help educators address critical aspects of the 
NCLB legislation and verify that their students are 
on the path to achievement.

Student attributes may be defined in a dialog box 
(at right) available when you create a new student 
record or update an existing student’s record. See 
Student Records on page 27. 

District Reports Administrator User

The district reports administrator generates district‐wide reports and has access only to the Reports module. By 
default, a site is set up without a district reports administrator; this user type must be created by 

Student population 
performance

How do I analyze student 
performance by groups?

• Student Progress on page 125

• Objective‐based Test Results on page 138

• Test Summary by Objective on page 147

• Objective Score on page 150

• Writing Summary on page 175

No Child Left Behind How do I show adequate 
yearly progress or 
accountability for NCLB 
requirements?

• Progress Summary on page 130

• Objective‐based Test Results on page 138

• Objective Score on page 150

• Student Writing Portfolio on page 172

• Attendance  on page 108
(options to report on number of student, parent, and 
teacher logins)

Issue Guiding question Reports
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CompassLearning. To create a district reports administrator for your site, contact CompassLearning Customer 
Support. The district reports administrator has access to the same reports as the district administrator.

NOTE    A district must have at least one district administrator with full access. 

At login, the district reports administrator sees the Reports home page; all reports that are available to that 
district are displayed.

NOTE    A district may have multiple district administrator and district reports 
administrators; a school may have only one school administrator. All administrator user 
accounts are created by CompassLearning. To create a new administrator account, 
contact Customer Support. For enterprise sites: reactivation is required after the 
administrator account is created.

Best Practices and Tips

• After using the system for a semester, determine which reports are being used the most and then save these 
report settings to reuse during the next semester.

• When saving report settings, predetermined naming conventions allow users to locate a specific report 
quickly. Also, limit the report name to no more than 45 characters. 

• Consider appointing one or two individuals to pull data from the district level and one or two to pull data from 
each school. Be aware of the data set on which you are reporting. Including or not including transferred 
students can change results dramatically.
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• Printing from PDF: When printing PDF reports, ensure that your printer driver is available and enabled. Issues 
with printer drivers may prevent graphics from printing correctly.

Offline Report Processing

Odyssey processes all reports generated by school and district administrators offline so that large amounts of 
data may be processed without tying up system resources. When you generate a report that Odyssey will process 
offline, you will see this message in the Confirmation screen of the report wizard:

Report will be processed offline (delayed).

NOTE    To receive an email after Odyssey generates the report, check the Email box. 

Reports that have been generated offline are available from the Reporting Queue window. Open the Reporting 
Queue window from the report’s welcome screen: Reports>Report Category>Report Name and click Show 
Queue. 

The Reporting Queue window lists all reports—starting with the most recently generated report—that Odyssey 
has generated or attempted to generate in the past 30 days. Online reports generated by teachers are not listed 
in the Reporting Queue window. 

A report’s status may be one of the following:

• Queued. The report data is in the queue to be processed.

• In Progress. Odyssey is processing the report data.
CompassLearning® Odyssey User’s Guide



Reports 104
Managing Report Settings
• Completed. The report is successfully generated and available to View Online, View as PDF, or Export as CSV. 
Reports that have been processed offline successfully are available for ten days. After ten days, a report is 
deleted from the Odyssey server. 

• Expired. The report was generated within the past 30 days but over ten days ago. Expired reports are 
unavailable for viewing or downloading. 

• Completed*. Odyssey was unable to generate the report successfully. Click the Completed* link to display 
more information. If you see this status message, try generating the report when fewer users are on the 
system. 

• Failed. Odyssey was unable to generate the report. Click the Failed link to display more information. If you see 
this status message, contact Customer Support. 

Displaying a Previously Generated Report

1 In the navigation bar, click Reports>Report Category>Report Name. 

2 From the report’s welcome screen, click Show Queue.

The Reporting Queue window displays reports that Odyssey has processed offline.

3 To display a successfully completed report, click an available option:

• View Online displays the online HTML version of the report. 

• View as PDF displays the PDF version of the report, which you can print.

• Export as CSV sends the report data to a CSV file. 

Managing Report Settings

Using previously saved report settings to generate a new report lets you use the same filters with new student 
data. 

NOTE    When you use saved report settings to generate a new report, you are not 
displaying the same report—you are performing a new query on the data. The resulting 
report may be the same or it may include different data. 

Generating a Report from Saved Report Settings

1 In the navigation bar, click Reports>Report Category>Report Name.

2 From the welcome screen’s Open a saved report dropdown list, select the report settings you want to use to 
generate a new report and then Open. 

3 Click Generate Report.
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Editing Saved Report Settings

1 In the navigation bar, click Reports>Report Category>Report Name.

2 From the welcome screen’s Open a saved report dropdown list, select the report settings you want to edit 
and then Open. 

3 The Confirmation screen displays the report’s original settings. To make changes, click the desired Edit 
button, make your change, and then click Next until you reach the Confirmation screen.

4 To save the report settings with a new name, type a name and then Save Report. 

OR

To overwrite the original report settings, leave the original name unchanged and click Save Report. At the 
confirmation prompt, click OK.

Deleting Saved Report Settings

1 In the navigation bar, click Reports>Report Category>Report Name.

2 From the welcome screen’s Open a saved report dropdown list, select the report settings you want to delete 
and then Open. 

3 From the report’s Confirmation screen, click Delete. At the confirmation prompt, click OK.

District‐Wide Reporting from Multiple Databases

For Enterprise Customers

If your Odyssey system runs on multiple database servers, you may implement district‐wide reporting. 

Consider the following example: each of six elementary schools has an individual Odyssey enterprise server and 
the district administrator wants to aggregate the data. One server can be designated as the main server and used 
as the site from which district reports are run. For more information, contact CompassLearning Customer 
Support.
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Administration Reports

Utilization

For School and District Administrators

The Utilization report summarizes student time on Odyssey activities for a school and for a district, letting school 
and district administrators quantify utilization of the Odyssey system. Define up to five time intervals in minutes 
to display the number of students who have used the system for each duration. 

The following Utilization report displays utilization data for the Riverton Education District: 

Report feature Description

Distribution For each defined interval of time, displays the number of students who have used the 
specified curriculum and activities.

Date range Displays utilization within a date range you specify. 

District summary District administrators: choose to display a district summary only. 

Filters Filter to display data for the following: 
• Students in selected grade levels.

• Students by attribute.

• Activity in selected curriculum and activity types.

Data from previous 
schools

Choose whether to include data from a previous school. Select this option to include data for 
transferred students. 

Report formats Choose from HTML, PDF, and CSV formats.

Use the 
controls to 
navigate the 
online 
report.

Choose to display and print the report in PDF 
format or export the report data into a CSV file.

Total number 
of students 
available for 
report.

Utilization data reported for all activities students performed 
in language arts and math.

Three intervals are defined for this report. Each 
interval displays the number of students who have 
used Odyssey for the defined duration.Total number 

of students 
meeting 
criteria.

Data 
returned for 
this date 
range.
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The Utilization report displays data for individual schools below the summary. 

Generating a Utilization Report 

For School and District Administrators

1 In the navigation bar, click Reports>Administration Reports>Utilization.

2 From the Welcome screen, click Next. 

3 Specify the Start Date and End Date. 

4 Check the grade levels of students to include in the report. 

5 To display one to five distribution intervals, enter a beginning and ending value for each interval. Each 
distribution interval will display the number of students who have used the system for the specified duration. 

6 District administrators only: To display a district summary only, click Yes. 

7 To include data from previous schools, click Yes. 

8 When finished, click Next. 

9 From the Curriculum screen, select one or multiple subjects and one or multiple activity types and then Next. 

10 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

11 Check the district or school to include in the report, opening a tree to locate the desired classes, if required.

NOTE    Your user role determines the options available to you. 

12 When finished, click Next.

13 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

14 Optional: To save the report settings, type any name and then Save Report.

15 Click Generate Report.

16 Because school and district administrators generate the Utilization report, Odyssey will send the report to be 
processed offline. 

You will see the following message:

Report has been queued for offline processing. 

17 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 
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18 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

NOTE    By default, all reports generated by school and district administrators are 
processed offline. If Odyssey generates the HTML report immediately, you will see the 
report displayed in your browser. To view and then print the report in PDF format, click 
View as PDF. To export the data to a CSV file, click Export as CSV.

Attendance

Use the Attendance report to measure session attendance in multiple ways, helping you evaluate how the 
Odyssey system is being used in your classes. 

Report feature Description

Student session times Completed Session Times. Lists, by student, total number of logins and total session time 
(in hh:mm:ss format) for all completed sessions. A completed session is a successful login 
that is followed by a successful logout.
Session Times. Lists, by student, time of login (your local time) and total session time (in 
hh:mm:ss format). 

Login data for students, 
parents, and teachers

Incomplete Sessions. Lists, by student, the number of successful logins without a 
successful logout.
All Sessions. Lists, by student, the total number of logins.
No Sessions. Lists students who have not logged into the system.
Parent Login. Lists, by parent, the number of successful logins and total session time (in 
hh:mm:ss format). 
Teacher Login. Lists, by teacher, the number of successful logins and total session time (in 
hh:mm:ss format). 

Date range Define a date range to measure.

Filters Depending on your user role, displays data by school, class, student, and student 
attribute:
• District administrators can select the district or one or multiple schools and classes. 

• School administrators can select the school or one or multiple classes. 

• Teachers can select their own classes and students.

Data from previous 
schools

Choose whether to include data from a previous school. (This option is not available for 
the Teacher Login report.)

Report formats Choose from HTML, PDF, and CSV formats.
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Attendance Report: Session Times and Completed Session Times

The following two Attendance reports display individual session times (for one student) and the grand total for all 
completed session times for eight students. The report type is circled on each example. For instructions, see 
Generating an Attendance Report on page 111.  

Student’s user name for logging into Odyssey.

Session start time is local time.

The entire 
report is 
displayed 
on one 
online 
page.

Choose to display and print the report in PDF format or export 
the report data into a CSV file.
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Attendance Report: Login Data for Students

The following three Attendance reports display login data for students—total number of logins, by student, for all 
sessions, no sessions, and incomplete sessions. The report type is circled on each example. For instructions, see 
Generating an Attendance Report on page 111.  
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Attendance Report: Login Data for Parents and Teachers

The following Attendance reports display total number of logins and total time for parents and teachers. The 
report type is circled on each example. For instructions, see Generating an Attendance Report below.  

Generating an Attendance Report

1 In the navigation bar, click Reports>Administration Reports>Attendance.

2 From the Welcome screen, click Next. 

3 Select a report type—Completed Session Times, Incomplete Sessions, All Sessions, No Sessions, Session 
Times, Parent Login or Teacher Login—and click Next. 

Parent’s user name for logging into Odyssey.

Teacher’s user name for logging into Odyssey.

Report generated 
by teacher

Report generated by 
district administrator
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4 Specify the Start Date and End Date and whether to include data from previous schools. (Including data from 
previous schools is not an option for the Teacher Login report.) When finished, click Next.

5 Optional: From the Users screen, to more narrowly define your report, check the desired student attributes 
and click Apply Filter. Check the district, school, class or students to include in the report, opening a tree to 
locate the desired classes, if required. 

NOTE    Your user role determines which selections are available.

6 When finished, click Next.

7 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

8 Optional: To save the report settings, type any name and then Save Report.

9 Click Generate Report.

10 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

11 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

12 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Duration

Use the Duration report to learn how long each student spends on individual activities, including learning 
activities, lesson quizzes and chapter tests, objective‐based tests, and Odyssey Writer projects. 

NOTE    The Duration report does not provide data on time spent on authentic tasks.

Report feature Description

Subject (or Curriculum) Limits report to the subject you specify or all subjects. The report is separated by 
student and then organized by subject and level.

Date range Limits report to a date range you specify. 

Filters Depending on your user role, displays data by school, class, student, and student 
attribute:
• District administrators can select the district or one or multiple schools and 
classes. 

• School administrators can select the school or one or multiple classes. 

• Teachers can select their own classes and students.

Data from previous schools Includes data from previous schools.

Learning activities and answer 
keys

A learning activity’s name links to the activity. Test and quiz names link to their 
respective answer keys. Odyssey Writer project names link to the project.

Completions Displays the number of times the activity was started and successfully completed.

Total times Displays total time each student spent on the activity, lesson, and chapter.

Report formats Choose from HTML, PDF, and CSV formats.
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The following sample Duration report displays student activity on individual assignment activities, including 
learning activities, lesson quizzes, and chapter tests. 

Generating a Duration Report

1 In the navigation bar, click Reports>Administration Reports>Duration.

2 From the Welcome screen, click Next. 

3 From the Subject dropdown, select a subject. Then, specify the Start Date and End Date and whether to 
include data from previous schools. When finished, click Next.

4 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

5 Check the district, school, class or students to include in the report, opening a tree to locate the desired 
classes, if required. 

NOTE    Your user role determines which selections are available.

6 When finished, click Next.

7 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

8 Optional: To save the report settings, type any name and then Save Report.

Use the 
controls to 
navigate 
the online 
report.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Display one student per page.

Learning 
activity (LA) 
name and LA 
code link to 
the learning 
activity.

Student’s 
user name for 
logging into 
Odyssey.

Total amount of time (in hh:mm:ss format) the student 
has spent on the activity. This value is updated with the 
latest time if the student completes the activity again.

Total amount of time the student has 
spent on the chapter and lesson (updated 
after each successful completion).

Quiz name 
links to the 
answer key. 
Test names 
(not displayed) 
also link to the 
answer key.

Date and (local) time of the most recent 
successful completion of the activity. 
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9 Click Generate Report.

10 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

11 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

12 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Enrollment

The Enrollment report provides a snapshot of students enrolled in your class, school, and district.

Subjects and levels are displayed in the following format. Depending on your site’s licensing, you may not see all 
of these subjects and levels. 

Report feature Description

Filters Depending on your user role, displays data by class, teacher, school, and student attribute:
• Teachers can display student data for one or all of their classes.

• School administrators can display student data for one teacher or all teachers at a school. 

• District administrators can display student data for one school or all schools in a district.

Student grade level 
and status

School and District Administrators only: Filters by grade level and status—Enrolled, Not 
Enrolled, or Enrolled/Not Enrolled.

Student details Displays one or more details for each student—Student School ID, Parent User Name, 
Student Attributes, Subject Level Access.

Group by class or 
grade

School and District Administrators only: Groups student data by Class or Grade.
NOTE: Teachers can display data for one class or all classes (grouped by class). 

Report formats Choose from HTML, PDF, and CSV formats.

Subject and Level Code Subject and Level Code

Algebra I High School level A1 Macroeconomics High School 
level

ME

Algebra II High School level A2 Matemáticas levels K through 6 SM‐K, SM‐1... SM‐6

Honors Algebra (no level) AL Math levels K through 8 MA‐K, MA‐1, MA‐2... 
MA‐8

Biology High School level B1 Microeconomics High School level MC

Brain Buzzers levels 4 through 8 BB‐4, BB‐5... BB‐8 Physical Science High School level PS

Chemistry CH Physics High School level PH

ELL Elementary (no level), 
assistive language

EE‐[assistive 
language]

PlayBox Theme Time level PreK PB‐P

ELL Secondary ES‐[assistive 
language]

Public Speaking High School level SP

English I High School level E1 Science levels 1 through 8 SC‐1, SC‐2... SC‐8

English II High School level E2 Social Studies levels 2 through 8 SS‐2, SS‐3... SS‐8

English III High School level E3 Thematic Research Projects levels 
4 through 8

TP‐4, TP‐5... TP‐8

English IV High School level  E4 Trigonometry TR

Focus Algebra (no level) FA US Government High School level GV

Focus Math levels K through 8 FM‐K, FM‐1...FM‐8 US History I High School level H1

Geometry High School level GE US History II High School level HS

Language Arts levels K through 8 LA‐K, LA‐1, LA‐
2...LA‐8

World History High School level WH

Language Arts extension LE‐1, LE‐2... LE‐8
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The following example displays an Enrollment report generated by the teacher.

Generating an Enrollment Report

1 In the navigation bar, click Reports>Administration Reports>Enrollment.

2 From the Welcome screen, click Next. 

3 Select the report’s display criteria. 

If you are logged in as a teacher, select one class or all of your classes.

OR

If you are logged in as a school administrator, select one teacher or all of the teachers at your school. Next, 
select a grade or all grades. Finally, select a status—Enrolled, Not Enrolled, or Enrolled/Not Enrolled.

OR

If you are logged in as a district administrator, select one school or all schools in your district. Next, select a 
grade or all grades. Finally, select a status—Enrolled, Not Enrolled, or Enrolled/Not Enrolled.

4 Optional: To more narrowly define your report, check the desired student attributes.

5 When finished, click Next.

6 Optional: Select details to include for each student—Student School ID, Parent User Name, Student 
Attributes, Subject Level Access.

7 For School and District Administrators: Select to group the report by Class or by Grade Level.

Display criteria: available filters depend on the user who 
generates the report.

Teacher’s user name for logging into Odyssey.

Parent’s user name for 
logging into Odyssey.

Details displayed for each student.

Student has 
access to these 
Odyssey subjects.

Student’s 
user name 
for logging 
into Odyssey.

Use the 
controls to 
navigate the 
online 
report.

Choose to display and print the 
report in PDF format or export 
the report data into a CSV file.
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8 When finished, click Next.

9 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

10 Optional: To save the report settings, type any name and then Save Report.

11 Click Generate Report.

12 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

13 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

14 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
CompassLearning® Odyssey User’s Guide



Reports 119
Administration Reports
Assignment Status

An Assignment Status report displays the completion status of assignments for a specified date range. 

NOTE    An assignment must be assigned during the specified date range to be included in 
the report.

You can also use the online Assignments>Assignment Status screen to display assignment information. 
Additionally, teachers can use the Assignment Status screen to unassign or edit assignments. See Online 
Assignment Status on page 71.

By default, all reports generated by school and district administrators are processed offline. If Odyssey generates 
the HTML report immediately, you will see the report displayed in your browser. To view and then print the 
report in PDF format, click View as PDF. To export the data to a CSV file, click Export as CSV.

TIP    If you have created an assignment defined for more than one grade level, ensure 
that your search for assignments for the Assignment Status report includes all relevant 
grade levels. 

Report feature Description

Details Information grouped by assignment. For each assignment, lists each student’s status, date 
assigned, and assigning teacher.
Information grouped by student. For each student, lists assignments, status, date assigned, 
and assigning teacher.

Summaries
Administrators only

Information grouped by assignment 
• School administrators: For each assignment, lists assigning teacher and number of 
students.

• District administrators: For each assignment, lists schools with number of students.

Information grouped by teacher. School administrators: For each teacher, lists assignments 
with number of students (assigned and completed).
Information grouped by school. District administrators: For each school, lists assignments 
with number of students (assigned and completed).

Date range Displays status on assignments assigned within a date range you specify. 

Report formats Choose from HTML, PDF, and CSV formats.
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Assignment Status Report: Details by Assignment

The following Assignment Status report generated by teacher Sandy Pasch displays assignment status by 
assignment. 

Generating an Assignment Status Report: Details by Assignment

1 In the navigation bar, click Reports>Administration Reports>Assignment Status.

2 From the Welcome screen, click Next. 

3 Ensure that Report By is set to Assignment.

4 School and district administrators: Set Display to Details. 

5 Specify the Assigned Start Date and Assigned End Date and click Next.

6 Under Assignment Search, select the search criteria for locating one or multiple assignments and click 
Search.

7 Select the desired assignments and then Next.

8 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

9 Optional: To save the report settings, type any name and then Save Report.

10 Click Generate Report.

Icons 
indicate 
assignment 
status.

Sandy Pasch 
is both the 
assignment 
owner and 
the assigning 
teacher.

Use the 
controls to 
navigate the 
online 
report.

Display option lets you display each table of 
information on a separate page.

Choose to display and print the 
report in PDF format or export 
the report data into a CSV file.
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11 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

12 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

13 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

Assignment Status Report: Details by Student

The following Assignment Status report generated by teacher Sandy Pasch displays assignment status by student.

Generating an Assignment Status Report: Details by Student

1 In the navigation bar, click Reports>Administration Reports>Assignment Status.

2 From the Welcome screen, click Next. 

3 Change Report By as follows:

Teachers: Set Report By to Student. 

School administrators: Set Report By to Teacher. 

District administrators: Set Report By to School.

4 School and district administrators: Set Display to Details. 

5 Specify the Assigned Start Date and Assigned End Date and click Next.

The Selections screen displays students and classes, levels and teachers, or schools, depending on your user 
role. 

Icons indicate 
assignment 
status. Student has 

assignments 
from three 
different 
teachers.

The Default View displays multiple tables of 
information per page. 
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6 Optional for teachers: To more narrowly define your report, from the Selections screen, check the desired 
student attributes and click Apply Filter.

7 Check the district, school, class, or students to include in the report, opening a tree to locate the desired 
selections, if required.

8 When finished, click Next. 

9 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

10 Optional: To save the report settings, type any name and then Save Report.

11 Click Generate Report.

12 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

13 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

14 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

Assignment Status Report: Summary of Assignments by Teacher

The following Assignment Status report generated by a school administrator displays a summary of assignments 
by teacher. 
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Generating an Assignment Status Report: Summary by Teacher

For School Administrators

1 In the navigation bar, click Reports>Administration Reports>Assignment Status.

2 From the Welcome screen, click Next. 

3 Set Report By to Teacher.

4 Select a Group Teachers option—Alphabetically or By Grade Level. 

5 Ensure that Display is set to Summary. 

6 Specify the Assigned Start Date and Assigned End Date and click Next.

7 From the Selections screen, select one or multiple grade levels and teachers or the entire school and then 
Next. 

8 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

9 Optional: To save the report settings, type any name and then Save Report.

10 Click Generate Report.

11 Because school administrators generate this report, Odyssey will send the report to be processed offline. 

You will see the following message:

Report has been queued for offline processing. 

12 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

13 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

Generating an Assignment Status Report: Summary by Assignment

For School and District Administrators

1 In the navigation bar, click Reports>Administration Reports>Assignment Status.

2 From the Welcome screen, click Next. 

3 Set Report By to Assignment.

4 Ensure that Display is set to Summary. 

5 Specify the Assigned Start Date and Assigned End Date and click Next.

6 Under Assignment Search, select the search criteria for locating assignments and click Search.

7 Select the desired assignments and then Next.

8 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

9 Optional: To save the report settings, type any name and then Save Report.

10 Click Generate Report.

11 Because school and district administrators generate this report, Odyssey will send the report to be processed 
offline. 

You will see the following message:

Report has been queued for offline processing. 
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12 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

13 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

Generating an Assignment Status Report: Summary by School

For District Administrators

1 In the navigation bar, click Reports>Administration Reports>Assignment Status.

2 From the Welcome screen, click Next. 

3 Set Report By to School.

4 Select a Group Schools option—Alphabetically or By Grade Level. 

5 Ensure that Display is set to Summary. 

6 Specify the Assigned Start Date and Assigned End Date and click Next.

7 From the Selections screen, select one or multiple schools or the entire district and then Next. 

8 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

9 Optional: To save the report settings, type any name and then Save Report.

10 Click Generate Report.

11 Because district administrators generate this report, Odyssey will send the report to be processed offline. 

You will see the following message:

Report has been queued for offline processing. 

12 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

13 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Progress Reports

BEST PRACTICE    If a teacher generates a progress report by assignment, the progress 
report will provide information only on assignments the teacher owns. When a new 
student with previous assignments joins a class, ensure that the ownership of those 
assignments is changed to the new teacher. See Editing Assignments on page 58. Note 
that generating a progress report by activity returns all of a student’s data.

In addition to progress reports, teachers can use the online Assignments>Class Progress screen to display an 
overview of assignment status for a teacher’s class. See Class Progress on page 69.

Student Progress

A Student Progress report displays individual student progress on completed activities within a specified date 
range. The Student Progress report includes—for each student—the activity name, learning activity code (if 
applicable), the date and time the student completed the activity, the score, the status, and duration. Because 
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student activity for completed activities is listed in one place, the Student Progress report serves as an important 
tool to evaluate learning activities.

BEST PRACTICE    Review the relationship between a student’s activity score and duration 
to evaluate the amount of time a student spends on each activity.

NOTE    By default, Student Progress reports are sorted by activity. If you reuse a Student 
Progress report format from a previous version of Odyssey with a different sort order, 
Odyssey will resort the report results by activity.

Report feature Description

Activity information To preview an activity, click the activity name. 

Scores Displays the score on the activity as a percentage. Non‐scored activities display N/A. Scores for chapter 
tests and quizzes are links to test summaries and quiz details. Objective‐based test scores are links to the 
objective‐based test summary. Odyssey Writer scores are links to student projects.

Status Mastered and not mastered status is denoted in the online and PDF report formats by green and red score 
bars, respectively. The bar lengths graphically represent scores. 
Mastered and not mastered status applies to scored activities, including:
• Scored learning activities

• Lesson quizzes

• Chapter tests

• Objective‐based tests

• Odyssey Writer projects

Scores for activities without predefined mastery levels are denoted by blue bars.

Views:
By activity type
By assignment 
(teachers only) 

Activity types include chapter tests, lesson quizzes, learning activities, objective‐based tests, and Odyssey 
Writer projects.
Teachers: Displays student progress for their classes and students by activity type or for the specified 
assignment. Note that to view student progress from previous schools, you must generate the report by 
activity type.
School Administrators: Displays student progress by activity type for classes in their school.
District Administrators: Displays student progress by activity type for schools in their district.

Date range Displays student progress within a date range you specify. 

Summaries Includes a summary by activity type, including number complete, average score, and average time per 
activity type.

Data from previous 
schools

Choose whether to include data from a previous school. Select this option to include data on transferred 
students.

Student attributes Displays data for students defined by the checked attributes.

Sort order By default, sorts the student data by activity within each chapter and lesson grouping. With the online 
report generated, you can resort the report results. Options include:
• Activity

• Date and time

• Activity—one student per page

• Date and time —one student per page

To print the entire report with a new sort order, select the desired order; View as PDF; and print the report 
from the PDF file.
To perform sorting not available with the online report, export the report data to a CSV file and perform the 
desired sorting in that format.

Report formats Choose from HTML, PDF, and CSV formats.
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The following Student Progress report displays progress by activity: 

Generating a Student Progress Report by Activity Type

1 In the navigation bar, click Reports>Progress Reports>Student Progress.

2 From the Welcome screen, click Next. 

3 From the Curriculum screen, select the subject and grade level from the dropdown lists.

Teachers: For Report on activities by, ensure that the default Type is selected. To display student progress 
from previous schools, Type must be selected.

NOTE    If you select Algebra, ELL Elementary, or ELL Secondary as a subject, you must 
select All for the grade level. 

4 Select one or multiple activity types, including Chapter Tests, Lesson Quizzes, Learning Activities, Objective‐
based Test, Odyssey Writer Project and then Next.

5 From the Options screen, specify the Start Date and End Date.

Use the controls to 
navigate the online 
report.

Status bar key.

Clink the activity’s 
name to launch the 
activity.

Summary of each 
student’s progress 
follows all of the 
activity detail for the 
student.

Sort options within chapter 
and lesson grouping.

Quiz and chapter test 
scores link to summary 
information. N/A indicates 
a non‐scored activity.

Summary of the 
selected report 
criteria.

Choose to display 
and print the report 
in PDF format or 
export the report 
data into a CSV file.
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6 Choose whether to Show summaries and Include data from previous schools. 

7 When finished, click Next.

8 Optional: To more narrowly define your report, from the Students screen, check the desired student 
attributes and click Apply Filter.

9 Check the district, school, class, or students to include in the report, opening a tree to locate the desired 
classes, if required. 

NOTE    Your user role determines which selections are available.

10 When finished, click Next.

11 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

12 Optional: To save the report settings, type any name and then Save Report.

13 Click Generate Report.

14 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

15 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

16 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

Generating a Student Progress Report by Assignment

For Teachers

1 In the navigation bar, click Reports>Progress Reports>Student Progress.

2 From the Welcome screen, click Next. 

3 From the Curriculum screen, select the subject and grade level from the dropdown lists.

4 For Report on activities by, select Assignment.

5 Assignments matching your criteria are displayed in the grid. To include unassigned assignments, check 
Include assignments not currently assigned to any students. 

6 Select the desired assignment from the grid and then Next. 

NOTE    To display assignments for a different curriculum and grade, select a subject and 
grade level from the dropdown lists and then Apply Filter. 

7 From the Options screen, specify the Start Date and End Date.

8 Choose whether to Show summaries and Include data from previous schools. 

9 When finished, click Next.
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10 Optional: To more narrowly define your report, from the Students screen, check the desired student 
attributes and click Apply Filter.

11 Check one or multiple classes or students to include in the report, opening a tree to locate the desired 
classes, if required. 

12 When finished, click Next.

13 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

14 Optional: To save the report settings, type any name and then Save Report.

15 Click Generate Report.

16 Because teachers generate this report, Odyssey process the report immediately, and you will see the report 
displayed in your browser. To view and then print the report in PDF format, click View as PDF. To export the 
data to a CSV file, click Export as CSV.
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Progress Summary

The Progress Summary report displays individual student summaries on completed activities within a specified 
date range. Names of students who have no completed activities are not included in the report. The Progress 
Summary report includes—for each student—the number complete, number passed, average score, and the 
duration. Statistics are summarized for all students at the beginning of the report.

Report feature Description

Average Score Displays each student’s average of scores for each scored activity type. Odyssey Writer 
projects are not averaged. Non‐scored activities display N/A. 

Status Mastered and not mastered status is denoted by green and red score bars, respectively. The 
bar lengths graphically represent scores. Scores for activities without predefined mastery 
levels are denoted by blue bars. 

Views
• By activity type

• By assignment 
(teachers only)

Activity types include chapter tests, lesson quizzes, learning activities, objective‐based tests, 
and Odyssey Writer projects.
Teachers: Displays student progress for their classes and students by activity type or by 
assignment. Note that to view student progress from previous schools, you must generate 
the report by activity type.
School Administrators: Displays student progress by activity type for classes in their school.
District Administrators: Displays student progress by activity type for schools in their district.

Date range Displays student progress within a date range you specify. 

Report summary Summarizes all report data by activity type, including number complete, number passed, 
average score, status, and average time per activity type.

Data from previous 
schools

Choose whether to include data from a previous school. Select this option to include data on 
transferred students.

Student attributes Displays data for students defined by the checked attributes.

Report formats Choose from HTML, PDF, and CSV formats.
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The following Progress Summary report displays progress by activity type. The sample displays one student’s 
data from the report and the report summary.

Generating a Progress Summary Report by Activity Type

1 In the navigation bar, click Reports>Progress Reports>Progress Summary.

2 From the Welcome screen, click Next. 

3 From the Curriculum screen, select one or multiple subjects and grade levels and then Next.

4 From the Options screen, specify the Start Date and End Date, remembering that the range must be under 
one year if you select all subjects or grade levels.

5 Choose whether to Show summary only and whether to Include data from previous schools.

6 Teachers only: Ensure that Report on activities by is set to Type.

7 Select one or multiple activity types, including Chapter Tests, Lesson Quizzes, Learning Activities, Objective‐
based Test, Odyssey Writer Project.

8 When finished, click Next.

9 Optional: To more narrowly define your report, check the desired student attributes and click Apply Filter.

Filter by 
activity type 
or (for 
teachers 
only) by 
assignment

Report summary 
includes grand 
totals on each of 
the activity types 
for all students 
selected for the 
report.

Total time the 
student has spent 
on each of the 
activity types.

Use the 
controls to 
navigate the 
online report.

Choose to display one student’s data per page.Choose to display and print the report in PDF format 
or export the report data into a CSV file.
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10 Check the district, school, class or students to include in the report, opening a tree to locate the desired 
classes, if required. 

NOTE    Your user role determines which selections are available.

11 When finished, click Next.

12 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

13 Optional: To save the report settings, type any name and then Save Report.

14 Click Generate Report.

15 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

16 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

17 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 

Generating a Progress Summary Report by Assignment

For Teachers

1 In the navigation bar, click Reports>Progress Reports>Progress Summary.

2 From the Curriculum screen, select one or multiple subjects and grade levels and then Next.

3 From the Options screen, specify the Start Date and End Date, remembering that the range must be under 
one year if you select all subjects or grade levels.

4 Choose whether to Show summary only and whether to Include data from previous schools.

5 For Report on activities by, select Assignment.

Assignments matching your criteria are displayed in the grid. 

NOTE    To display assignments saved under different subjects and/or grade levels, return 
to the Curriculum screen (click Back) to make your selections. 

6 To include unassigned assignments, check Include assignments not currently assigned to any students and 
enter a date range. 

7 Select the desired assignment and then Next. 

8 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

9 Check one or multiple classes or students to include in the report, opening a tree to locate the desired 
classes, if required. 

10 When finished, click Next.
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11 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

12 Optional: To save the report settings, type any name and then Save Report.

13 Click Generate Report.

14 Because teachers generate this report, Odyssey process the report immediately, and you will see the report 
displayed in your browser. To view and then print the report in PDF format, click View as PDF. To export the 
data to a CSV file, click Export as CSV. 
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Learning Path Status

The Learning Path Status report displays status of and scores on activities prescribed to students through an 
objective‐based test.

Report feature Description

Filters • Displays assignments by subject and level.

• Displays data by class, student, student attribute.

Summary view • Pre‐test and post‐test scores for each objective in the learning path.

• Number of completed activities.

• Average score of scored activities.

• Duration of completed activities.

Details view Objectives. Displays the objective code, name, and description. Explorer tests and learning paths 
correlated to National Assessment of Educational Progress (NAEP) list Explorer codes and 
descriptions.
Mastery level. Displays the mastery level set for each objective and for scored activities serving as 
decision points. Activities repeated during cycling appear, with results, as many times as 
completed. Each authentic task appears in the report only once, even when completed more than 
once.
Results. Displays a student’s score on the objective. Icons indicate status for each activity. For 
scored activities, a student’s score links to the activity details. Odyssey Writer grades link to 
projects and teacher evaluations. An asterisk next to the status icon indicates that the activity was 
completed for another objective within the same learning path.
Activities. Displays all of the activities that are in objective folders, including activity icons, names, 
and learning activity numbers. Learning activity names and numbers are links to the activities. As 
a student completes activities in the learning path, status for completed activities is listed at the 
top of the report.

Report formats Choose from HTML, PDF, and CSV formats.
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Learning Path Status Report: Details

The following Learning Path Status report displays the details view. 

Learning Path Status: Mastered Objectives

If a student has mastered one or more objectives in a test, those results are displayed at the top of the report. 
The following example displays objectives that Emma Young mastered. Learning activities are not assigned for 
mastered objectives. 

Learning 
path name.

Lesson quizzes and chapter 
tests link to results. 

Activity with 
a decision 
point. Click 
the name to 
launch the 
activity.

Mastery level 
for the 
objective.

Student’s 
score for the 
objective.

Mastery level for the activity 
with the decision point.

Student’s score for the activity 
with the decision point.

Use the controls to 
navigate the online 
report.

Choose to display and print the report 
in PDF format or export the report data 
into a CSV file.

Display one student per page.

Objective 
code and 
short name.

Objective 
code and 
description.
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Learning Path Summary Report

The following Learning Path Summary report displays the summary view: 

Student’s score on the objective 
from the first administration of the 
objective‐based test. 

Student’s score on the 
objective from the most 
recent administration of the 
objective‐based test. 

Number of activities 
completed in the learning 
path. This value does not 
include activities not started 
or not completed.

Student’s average score for all scored 
activities in the learning path.

Duration of completed 
activities in the learning 
path.

Blue cells 
denote a 
completed 
learning path.

Clear cells 
denote an 
incomplete 
learning path.
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Generating a Learning Path Status Report

1 In the navigation bar, click Reports>Progress Reports>Learning Path Status.

2 From the Welcome screen, click Next. 

3 From the Options screen, select a view—Details or Summary.

4 To display available learning paths, select the subject and grade level from the dropdown lists and then Apply 
Filter.

5 Select one or multiple learning paths and then Next. 

6 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

7 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

8 When finished, click Next.

9 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

10 Optional: To save the report settings, type any name and then Save Report.

11 Click Generate Report.

12 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

13 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

14 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Assessment Reports

BEST PRACTICE    Assessments reports generated by teachers provide information only on 
assignments the teacher owns. When a new student with previous assignments joins a 
class, ensure that the ownership of those assignments is changed to the new teacher. See 
Editing Assignments on page 58.

Objective‐based Test Results

The Objective‐based Test Results report displays student, class, or school performance on objective‐based tests, 
tests that include objectives aligned to state, school, and district standards for that subject area. District 
administrators may generate a report for each school account to compare schools within the district and analyze 
adequate yearly progress. 

When you generate Objective‐based Test Results, consider the following:

• Compare gains between schools by administering the same test twice—as a pre‐test and post‐test.

To display student progress, the most recent instance of an assigned test must be a copy of the original test. 
For instructions on creating a copy of the original test, see Building an Objective‐based Post‐Test on page 56.

NOTE    To measure gains, you must make a copy of the pre‐test, save it, and assign it. 
Creating a second test that is not a copy—even if it is identical to the first—and assigning 
it as a post‐test will not measure gains.

• You can run the report against particular student attributes for NCLB reporting purposes (disaggregate data).

• To keep district‐wide assessment data current with enrollment, ensure that student data is transferred with 
the students and that reports include data from previous schools.

Report feature Description

Test results First and recent scores 
• For each student, displays the date, raw score, and percentage score for the first and most 
recent times the test was taken.

• For each class or school, displays the percentage score for the first and most recent times the 
test was taken.

Average scores. Summary average percentage of scores.
• For each student, displays the average of first score. If the student took the test more than once, 
the average of the recent score is also displayed.

• For each class or school, displays the average of first scores for all students. If all students took 
the test more than once, the average of all recent scores is also displayed.

Gain. If the first score is higher than the recent score, the gain is a negative percentage.
• For each student, displays the percentage change from the first test to the most recent test. 

• For each class or school, displays the total class or school percentage change. 

Results by test or 
objective

Results by test. Displays results for each test as a whole.
Results by objective. Displays results for each objective in each test. 

Details by 
student, class, or 
school

Test results for the selected objective‐based test are reported for each:
• Student (teachers only)

• Class 

• School (school and district administrators only)
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Objective‐based Test Results: Data View of Students by Test

The following reports show data views of each student’s test results on an objective‐based test. The bottom 
example includes only those students who took both the pre‐ and post‐tests. 

Display options Data view. Includes dates, raw scores, and percentage scores for the first and recent tests. Also 
lists the percentage gain from the first to recent test scores.
Graphs view. Includes dates of first and recent tests and the percentage gain from the first to 
recent test scores. The first and recent scores are represented graphically by proportional 
horizontal bars and expressed as percentages.

Report formats Choose from HTML, PDF, and CSV formats.

Report feature Description

Because all students did not take the post‐test, Average Score displays N/A.

Because report 
includes only students 
who took the pre‐test 
and post‐test, the 
Average Score 
displays values.

Percentage 
gain from the 
first score to 
the most 
recent score.

Student’s 
last, first, and 
user name.

Results 
displayed by 
test. First and recent scores.

Details 
displayed for 
each student.

Display option lets you display each table of information 
on a separate page or multiple tables on a page (default).

Choose to display and print the report in PDF 
format or export the report data into a CSV file.

Click to display the 
graph view of the 
report.
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Objective‐based Test Results: Graph View of Students by Test

The following example shows the graph view for student results on the objective‐based test. 

Student’s 
last, first, and 
user name.

Results 
displayed by 
test.

Details 
displayed for 
each student.

Test name.

The gain is 
empty 
because the 
student took 
only the pre‐ 
test.

Click to 
display the 
data view of 
the report.
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Objective‐based Test Results: Data View of Students by Objective

The following example shows the data view for class results on objectives in an objective‐based test. 

Objective‐based Test Results: Data View of Classes by Test

The following example shows test results from two classes in a district school. The report was generated by a 
district administrator. 

Test name 
and first 
objective in 
the test.

Results 
displayed by 
objective.

Details 
displayed for 
each class.

Because all students did not take the pre‐test and post‐test, Average Score displays N/A.
CompassLearning® Odyssey User’s Guide



Reports 142
Assessment Reports
Generating an Objective‐based Test Results Report

NOTE    User roles determine which test results are available. District and school 
administrators are able to view tests saved to My School and My District. Teachers are 
able to view tests saved to My Assignments, My School, My District, and All Schools.

1 In the navigation bar, click Reports>Assessment Reports>Objective‐based Test Results Report.

2 From the Welcome screen, click Next. 

3 A list of objective‐based tests is displayed. If a test has not been completed by a minimum of one student, 
that test will not be displayed in this list. To filter the number of displayed objective‐based tests, select the 
subject and grade level from the dropdown lists.

4 Select one or more objective‐based tests and then Next. 

5 From the Options screen, choose from the following options:

• Show results for each Test or for each Objective.

• Show details for each Class or for each Student (teachers only) or for each Class or for each School (school 
and district administrators only). 

• Choose whether to Show Summaries.

• Select a display type—Data or Graphs.

• Choose whether to include data from previous schools.

• Choose whether to display the percentage of gains and averages for classes, remembering that only those 
students who have taken the test multiple times will be included in the report.

6 When finished, click Next. 

7 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

8 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

9 When finished, click Next.

10 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

11 Optional: To save the report settings, type any name and then Save Report.

12 Click Generate Report.

13 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 
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14 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

15 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Test Item Summary

The Test Item Summary lists items in an objective‐based test and displays student choices for each distractor in 
the test item. 

A distractor is one of the incorrect answers presented as a choice in a multiple‐choice test. 

Use this report to evaluate the effectiveness of custom test items. The percentage bar graph lets you quickly spot 
regularly missed questions.

BEST PRACTICE    Because a larger sample size results in a more reliable analysis, consider 
using a sample size of 250 students or more.

Report feature Description

Filters • Lists tests by subject and level.

• Displays data by class, student, student attribute.

Views Lists test items four ways:
• Position in test.

• Least to greatest percent correct.

• Greatest to least percent correct.

• Objective.

Answers For each test item, displays the correct answer bubble darkened, along with the number and 
percentage of students who answered each choice, including no response.

Objectives For each item, displays the objective code and short description.

Graphical display Displays percentage of students who selected each choice represented by horizontal bars.

Report formats Choose from HTML, PDF, and CSV formats.
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The following Test Item Summary lists test items first by objective and then from least to greatest percent 
correct. Note that sample reports are not displayed in their entirety below. 

Generating a Test Item Summary

1 In the navigation bar, click Reports>Assessment Reports>Test Item Summary Report.

2 From the Welcome screen, click Next. 

Name of the test.

Item title. Explorer items 
display EX codes; custom 
items are named by the 
author.

View option for 
listing test items.

Item position in the test.

Graphical display of 
percentage of students 
who selected the item.

Use the 
controls to 
navigate the 
online report.

Choose to display and print the report in PDF 
format or export the report data into a CSV file.

Percentage of students 
who selected the item.

Objective key code and short name.

Number of students who 
selected the item. 

Correct answer.

Test Item Summary lists test items 
from least to greatest percent 
correct. (The example displays the 
first test item only.)
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3 A list of assignments containing objective‐based tests is displayed. To filter the number of displayed 
objective‐based tests, select the subject and grade level from the dropdown lists and then Apply Filter.

NOTE    User roles determine which test results are available to view. District and school 
administrators are able to view objective‐based tests that are not assigned; assigned but 
not started; assigned but incomplete; and assigned and completed. Teachers are able to 
view objective‐based tests that are assigned by the teacher and completed.

4 Select the desired objective‐based test and then Next. 

5 From the Options screen, choose how you want the test items to be listed—Position in Test; Least to 
Greatest Percent Correct; Greatest to Least Percent Correct; or Objective.

6 When finished, click Next.

7 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

8 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

9 When finished, click Next.

10 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

11 Optional: To save the report settings, type any name and then Save Report.

12 Click Generate Report.

13 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

14 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

15 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Test Summary by Objective

The Test Summary by Objective report displays individual student performance on objective‐based tests. With 
this report, you can see at a glance how many students have mastered the objectives evaluated by a diagnostic 
test.

Report feature Description

Objectives Displays the objective key code, short name, and description. Explorer tests and learning 
paths correlated to NAEP are listed with Explorer codes and descriptions. Custom state tests 
and learning paths are listed with state codes and descriptions.

Filters Report on selected students and/or classes. To more narrowly define the report, filter by 
student attributes.

Scores Score for each student, in descending order from the highest score. By default, a green check 
box indicates a mastered objective; a red X indicates a non‐mastered objective. You can also 
display individual student scores in each cell. The report includes the overall test score for 
each student.

Percent Mastered Number of students who have mastered the objective, expressed as a percentage and in 
descending order from the highest score.

Data from previous 
schools

Choose whether to include data from a previous school.

Report formats Choose from HTML, PDF, and CSV formats.
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The following Test Summary by Objective displays student performance on individual objectives in an objective‐
based test: 

Generating a Test Summary by Objective

1 In the navigation bar, click Reports>Assessment Reports>Test Summary by Objective.

2 From the Welcome screen, click Next. 

3 From the Options screen, select the subject and grade level from the dropdown lists and then Apply Filter.

4 Tests matching your criteria are displayed in the grid. Select the desired test. 

5 Choose whether to Include data from previous schools. 

6 When finished, click Next.

7 Optional: To more narrowly define your report, check the desired student attributes and click Apply Filter.

Click Show with scores to 
display individual student 
scores in each cell.

Choose to 
display and 
print the 
report in PDF 
format or 
export the 
report data 
into a CSV 
file.

Student’s last, first, 
and user name.

Number of students who have mastered 
the objective, expressed as a percentage.

Objective key code and short name.

Long description of the objective.

Test results for each student in 
descending order from highest score. A 
green checkmark denotes mastery and 
a red X denotes nonmastery.

Scores ordered by 
test objectives.

Total score on the test for each student.
CompassLearning® Odyssey User’s Guide



Reports 149
Assessment Reports
8 Check one or multiple classes or students to include in the report, opening a tree to locate the desired 
classes, if required. 

9 When finished, click Next.

10 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

11 Optional: To save the report settings, type any name and then Save Report.

12 Click Generate Report.

13 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

14 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

15 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Objective Score

For School and District Administrators

The Objective Score report summarizes student performance on objectives and benchmarks, independent of an 
objective‐based test. 

Report feature Description

Standard set For a subject and grade level, lets you select standard sets by strand, substrand, or 
individual objective.

Number of students Displays the number of students by class or school and total number of students 
tested on each objective.

Percent average Displays aggregate percent score for groups tested on each objective.

Date range Limits report to a date range you specify. 

Filters Depending on your user role, displays data by school, class, student attribute, and 
standard set:
• District administrators can select the district or one or multiple schools and 
classes. 

• School administrators can select the school or one or multiple classes. 

Data from previous schools Includes data from previous schools. 

Report formats Choose from HTML, PDF, and CSV formats.
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The following Objective Score reports display student data on objectives grouped by class (top) and school 
(bottom).

Generating an Objective Score Report

1 In the navigation bar, click Reports>Assessment Reports>Objective Score.

2 From the Welcome screen, click Next. 

Objective 
key code and 
short name.

Number of students tested on the objective.

Aggregate percent score 
for groups tested on each 
objective.

Objective 
description.

Report 
grouping by 
class.

Totals for the objective.

Individual 
class.

Use the 
controls to 
navigate the 
online report.

Choose to display and print the report in PDF 
format or export the report data into a CSV file.

Report grouping 
by school. If you 
select a grouping 
by school, you are 
unable to select 
individual classes.
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3 From the Curriculum screen, select a standard set, subject, and grade level. To more narrowly define your 
search, enter a keyword and then Search.

4 The grid displays strands, substrands, and objectives that meet your search criteria. Check the strand, 
substrand, and objectives for your report and then Next. 

5 Enter the Start Date and End Date.

6 Choose whether to include data from previous schools and to group the report by Class or by School.

7 When finished, click Next.

8 Optional: To more narrowly define your report, check the desired student attributes and click Apply Filter.

9 Depending on your user role, check one or multiple schools or classes to include in the report and then Next.

NOTE    If you choose to group the report by School, you will be unable to select classes.

10 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

11 Optional: To save the report settings, type any name and then Save Report.

12 Click Generate Report.

13 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

14 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

15 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Test Translator Reports

NOTE    Your site’s licensing determines whether these reports are available to you.

Goal‐based Test Results

The Goal‐based Test Results report provides information about student performance on NWEA or state tests that 
have been administered externally and imported into Odyssey with Test Translator. 

NOTE    NWEA and state goals are comparable to Odyssey objectives.

The following Goal‐based Test Results report (generated by a teacher) displays student results by goal. 

Report feature Description

Filters • Lists goals by source—NWEA or State Test—and subject.

• Displays results by test or by goal.

• Depending on your user role, displays data by student, student attribute, class, or school.

Detail views • Student: Displays the RIT range (for NWEA tests) or scores (for state tests) for each student on 
each goal. 

• Class: Displays the number of students who were administered the test in each class.

• School: Displays the number of students who were administered the test in each school.

Report formats Choose from HTML, PDF, and CSV formats.

RIT range on 
each goal in 
the test.

Results displayed 
by goal.

Details displayed 
for each student.

Test name.

Goal name.

Last and first name 
of student.

Choose to display and print the report in PDF format or export the report data into a CSV file.
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The following Goal‐based Test Results report displays class results by test. 

Generating a Goal‐based Test Results Report

1 In the navigation bar, click Reports>Test Translator Reports>Goal‐based Test Results Report.

2 From the Welcome screen, click Next. 

3 From the Curriculum screen, select a source—NWEA or State Test—and a subject (or All) from the dropdown 
lists.

4 To display tests that match your criteria, click Apply Filter.

5 Select one or more goal‐based tests and then Next. 

6 From the Options screen, choose to show results for each Test or for each Goal. 

NOTE    If you choose to show results for each test, you will be unable to show details for 
each student.

7 Teachers: Choose to show details for each Class or for each Student and then Next.

OR

School and District Administrators: Choose to show details for each Class or for each School and then Next.

8 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

Results displayed 
by test.

Details displayed 
for each class.

Test name.

Class name.

Total number of 
students 
represented in 
each class.

Choose to display and print the report in PDF format or export the report data into a CSV file.
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9 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

10 When finished, click Next.

11 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

12 Optional: To save the report settings, type any name and then Save Report.

13 Click Generate Report.

14 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

15 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

16 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Test Summary by Goal

The Test Summary by Goal report displays individual student performance on goal‐based tests administered 
externally and imported with Odyssey’s Test Translator. Goals are ordered by RIT range or score.

NOTE    NWEA and state goals are comparable to Odyssey objectives.

The following Test Summary by Goal report displays student performance on an NWEA test: 

Generating a Test Summary by Goal

1 In the navigation bar, click Reports>Test Translator>Test Summary by Goal.

2 From the Welcome screen, click Next. 

3 From the Options screen, select the source and subject from the dropdown lists and then Apply Filter.

Report feature Description

Filters • Report on selected students and/or classes. To more narrowly define the report, filter by 
student attributes.

• Displays goals by selected subject or by all subjects.

Scores • For NWEA test data, displays a student’s RIT ranges, in descending order from the highest 
score.

• For state test data, displays a student’s scores, in descending order from the highest score.

Report formats Choose from HTML, PDF, and CSV formats.

Name of external goal in test.

RIT ranges by goal for each student.

Last, first, 
and user 
name of 
student.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Test source 
and subject.

Test name.
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4 Tests matching your criteria are displayed in the grid. Select the desired test. 

5 When finished, click Next.

6 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

7 Check one or multiple classes or students to include in the report, opening a tree to locate the desired 
classes, if required. 

8 When finished, click Next.

9 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

10 Optional: To save the report settings, type any name and then Save Report.

11 Click Generate Report.

12 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

13 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

14 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Goal Score

The Goal Score report lists the number of students tested on NWEA or state goals, independent of a goal‐based 
test. 

Report feature Description

Number of students Displays the number of students by class or school and total number of students 
tested on each goal.

Date range Limits report to a date range you specify. 

Filters Depending on your user role, displays data by school, class, student attribute, and 
goal:
• District administrators can select the district or one or multiple schools and 
classes. 

• School administrators can select the school or one or multiple classes. 

Report formats Choose from HTML, PDF, and CSV formats.
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The following Goal Score reports display student data on NWEA goals grouped by school (top) and class (bottom).

Generating a Goal Score Report

1 In the navigation bar, click Reports>Test Translator>Goal Score.

2 From the Welcome screen, click Next. 

3 From the Curriculum screen, select a source—NWEA or State Test—and subject and then Apply Filter.

4 The grid displays goals that meet your search criteria. Check one or multiple goals for your report and then 
Next. 

5 Enter the Start Date and End Date.

6 Choose whether to report by Class or by School and then Next. 

Goal name.

Number of students tested on the goal.

Report 
grouping by 
school. 

Total number of students 
tested on the goal.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Report grouping by class. 

Test source.

Date range 
test was 
administered.
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7 Optional: To more narrowly define your report, check the desired student attributes and click Apply Filter.

8 Depending on your user role, check one or multiple schools or classes to include in the report and then Next.

NOTE    If you choose to group the report by School, you will be unable to select classes.

9 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

10 Optional: To save the report settings, type any name and then Save Report.

11 Click Generate Report.

12 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

13 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

14 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Test Translator Import Log

The Test Translator Import Log summarizes the import results of goal‐based tests administered externally. Use 
this report to view all messages, including errors, generated during the import.

NOTE    NWEA and state goals are comparable to Odyssey objectives.

Test Translator Import Log: NWEA Data

The following example displays the log from importing NWEA test results. 

Report feature Description

Filters • Displays results for a date range you specify. The date range indicates when the test was 
imported into Odyssey.

• Displays results by test source—NWEA or state test.

• Displays results for a single test by test name or for one or more files by file name.

• Depending on your user role, displays data by student, student attribute, class, or school.

Scores • For NWEA test data, displays students’ RIT ranges for the imported test.

• For state test data, displays students’ scores for the imported test.

Report formats Choose from HTML, PDF, and CSV formats.

Test name.

Last, first, and 
user name of 
student.

Date range 
of import.

Name of goal.
RIT range for the goal.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Test source. 

Date test was 
taken by 
student.

Use the 
controls to 
navigate the 
online report.
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Test Translator Import Log: State Data

The following example displays an import log from importing state test results. 

Generating a Test Translator Import Log

1 In the navigation bar, click Reports>Test Translator Reports>Test Translator Import Log.

2 From the Welcome screen, click Next. 

3 From the Options screen, specify a date range and test source—NWEA or State Test.

4 District Administrators: Select a school from the dropdown list.

5 School and District Administrators: To select by test, click Test Name and select a test from the dropdown list.

OR

To select by file, click Select File(s) and the one or multiple files from the displayed list.

6 When finished, click Next. 

7 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

8 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

School name.

Last, first, and 
user name of 
student.

Date range 
of import.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Test source. 

Date test was 
taken by 
student.

Use the 
controls to 
navigate the 
online report.

Name of goal.
Score.

Test name.
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9 When finished, click Next.

10 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

11 Optional: To save the report settings, type any name and then Save Report.

12 Click Generate Report.

13 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

14 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

15 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Longitudinal Goal Score Analysis

The Longitudinal Student Goal Score Analysis looks at tests taken over a period of time by one or multiple 
students, providing scores on goal‐based NWEA or state tests administered externally and imported with 
Odyssey’s Test Translator.

Scores are displayed for each test attempt. A record in the report corresponds to one test taken by one student. 
Subsequent records are for other tests taken by the same student.

NOTE    NWEA and state goals are comparable to Odyssey objectives.

Report feature Description

Filters • Lists goals by source—NWEA or state test—and subject.

• Displays results by student or by test.

• Depending on your user role, displays data by student, student attribute, class, or school.

Scores • For NWEA test data, displays students’ RIT ranges for goal‐based tests taken over a period of 
time.

• For state test data, displays students’ scores for goal‐based tests taken over a period of time.

Report formats Choose from HTML, PDF, and CSV formats.
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Longitudinal Goal Score Analysis: NWEA Data

The following sample Longitudinal Goal Score Analysis displays data by student for NWEA test results imported 
with Odyssey’s Test Translator. 

Results displayed 
by student.

Last, first, and user 
name of student.

Test name.

Goal name.

Choose to display and print the report in PDF format or export the report data into a CSV file.

Use the controls to 
navigate the online 
report.

Date student took test.

Results 
displayed by 
test.

RIT ranges.
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Longitudinal Goal Score Analysis: State Data

The following sample Longitudinal Goal Score Analysis displays data by student for state test results imported 
with Odyssey’s Test Translator. 

Generating a Longitudinal Goal Score Analysis

1 In the navigation bar, click Reports>Test Translator Reports>Longitudinal Goal Score.

2 From the Welcome screen, click Next. 

3 From the Curriculum screen, select a source—NWEA or State Test—and a subject (or All) from the dropdown 
lists.

4 To display tests that match your criteria, click Apply Filter.

5 Choose to display the results by Test or by Student. 

6 Select one or more goal‐based tests and then Next. 

7 From the Options screen, specify a date range and whether to display the first and last records only. 

8 When finished, click Next. 

9 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

Results displayed 
by test.

Last, first, and user 
name of student.

Test name.

Goal name.

Choose to display and print the report in PDF format or export the report data into a CSV file.

Use the controls to 
navigate the online 
report.

Date student took test. Scores.
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10 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you: district administrators can 
select their schools or classes; school administrators can select their school and classes in 
their school; and a teacher can select their classes or students.

11 When finished, click Next.

12 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

13 Optional: To save the report settings, type any name and then Save Report.

14 Click Generate Report.

15 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

16 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

17 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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NWEA Learning Path Status

The NWEA Learning Path Status report displays status of and scores on activities prescribed to students through 
an NWEA test.

The following sample NWEA Learning Path Status report displays status for Emmeline Pankhurst on two learning 
paths. 

Generating an NWEA Learning Path Status Report

1 In the navigation bar, click Reports>Test Translator Reports>NWEA Learning Path Status.

2 From the Welcome screen, click Next. 

3 From the Options screen, to display available learning paths, select the subject and grade level from the 
dropdown lists and then Apply Filter.

Report feature Description

Filters • Displays assignments by subject and level.

• Displays data by school, class, student, student attribute.

Goals Displays the goal name and code. 

Results Displays a student’s progress and results for each activity in the learning path. Icons indicate 
status for each activity. An asterisk next to the status icon indicates that the activity was 
completed for another objective within the same learning path. For scored activities, a student’s 
score links to the activity details. Odyssey Writer grades link to projects and teacher evaluations. 

Activities Displays all of the activities that are in goal folders, including activity icons, names, and learning 
activity numbers. Learning activity names and numbers are links to the activities.

Report formats Choose from HTML, PDF, and CSV formats.

The student has not started these activities.

Learning path name.
Assignment folder.

To preview the activity, click the activity name.

Choose to display and print the report in PDF format or export the report data into a CSV file.
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4 Select one or multiple learning paths and then Next. 

5 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

6 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

7 When finished, click Next.

8 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

9 Optional: To save the report settings, type any name and then Save Report.

10 Click Generate Report.

11 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

12 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

13 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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State Learning Path Status

The State Learning Path Status report displays status of and scores on activities prescribed to students through a 
state test.

The following sample State Learning Path Status report displays status for Sarah Polk. 

Generating a State Learning Path Status Report

1 In the navigation bar, click Reports>Test Translator Reports>State Learning Path Status.

2 From the Welcome screen, click Next. 

Report feature Description

Filters • Displays assignments by subject and level.

• Displays data by school, class, student, student attribute.

Goals Displays the state assessment code. 

Results Displays a student’s progress and results for each activity in the learning path. Icons indicate 
status for each activity. An asterisk next to the status icon indicates that the activity was 
completed for another objective within the same learning path. For scored activities, a student’s 
score links to the activity details. Odyssey Writer grades link to projects and teacher evaluations. 

Activities Displays all of the activities that are in goal folders, including activity icons, names, and learning 
activity numbers. Learning activity names and numbers are links to the activities.

Report formats Choose from HTML, PDF, and CSV formats.

Learning path name.

Activity with a 
decision point.

The student has not started these activities.

Choose to display and print the report in PDF format or export the report data into a CSV file.

Assignment folder.

Use the controls to 
navigate the online 
report.

To preview the activity, click 
the activity name.
CompassLearning® Odyssey User’s Guide



Reports 171
Test Translator Reports
3 From the Options screen, to display available learning paths, select the subject and grade level from the 
dropdown lists and then Apply Filter.

4 Select one or multiple learning paths and then Next. 

5 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

6 Check one or multiple schools, classes, or students to include in the report, opening a tree to locate the 
desired selections, if required. 

NOTE    Your user role determines the options available to you.

7 When finished, click Next.

8 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

9 Optional: To save the report settings, type any name and then Save Report.

10 Click Generate Report.

11 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

12 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

13 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Student Writing Portfolio

Use the Student Writing Portfolio report to summarize student work on Odyssey Writer projects that have been 
evaluated. You can report on multiple projects for classes or individual students. 

Report feature Description

Odyssey Writer project 
evaluations

For the selected students, displays the following information for each Odyssey Writer project 
included in the report:
• Date handed in. Date and time the student handed in the project. Time is your local time.

• Grade. Grade the teacher gives to the project. If multiple revisions have been made, only 
the most recent grade appears.

• Rubric Categories and Scores. Scores assigned to the rubric categories the project. Scoring 
criteria are established when projects are evaluated. Rubric scores range from 6 to 1. 
Teachers define the high‐to‐low score sort order (6–1 or 1–6) when creating the 
assignment.

• Annotations. Types and frequencies of common errors.

• Duration. Total amount of time (in hh:mm:ss format) that the student has spent on the 
project.

Date range Summarizes student work evaluated during a date range you specify. 

Student attributes Displays data for students defined by the checked attributes.

Report formats Choose from HTML, PDF, and CSV formats.
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The following example Student Writing Portfolio report summarizes student work on four Odyssey Writer 
projects. The report was filtered by female students and returned data for two students. 

Generating a Student Writing Portfolio Report

1 In the navigation bar, click Reports>Odyssey Writer Reports>Student Writing Portfolio.

2 From the Welcome screen, click Next. 

3 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Results are grouped by student. In this example, the report 
returns data for two students. Results for the student at left are 
returned for one Odyssey Writer project; for the student 
below, results are returned for three projects. 
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4 Check one or multiple classes to include in the report and then Next.

5 From the Options screen, enter the Start Date and End Date and then Next.

6 The Projects screen displays evaluated Odyssey Writer assignments. Select one or multiple assignments and 
then Next.

NOTE    Only the most recently evaluated version of a project handed in multiple times is 
available.

7 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

8 Optional: To save the report settings, type any name and then Save Report.

9 Click Generate Report.

10 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

11 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

12 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Writing Summary

Use the Writing Summary report to summarize evaluations by Odyssey Writer project. You can report on a single 
project for multiple students or classes. 

Report feature Description

Odyssey Writer project 
evaluations

For the selected project, displays the following student evaluation information:
• Date handed in. Date and time the student handed in the project. Time is your local time.

• Grade. Grade the teacher gives to the project. If multiple revisions have been made, only 
the most recent grade appears. 

• Rubric Categories and Scores. Scores assigned to the rubric categories the project. Scoring 
criteria are established when projects are evaluated. Rubric scores range from 6 to 1. 
Teachers define the high‐to‐low score sort order (6–1 or 1–6) when creating the 
assignment.

• Annotations. Types and frequencies of common errors. 

• Duration. Total amount of time (in hh:mm:ss format) that the student has spent on the 
project.

Date range Summarizes student work evaluated during a date range you specify. 

Student attributes Displays data for students defined by the checked attributes.

Report formats Choose from HTML, PDF, and CSV formats.
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The following example Writing Summary report summarizes evaluations for a single Odyssey Writer project. The 
report returned data for one student. 

Generating a Writing Summary Report

1 In the navigation bar, click Reports>Odyssey Writer Reports>Writing Summary.

2 From the Welcome screen, click Next. 

3 From the Options screen, enter the Start Date and End Date and then Next.

4 The Project screen displays Odyssey Writer assignments. Select one assignment and then Next.

NOTE    Only the most recently evaluated version of a project handed in multiple times is 
available.

5 Optional: From the Students screen, to more narrowly define your report, check the desired student 
attributes and click Apply Filter.

Choose to display and print the report in PDF format 
or export the report data into a CSV file.

Results for the Odyssey Writer project are grouped 
by student. In this example, the report returns data 
for one student.

Scroll to display the entire 
online HTML report.
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6 Check one or multiple classes to include in the report and then Next.

NOTE    Only students for whom the selected project has been evaluated are displayed.

7 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

8 Optional: To save the report settings, type any name and then Save Report.

9 Click Generate Report.

10 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

11 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

12 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Odyssey offers two reports for you to gather information about available curriculum. Generating either of these 
reports may be helpful as you build an assignment. 

• Curriculum Report

• State Correlation Report on page 182

Curriculum Report

Use the Curriculum report to view relationships among chapters, lessons, and learning activities for a subject and 
grade level. Three reports are available: Lesson vs. Learning Activities, Lesson Questions, and Chapter Questions. 

Lesson vs. Learning Activities

The Lesson vs. Learning Activities report displays learning activity numbers for the selected subject, grade, 
chapter, and lesson. To view a learning activity, click the learning activity’s link. The following sample Curriculum 
report displays learning activities associated with the Rounding Numbers lesson in grade 4 math Number Theory 
and Systems. 

Choose to display and print the report in PDF format or export the 
report data into a CSV file.

To preview the activity, click the learning activity’s number.

Chapter title and 
description.

Lesson code (ID) within 
the chapter.

Lesson title and description.

Type of Curriculum 
report. 
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Lesson Questions

The Lesson Questions report displays all lesson questions for the selected subject, grade, chapter, and lesson. The 
following sample curriculum report displays lesson questions from the Rounding Numbers lesson in grade 4 
math Number Theory and Systems.

Choose to display and print the report in PDF format or export the 
report data into a CSV file.

Scroll to display the entire 
online HTML report.

Type of Curriculum 
report. 

Lesson title and 
description of contents.

Question code (ID) 
within the lesson.

Lesson question.
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Chapter Questions

The Chapter Questions report displays chapter questions for the selected subject, grade, chapter, and lesson. The 
following sample curriculum report displays chapter questions from the Rounding Numbers lesson in grade 4 
math.

Generating a Curriculum Report

1 In the navigation bar, click Content>Resources.

2 With the default Curriculum tab selected, click Curriculum Report (underneath Reports).

3 From the Curriculum Report page, click Next. 

4 Select a subject, grade, chapter, and lesson from the dropdown lists, and click Next. 

Choose to display and print the report in PDF format or export the 
report data into a CSV file.

Scroll to display 
the entire 
online HTML 
report.

Type of 
Curriculum report. 

Chapter title and 
description of contents.

Question code (ID) 
within the chapter.

Chapter question.
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5 Select a report type—Lesson vs. Learning Activities, Lesson Questions or Chapter Questions—and click 
Next. 

6 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

7 Optional: To save the report settings, type any name and then Save Report.

8 Click Generate Report.

9 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

10 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

11 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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State Correlation Report

Use the State Correlation report to view learning activities and lesson quizzes by strand for the specified state, 
subject, and level. To view a learning activity or quiz, click the learning activity’s or quiz’s link. 

NOTE    If the Lesson Quizzes column is empty in a State Correlation report, the 
curriculum does not include lesson quizzes. 

The following sample report displays learning activities and quizzes grouped by strand for grade 8 math in 
Georgia.

Generating a State Correlation Report

1 In the navigation bar, click Content>Resources.

2 With the default Curriculum tab selected, click State Correlation Report (underneath Reports).

3 From the State Correlation Report page, click Next. 

4 Select a state, subject, and level from the dropdown lists, and click Next. 

5 In the Confirmation screen, review the report’s definition. To make changes, click the desired Edit button. 
Make your change and then click Next until you reach the Confirmation screen.

6 Optional: To save the report settings, type any name and then Save Report.

7 Click Generate Report.

Choose to display and print the report in PDF format or export the 
report data into a CSV file.

To preview the activity or lesson quiz, click the link.

Strand key and 
description.

Grade level and 
subject. 

Use the controls to 
navigate the online 
report.
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8 If Odyssey generates the HTML report immediately, you will see the report displayed in your browser. To view 
and then print the report in PDF format, click View as PDF. To export the data to a CSV file, click Export as 
CSV.

OR

If Odyssey sends the report to be processed offline, you will see the following message:

Report has been queued for offline processing. 

9 To display the status of a report processed offline, click Show Queue. 

The Reporting Queue window displays reports that Odyssey has processed offline. 

10 To display a report processed offline, click an available option—View Online, View as PDF, or Export as CSV. 
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Odyssey Writer is a customizable writing tool in Odyssey Manager that helps educators in all disciplines teach the 
writing process to their K‐12 students. Designed to improve narrative, persuasive, informative, fiction, and 
nonfiction writing skills, Odyssey Writer lets teachers create and assign writing assignments and guides students 
through the entire writing process. Students are encouraged to monitor their progress via assessment tools, such 
as state writing rubrics and checklists. Odyssey Writer’s features empower teachers to create and assign writing 
assignments that meet national and state standards.

Forms of Writing

Odyssey Writer aims to improve students’ writing skills in all forms of writing. The following are descriptions of 
some forms of writing students will use in Odyssey Writer. 

Form of writing Description

Narrative  In narrative writing, the author tells a story or an account of events or experiences. Narrative 
writing can be either fiction or nonfiction. Some examples of narrative writing are novels, 
biographies, and some poetry.

Persuasive  In persuasive writing, usually the author is clearly arguing for or against a position. Persuasive 
writing tries to influence the reader to think or act a certain way. It attempts to sway the reader’s 
opinion. Some examples of persuasive writing are found in political speeches, advertisements, 
and editorials.

Informative  Informative writing conveys an author’s knowledge of objects, events, and ideas, without 
expressing his or her feelings or attitudes. By focusing on facts, it explains how to do something, 
what something is like, or what someone has done. Examples of informative writing are news 
articles, instruction manuals, textbooks, and “how to” guides.

Fiction Fiction writing is speculative and make‐believe. An author’s imaginary experiences can be set in 
the past, present, or future. Often, the purpose of fiction writing is to entertain, but authors 
sometimes use fiction writing to symbolically teach a moral or state an opinion. Some examples 
of fiction writing are science fiction, fairy tales, fables, and tall tales.

Nonfiction Nonfiction writing is narrative prose based on facts and reality. Nonfiction writing is an unbiased, 
factual account of events. Some examples of nonfiction writing are biographies, historical 
articles, and essays.
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Stages of the Writing Process

Odyssey Writer guides students through each stage of the writing process: prewriting, drafting, revising, editing, 
and publishing. Here are brief descriptions of each of these stages, as well as a few suggestions for teachers. 

Stage Description Read more

Prewriting  The prewriting stage allows students the opportunity to brainstorm and start 
forming a plan for their writing assignment. 
• Teachers can write questions that help prepare students for their writing 
assignment.

• Teachers can also give students partially completed note cards to fill in or can 
ask students to develop the note cards or graphic organizers themselves.

• Outlines help students to collect information relevant to their writing topic and 
to organize their thoughts.

• Students can also use graphic organizers to jot down ideas during the prewriting 
stage. The Graphic Organizer and Note Cards tools are synchronized with the 
outline. The outline can then be pasted to the Drafting tool for students to 
expand on their writing.

page 194

Drafting  Drafting is the beginning of the final product, which is usually a project. Students 
concentrate on organization, supporting details, and coherence of their entire 
composition. They can express their thoughts freely, since the software tools make 
rewriting and revising easy to do. You can remind students to express all ideas in 
sentences and paragraphs when writing a draft.

page 198

Revising  When students have finished their drafts, they can evaluate their projects using a 
self‐assessment and rubric. Students can then revise their projects accordingly.

page 201

Editing Editing includes correction of punctuation, spelling, capitalization, sentence 
structure, word selection, and so on. Students can also cut and paste text to 
change the order of their words, sentences, or paragraphs.

page 205

Publishing Publishing is the process of creating the final product for the intended audience. 
Students can use desktop publishing features, such as centered and boldface type, 
to make their projects look polished.

page 206
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Assigning Odyssey Writer Projects

When teachers first launch Odyssey Writer, they will see the Odyssey Writer screen with the Instructions tab 
displayed. 

When you save an Odyssey Writer project, your target folder determines who will have access to the project. 

Instructions.
Include prompts for 
students.

Writing Framework.
Include information 
to support prewriting 
and draft writing.

Note Cards.
Create up to ten note 
cards.

Web Links.
Create web URLs for 
students to access to 
support their writing.

Rubric.
Create a new rubric or 
use an existing rubric as 
a template.

Closes the Odyssey 
Writer window.

Makes the project available 
for an assignment.

Odyssey Writer tabs let 
teachers customize each 
assignment.

Opens the 
Equation Editor.

Inserts an image.

My Projects.
Only you have access to Odyssey 
Writer projects saved in this folder.

School Projects.
Accessible to users in your school who 
have permission.

District Projects.
Accessible to users in your district who 
have permission.

Odyssey Projects.
You cannot save projects in this folder.
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Creating an Odyssey Writer Project

1 From the navigation bar, select Assignments>Assignment Builder.

2 With the Curriculum tab selected, click Create Custom Activity.

3 In the Create Custom Activity dialog box, select Odyssey Writer Activity and click Next.

Odyssey Writer opens with the Instructions tab selected.

NOTE    Instead of creating a project from scratch, you can edit a copy of a project. See 
Using an Existing Project as a Template below.

4 If desired, include instructions for students to read when they first start the Odyssey Writer project. 

5 To include prewriting and draft writing support, click the Writing Framework tab and enter the desired 
information.

6 To create note cards, click the Note Cards tab and enter note card and pinpoint text. 

7 To include web links that students may visit as they work on their projects, click the Web Links tab and enter 
titles and URLs.

8 To use a rubric, click the Rubric tab. You can use an existing rubric or create a new one. See Using an Existing 
Rubric on page 188 or Creating a New Rubric on page 188.

9 When you are finished creating the new Odyssey Writer project, click File>Save. 

10 In the Save Project dialog box, click the desired folder in which to save the project, remembering that you 
must have permission to save to the District and School Projects folders and that you cannot save to the 
Odyssey Projects folder.

NOTE    Saving a project in the My Projects folder restricts access so that only you can see 
and copy the project.

11 Turn spell check On or Off.

12 If desired, set Draft Mode to Yes. 

NOTE    You cannot assign a project that is in Draft Mode. When you are ready to assign 
the project, open the draft, make any changes, and then Save As (renaming the project). 
Ensure that Draft Mode is set to No.

13 Select the Subject and Grade.

14 Enter a name for the project; click Save; and then Close. 

15 To make the project available for an assignment, click Send to Assignment Builder. 

16 Click Close and then Exit. 

Assignment Builder displays your new Odyssey Writer project. You can continue to add curriculum or 
complete the assignment. See Task 2: Refine the Assignment on page 50.
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Using an Existing Project as a Template

1 With Odyssey Writer open, select File>Open. 

The Open Project dialog box displays a list of your projects, if any, from the My Projects folder. 

2 If the project you want to use is in a different folder, open the desired folder—District projects, School 
projects, or Odyssey projects—remembering that you need permission to access the District projects and 
School projects folders. 

3 Select the desired project and click Open.

Odyssey Writer displays the project for you to edit and save as a new project. 

Using an Existing Rubric

1 With Odyssey Writer open, select the Rubric tab.

2 Click Open Rubric. 

The Open Rubric dialog box displays any existing rubrics you have created in the My Rubrics folder.

3 To select a rubric from the My Rubrics folder, click the desired rubric.

OR

To select a rubric from the District, School, or Odyssey Rubrics folder, click the folder and then the desired 
rubric.

NOTE    You must have permission to access the District and School Rubrics folders.

4 With the desired rubric selected in the Open Rubric dialog box, click Open.

The contents of the rubric you selected are populated in your new Odyssey Writer project.

5 If desired, make changes to the rubric.

6 When finished, click Save Rubric. 

The Save Rubric dialog box is displayed. 

7 Click the desired folder in which to save the rubric, remembering that you must have permission to save in 
the District and School Rubrics folders and that you cannot save to the Odyssey Rubrics folder.

NOTE    Saving in the My Rubrics folder restricts access so that only you can see and copy 
the rubric.

8 Give the rubric a name; click Save; then Close.

Creating a New Rubric

1 With Odyssey Writer open, select the Rubric tab.

2 Click New Rubric. 

3 Define each category and the performance you expect for each level of quality.
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4 When finished, click Save Rubric. 

The Save Rubric dialog box is displayed. 

5 Click the desired folder in which to save the rubric, remembering that you must have permission to save in 
the District and School Rubrics folders and that you cannot save in the Odyssey Rubrics folder.

NOTE    Saving in the My Rubrics folder restricts access so that only you can see and copy 
the rubric.

6 Give the rubric a name; click Save; then Close.

Web Links on the Instructions Screen

1 From within the Odyssey Writer project, click the Instructions tab.

2 Highlight the word or sentence that you want to appear as a link.

3 From the Odyssey Writer menu bar, select Insert>Hyperlink.

The Insert Hyperlink dialog box is displayed.

4 Type the web address and then click OK.

The highlighted text becomes a hyperlink. When students click on the link in their draft (displayed in the 
Drafting tool), a new browser window opens to the linked page.

5 To change the web link, select the link text and then Insert>Hyperlink.

6 With the Insert Hyperlink dialog box displayed, enter a new web address.

Images and Equations

You can add images or equations to the Instructions and Writing Framework screens. As you work with images 
and equations, note the following: 

• To add text beside or below an image or equation, place the cursor beside the image or equation and press 
Enter (on the keyboard) until the cursor is in the desired location.

• To move an image or equation, click the image or equation to display sizing handles and a Move button. 
Single‐click Move and then click in the area of the desired move location in the screen.

• To remove an image or equation, single‐click the image or equation and press Delete (on the keyboard). After 
you delete an image or equation, you may need to adjust the spacing of remaining text.

Evaluating Odyssey Writer Projects

Teachers can access submitted Odyssey Writer projects in these ways:

• Selecting Assignments>Submitted Projects from Odyssey’s main menu.

• Selecting Assignments. From the Assignments home page, the Submitted Projects button becomes animated 
if submitted but unopened projects are awaiting the teacher’s attention. 
CompassLearning® Odyssey User’s Guide



Odyssey Writer 190
Evaluating Odyssey Writer Projects
When Odyssey Writer opens, the Submitted Projects dialog box displays a list of projects that students have 
turned in. 

TIP    To display a list of all submitted projects—evaluated and unevaluated—first close 
the Submitted Projects dialog box. Then, select File>Open. 

When a teacher opens a project to evaluate, the student’s work is displayed (at right) with the teacher’s rubric 
open (at left). 

The teacher’s 
Rubric tool is 
displayed when 
you first open a 
project.

Note cards DraftingGraphic 
organizer

Self‐assessment

Student’s tools:

Opens one of four 
teacher evaluation tools.

Returns the evaluated project 
to the student.

Displays a 
rubric 
category.

Assigns a 
score.
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Rubrics 

A rubric is a scoring tool that allows teachers to assess student projects by 
measuring them against scoring criteria. A rubric may include up to eight 
scoring sections with a maximum of six criteria per section. Numbers 
displayed across the top of the rubric panel represent categories of the rubric. 
An example of a rubric category is Conventions.

• To evaluate with a rubric, select the appropriate number for each category. 

• To advance to a different category, click a number in the white square.

• To view the self‐assessment rubric the student used, click the self‐
assessment  button.

• To return to the teacher’s version of the rubric, click the teacher evaluation 
button. 

Assigning a Grade 

1 To display the Grade tool, click  . 

2 From the pulldown menu, choose a grade. Available grades are A+, A, A‐, 
B+, B, B‐, C+, C C‐, D+, D, C‐, and F.

Teacher Comments

Teachers can use the Comments tool to write general comments about the student’s work. 

1 To display the Comments tool, click  .

2 From the displayed Teacher Comments box, type comments for the student to read after you have evaluated 
and returned the project.

Annotations

Teachers can use the Annotations tool to include notes and annotations to 
specific parts of the project. 

To display the Annotations tool, click  . 

Common errors include:

• Spelling errors

• Capitalization errors

• Run‐on sentences

• Subject/Verb agreement

• Usage errors

• Punctuation errors

• Sentence fragments

• Improper use of commas
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Inserting Common Error Annotations

1 With the student’s Odyssey Writer project displayed and Annotations tool selected, position your cursor in 
the location for the annotation. 

2 Click the desired annotation button.

Odyssey Writer displays the annotation in the project. This example displays a sample capitalization 
annotation: 

TIP    To delete an annotation, click the annotation and then press the Delete key on the 
keyboard.

Inserting Custom Annotations

Custom annotations you create are available for you to use in all of the 
Odyssey Writer projects you review.

1 With the student’s Odyssey Writer project displayed and the Annotations 
tool selected, select the custom annotation button  . 

Odyssey Writer displays the Custom dialog box.

2 In the Title box, enter a title for your custom annotation.

3 In the Annotations box, enter the annotation text to be displayed in the project.

4 When finished, click OK.

The newly created annotation is displayed as a button beside the custom annotation button.

5 To insert the custom annotation in the project, position your cursor in the location for the annotation and 
then click the custom annotation button.

The custom annotation is displayed in the text.

TIP    To edit a custom annotation, click the custom annotation button for that 
annotation. 

Entering Special Notes

1 With the student’s Odyssey Writer project displayed, position your cursor in the location for the custom note, 
and then Notes button  . 

Odyssey Writer displays a new dialog box.

2 In the dialog box, enter your note text.

3 When finished, click the dialog box’s X button.

The note appears in the student’s project. 

TIP    To edit a note, double‐click the note text; to delete a note, select it and press the 
Delete key on the keyboard.
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Returning an Evaluation to the Student

After you have finished evaluating a student’s Odyssey Writer project, you will return the evaluation to the 
student by clicking the Send button  . The Submitted Projects dialog box is displayed, letting you select 
another project to evaluate. 

Using Odyssey Writer

When students log into Odyssey, they will see a student launch pad that corresponds to their grade level (set in 
their student profile). Odyssey Writer buttons also correspond to the student’s grade level. 

Students may launch Odyssey Writer when they complete an Odyssey Writer assignment; or students may start 
the tool by clicking the launch pad icon. When a teacher returns a graded Odyssey Writer assignment to a 
student, the icon below the Odyssey Writer is animated. 

NOTE    For grades PreK–2: Odyssey Writer is available on the student launch pad only 
after the teacher has evaluated and returned the student’s first Odyssey Writer project. 

Levels PreK–2 Levels 3–5 Levels 6–8 Levels 9–12

Clicking the top button 
launches Odyssey Writer. 

If an evaluated Odyssey Writer 
project is available to review, 
the bottom button is animated.
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The following example displays an Odyssey Writer assignment for a student in grade 5. The assignment includes a 
teacher prompt that the student sees when the assignment is first opened. 

Prewriting

Prewriting is the first stage of the writing process. At this stage, students begin to formulate ideas for their 
writing project. As a prewriting exercise, they can consider the following questions:

• What is the purpose of my writing?

• Who will read my writing?

• What am I going to write about?

Odyssey Writer offers these tools to assist students with prewriting activities:

Student note cards allow students to type notes for 
their project on electronic note cards. The note cards 
form an outline for students to use when writing their 
projects and can be pasted directly into the Outline 
view of the project. 

Teacher note cards serve as hints or even parts of an 
outline to help students through the prewriting 
phase. Teacher note cards appear on the screen 
when students access the Note Cards tool in Odyssey 
Writer. Students can add, edit, and delete their own 

note cards, but they cannot edit or delete a teacher note card. 

Clicking X 
closes the 
prompt.

Click to 
paste the 
prompt to 
the draft.

When the Instructions/Prompts window is closed, clicking the ? toolbar button displays the window again.
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Pinpoint text is a block of text teachers write in their note cards. Students can display pinpoint text from the 
Note Cards tool by pressing the T button (image on left) on a teacher note card. To display pinpoint text from the 
Outline tool, click the blue dot next to the outline item (image on right).

Students may also use a graphic organizer to link ideas together. Students create and position idea boxes to help 
them determine the flow of ideas for their writing project. 

Teachers can create idea boxes that are displayed when students access Odyssey Writer and open the graphic 
organizer. Students may not delete idea boxes a teacher has created. Similar to note cards, an idea box may 
include pinpoint text, notes from the teacher that help students through the writing phase. A pinpoint is marked 
by a small blue dot that is located in the top left corner of an idea box. When students click on the note, a block 
of read‐only text appears.

To add, edit, and delete note cards and idea boxes, students will use special toolbars. 

The contents of the graphic organizer are synchronized with note cards; both the idea boxes and note cards are 
displayed in the outline. Students can paste the outline into the draft to further expand on their writing.

Two idea boxes that are linked.

Click the note button to display more 
information about the idea.

Add a new note card. 

Indent right to increase outline level.

Indent left to decrease outline level.

Delete a note card.

Paste note card to draft.

Add a new idea box. 

Connect idea boxes.

Delete an idea box.

Paste idea box to draft.
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Adding a Note Card

1 To access the Note Cards tool, click the note card   button. 

A toolbar for managing note cards is displayed. 

2 Click the Add button.

The Title dialog box is displayed. 

3 Enter a title for the new note card. When the student saves the note card to a draft, the title appears as a line 
of text in the outline.

4 When finished, click OK.

The new card is displayed as part of the outline in the main panel.

5 Type the information that you want to appear on the note card. When saved to a draft, the note card body 
text is indented under the title text of the outline.

Moving a Note Card

Students can adjust the placement of note cards, thereby adjusting the structure of the outline. 

• To change the indentation, select the note card and then click the indent left or right button from the toolbar. 

• To change the vertical placement, select the note card and drag it to the desired location.

Deleting a Note Card

To delete a note card, select the note card and click the Delete  button from the Note Cards toolbar.

Adding an Idea Box

1 To access idea boxes, click the Graphic Organizer   button. 

A toolbar for managing idea boxes is displayed. If a teacher has created idea boxes, students will see these.

2 Click the Add button.

The Title dialog box is displayed. 

3 Enter a title for the new idea box. The length of the title determines the size of the idea box. When the 
student saves the idea box to a draft, the title appears as a line of text in the outline.

4 To add a note to the idea box, click the note button on the right side of the idea box.

A new box with a text field is displayed.

5 Type a note or change an existing note; to close the note box, click the window’s X button.

Linking Idea Boxes

1 Select an idea box by clicking it.

2 Click the Connect  button. 
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3 Click a second idea box.

NOTE    If an existing idea box is selected when a student adds a new idea box, the two 
idea boxes will be linked together with a link line.

4 To delete the link between two idea boxes, select the link line (by clicking it) and click the Delete button from 
the Graphic Organizer toolbar.

Moving an Idea Box

To adjust the location of an idea box, drag and drop the idea box: left‐click the idea box, and while holding the 
mouse button down, drag the idea box to the new desired location.

Deleting an Idea Box

To delete an idea box, select the idea box and click the Delete  button from the Graphic Organizer toolbar.

Pasting Note Card or Idea Box Text to the Draft

Students can paste text from note cards or idea boxes to a page in the draft. 

1 From the note card or idea box toolbar, click the Paste to Draft  button. 

You are asked to confirm your selection.

2 Click Yes.

The note card or idea box text is pasted to the draft in outline form.

NOTE    You are unable to adjust the location of note card or idea box text after it is pasted 
to the draft.

Using the Outline

The outline is linked to both the note cards and idea boxes. When students paste note card and idea box text to 
draft, Odyssey Writer converts the information into outline form. 

To access the outline, open the draft by clicking the Drafting  button. Then, click the Outline tab.

The outline hierarchy used to display note card text in the draft follows how note cards are indented. That is, the 
first note card you indent is A in the outline; the second indent is at the 1 level; and so on.

The outline hierarchy used to display idea box text follows the position of each idea box. The first idea box is at 
the top level of the outline, and subsequent idea boxes are at the next levels of the outline.

NOTE    The outline cannot be edited when it appears in the side panel; it can only be 
edited when it has been pasted to the draft.
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Drafting

Drafting is the stage during which students put their ideas and thoughts into sentences and paragraphs for the 
first time, beginning the first rough composition of the project. 

When students select File>New Project, a new blank file opens. The free‐form template is the default in the 
Drafting tool. Students can choose a different template from the template bank (Insert>Insert New Page). 

NOTE    If the project includes a prompt from the teacher, the Instructions/Prompts 
window is displayed when the student first opens the project. To begin working on the 
draft, students must close the prompt by clicking the window’s X button. Students can 
open the prompt at any time by clicking  . If the project does not include a prompt, 
this button is disabled.

Students can view an outline of the information they have organized with note cards or idea boxes by clicking the 
Outline tab from the draft. 

Students add the following to their drafts:

• Page

• Hyperlink

• Image

• Equation

Click to paste 
the outline 
to the draft.

Closes the outline.

Display a different page of the draft.

Web links are not available for this project 
(indicated by the dimmed tab).
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Inserting a New Page

1 With the draft displayed, select Insert>Insert New Page. 

The Select Template dialog box displays six templates, with 
the default Free Form template selected.

2 Accept the default or another template and then OK.

A new page is inserted into the project.

Inserting a Hyperlink

Using the Hyperlink option, students can add web links to their 
Odyssey Writer projects. 

1 Highlight the word or sentence you want to appear as a link.

2 Select Insert>Insert Hyperlink.

The Insert Hyperlink dialog box is displayed.

3 Enter the web address and then OK.

The highlighted text becomes a hyperlink, underlined and marked in blue. When you click the hyperlink in the 
draft, a new browser window displays the linked site.

4 To change the hyperlink, carefully select the same text and then Insert>Insert Hyperlink. 

The Insert Hyperlink dialog box displays the web address.

5 Edit the link and then click OK.

Inserting an Image

Students can insert JPG, GIF, TIF, and BMP images that are 
100 KB or smaller into their documents. Uploaded files are 
stored on the server for each user. When the Odyssey Writer 
storage limit has been met, a message informs you that no 
space is available. To free up space for more images, delete 
unused images from your list. 

1 Position your cursor at the point above which you want the 
image to appear.

2 Select Insert>Insert Image. 

The Insert Image dialog box is displayed. 

3 Click Upload.

The Upload Image Tool dialog box is displayed.

4 Browse to the desired image file, and from the Windows File Upload dialog box, click Open. 

The path and file name are displayed in the Upload Image Tool dialog box. 

5 Click Upload. 

The Insert Image dialog box displays the file name and a thumbnail of the image. If the file name and 
thumbnail are not displayed, click Refresh. 

6 To place the image on your page, click the file name and then Insert. 
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Image Tips

• To add text beside or below an image, position the cursor beside the image and press the Enter keyboard key 
repeatedly until the cursor is in the desired location.

• To move an image, select the image, click the Move button, and click the desired target location.

• If an image overlaps another image, cut one of the images and paste it to a new location on the page. Select 
the image; click the Cut  toolbar button; click the desired target location; and click the Paste  toolbar 
button. 

• To delete an image, select the image and press the Delete keyboard key. After you delete an image, you may 
need to adjust spacing inside or between paragraphs.

Inserting an Equation

1 Position your cursor at the point at which you want the equation to appear.

2 Select Insert>Insert Equation. 

The Equation Editor dialog box is displayed. 

3 Using the Equation Editor buttons and keyboard keys, create the desired equation. To clear the equation and 
start over, click Clear. 

The Upload Image Tool dialog box is displayed.

4 When finished, click Insert. 

Equation Tips 

• To edit an equation that has been inserted into an Odyssey Writer project, double‐click the equation. In 
Equation Editor, edit the equation, and when finished, click Insert.

• To add text beside or below an equation, position your cursor beside the equation and press the Enter 
keyboard key repeatedly until the cursor is in the desired location.

• To move an equation, select the equation, click the Move button, and click the desired target location.

• If an equation overlaps another equation, cut one of the equations and paste it to a new location on the page. 
Select the equation; click the Cut  toolbar button; click the desired target location; and click the Paste 

toolbar button. 
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• To delete an equation, select the equation and press the Delete keyboard key. After you delete an equation, 
you may need to adjust spacing inside or between paragraphs.

Saving a Project

Students can save Odyssey Writer projects in these ways:

• Click the Save  toolbar button.

• Select File>Save.

If a student has not yet saved the project, the Save dialog box is displayed, prompting the student to enter a 
project name. If a student chooses a project name that duplicates another project, the project name is not 
accepted. Two projects with the same name can be differentiated only by the date and time. If an Odyssey Writer 
project is teacher‐assigned, the student is not prompted for a project name.

Printing a Project

Students can print Odyssey Writer projects in these 
ways:

• Click the Print  toolbar button.

• Select File>Print.

The Print Preview screen displays the current page 
of the Odyssey Writer project and lets students 
preview and print all or a portion of the project.

To display a different page of the project, click the 
page number.

To print the project, from the Print Preview dialog 
box, click Print. 

Revising

Once students have composed a rough draft, they enter the revision stage. The revising and editing stages may 
be revisited several times, as students integrate changes to their projects based on teacher feedback. Odyssey 
Writer contains some helpful features for revising, such as the Self‐Assessment tool.

Assessing Your Work

Before handing in a project, students can check their work against the rubric to ensure that the project meets all 
criteria. To use a rubric to assess your work, click the Self‐Assessment   toolbar button.
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The rubric appears in the left panel of the screen and the working area remains in the right panel. While in Self‐
Assessment mode, the student can review the rubric categories and modify the text. All features work the same 
as in the Drafting tool. 

A rubric is a scoring tool that allows students to assess their projects by measuring them against scoring criteria, 
as determined by the teacher. A rubric includes a maximum of eight possible scoring sections, with a maximum 
of six criteria in each section. 

The numbers displayed across the top of the rubric panel represent a scoring section of the rubric, such as 
Content. The criteria are listed below the section name, each with an option button students can select.

Teachers can customize the rubric for a project or can choose to use no rubric. When students run Odyssey 
Writer via the student launch pad, if no customized rubric exists for a project, then a generic rubric is used.

To complete the self‐assessment, the student clicks a number along the top to access a scoring section, such as 
Content, and then clicks the option button next to the appropriate criterion. The process continues until all 
scoring sections have been completed. When a student saves a project, the self‐assessment rubric is saved with 
the project.

Students may print rubrics. The Print Preview dialog box allows students to choose the page of the rubric they 
want to print.

Opening a Project

Students can open all of their Odyssey Writer projects in these ways:

• From within Odyssey Writer, select File>Open.

• From within Odyssey Writer, click the Open  toolbar button.

• From the student launch pad, click the upper Odyssey Writer button in the left toolbar. With Odyssey Writer 
launched, you can use File>Open or the Open toolbar button.

NOTE    For grades PreK–2: Odyssey Writer is available on the student launch pad only 
after the teacher has evaluated and returned the student’s first Odyssey Writer project. 
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The following Open dialog box displays all of a student’s Odyssey Writer projects, those that are handed in or not 
yet handed in; and those that are graded and ungraded. 

To display Odyssey Writer projects that a teacher has graded and students have not yet viewed, students will click 
the lower Odyssey Writer button on their launch pad. 

The Open dialog box includes the following information. 

Viewing an Evaluated Project

To view a project that has been evaluated and returned by the teacher—denoted by a date in the Date Graded 
column of the Open dialog box—students select the project name from the Open dialog box and then click 

Field name Description

Name of the Project Project name.

Date Modified Most recent date the student worked on the project.

Date Assigned Date the project was assigned. If this is a free‐form project initiated by the student, this 
field is blank.

Date Completed Date the student handed the project into the teacher.

Date Graded Date the teacher reviewed and graded the project and returned it to the student.

Teacher Name Name of the teacher who assigned the project.
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Open. Graded projects are opened in Teacher Assessment mode, with the student’s editable project on top and 
the teacher’s evaluated, read‐only version on the bottom. 

Error indicators—green text surrounded by double asterisks—enable students to identify the types of errors they 
have made; for example, spelling, run‐on, comma, and so on. Teacher’s notes are blue, underscored text 
surrounded by double asterisks. All material in the teacher’s panel is read‐only and cannot be changed by the 
student.

Using the buttons along the bottom of the left panel, students can view the letter grade, teacher’s comments, 
and how the teacher assessed their work against the rubric. 

Students can print the following parts of the teacher assessment:

• evaluated text

• rubrics

• comments and grade

• note cards

Student’s 
version of the 
project can be 
edited.

Teacher’s 
evaluated 
version of the 
project is read‐
only.

Note from the teacher.

Annotation.

Custom annotation.
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• idea boxes in the graphic organizer

Deleting a Project

Students can delete any of their projects as follows:

1 With the Open dialog box displayed, click the project name.

2 Click the Delete button

3 At the confirmation, click OK. 

After a student deletes a project, the project cannot be retrieved.

Editing

When students begin revising their projects, they have reached the editing stage of writing. They can edit their 
projects by using the spell checker and by cutting and pasting sentences and paragraphs to rearrange the flow of 
text. Students will also use some editing features later, when they revise their projects, based on teacher 
feedback.

Performing Spellcheck 

To check the spelling of an Odyssey Writer project, select 
Tool>Spelling.

Similar to spell checkers in other word processing programs, 
the Odyssey Writer spelling tool searches the document for 
misspellings and prompts the student to either correct the 
spelling or leave as is. To correct spelling, students accept the 
default spelling or select one from the scroll list and then click 
Change. To leave the spelling as is, students click Ignore. To 
replace a word with a spelling of their own choice, students 
may type their word in the Replace With section and click 
Change.

To navigate the document, use the Prev Page and Next Page 
buttons.

NOTE    If you use the scroll bar in the lower box of the Spelling window, the misspelled 
word in your text loses its highlighting. Click anywhere in the text to restore the 
highlighting.

When spell check is complete, you will see an informational message box. Click Close. 
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Editing a Project

Odyssey Writer offers the following editing functions, available through the Edit menu or the editing toolbar 
buttons.

NOTE    Avoid using right‐clicks or keyboard function keys to edit an Odyssey Writer 
project. 

Publishing

The publishing phase includes all steps a student takes to create a final product. Students may use desktop 
publishing features in Odyssey Writer, such as adjusting the fonts, spacing, and alignment.

Formatting a Project

Students can adjust the formatting of their projects using options in the Format menu or formatting buttons in 
the toolbar. 

Edit function Description

Undo Undoes the most recent action. You can toggle between Undo and Redo.

Redo Available only after Undo is selected. Select Redo to revert back to the project’s state before 
selecting Undo. You can toggle between Undo and Redo.

Cut Removes the selected block of text or graphic and copies it to the Clipboard (memory). Students 
cannot cut teacher‐defined note cards and text boxes.

Copy Copies the selected block of text or graphic to the Clipboard without deleting the text or graphic.

Paste Pastes the items from the Clipboard to the Odyssey Writer project.

Delete Page Available from the Edit menu only. To use Delete Page, click on the page to select it, and then 
select the Delete Page option. Note that the page will be deleted with no warning message.

Formatting option Description

Font Applies a font family to new and existing text. To change existing text, select the text and 
then select Format>Font or use the font dropdown menu in the toolbar. Choose from Arial, 
Comic Sans, Helvetica, Times New Roman, or Verdana. 

Font Style Applies a font style to new and existing text. To change existing text, select the text and then 
select Format>Font Style>Bold, Italic, or Underline or the bold, italic, and underline buttons 
in the toolbar. 

Font Size Applies a font size to new and existing text. To change existing text, select the text and then 
select Format>Font Size>Size or the size dropdown menu in the toolbar. Font sizes range 
from 10 points to 24 points. 
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Students can change font color by using the color palette located on the toolbar. 

To display the color palette, click on the color palette button on the toolbar. A color 
is selected by clicking a color square in the palette. The color selection is applied to 
new text entered following the selection and to any text highlighted before or 
subsequent to the color selection.

Handing in a Project

When students are ready to hand in a project, they will use the toolbar Hand‐In button.

1 Click the Hand‐In   button.

2 At the confirmation message, click Yes.

3 If your classes are taught by different teachers, a dialog box lists your and their classes. Select the desired 
teacher and click Send.

4 At the successful submission message, click Close.

5 To send your project to another teacher, repeat steps 1 through 4.

Odyssey Writer FAQs

How does a student hand in an Odyssey Writer project 
from a different activity?

When a student opens Odyssey Writer from another activity and completes a free‐form project, the student 
must save and hand in the project before closing the other activity and logging out. If the other activity is closed 
first, the student will not be able to save or hand in the Odyssey Writer project.

Can student names be printed on Odyssey Writer projects?

Because student names do not appear on project printouts by default, you may instruct students to type their 
names in the text box in the Drafting tool.

May I right‐click within Odyssey Writer?

Odyssey Writer does not support the “right‐click” mouse function. To cut, paste, or use other “right‐click” 
functions, use the buttons on the toolbar or the menu options.

Spacing Applies single‐ or double‐spacing to new and existing text. To change the spacing of existing 
text, select the text and then select Format>Spacing>Single or Double. 

Alignment Aligns new and existing text left, right, or center. To change the alignment of existing text, 
select the text and then select Format>Alignment>Right, Left, or Center or select the 
alignment button from the toolbar. The toolbar also offers left‐margin increase and decrease 
buttons. 

Formatting option Description
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How does a student start typing with the Drafting tool?

Before students can begin typing in the Drafting tool, they must first click in the top left corner of the text box to 
display the cursor.

How does a student move text to the previous page?

To move text from the top of a page back to the previous page, students must use the toolbar button to cut the 
desired text, place the cursor location after the final paragraph on the previous page, and then use the toolbar 
button to paste the cut text. Text cannot be moved back to the previous page with the Backspace key on the 
keyboard.
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District Licensing

For District Administrators

A variety of licensing options are available for CompassLearning Odyssey. Your CompassLearning representative 
sets up licensing at installation time.

• Unlimited licensing allows districts to permit unlimited student logins to Odyssey. No school is limited to a set 
number of licenses. For Enterprise Sites: implementing unlimited licensing successfully depends on the site’s 
server capacity. 

• Single‐user subscription licenses are based on a one‐person, one‐user name access to Odyssey. The number 
of purchased subscriptions is the maximum number of users allowed on the account. For example, if an 
account has 40 subscription licenses, a maximum number of 40 users may be registered in that account and a 
maximum number of 40 users may be online at one time. To add a new student, the account must delete a 
student license or purchase an additional subscription license.

NOTE    Teacher and administrator users are not counted when calculating an account’s 
number of subscription or concurrent licenses.

• Concurrent‐user subscription licenses let students access Odyssey on a first‐come, first‐served basis from a 
pool of licenses. For example, similar to subscription licensing, if an account has 40 concurrent licenses, a 
maximum number of 40 users may be online at one time. The distinction between subscription and 
concurrent licensing is that concurrent licenses allow a larger number of users to be in the database. Also, 
concurrent licensing allows the account to add new users to the database without purchasing additional 
subscription licenses.

BEST PRACTICE    Ensure that districts and schools evaluate planned Odyssey use and 
work with their CompassLearning representative to adapt the best model for their 
environment. 

User Accounts

At installation time, your CompassLearning representative will set up district and school administrator accounts 
and district reports administrator accounts. A district may have multiple district and district reports 
administrators; each school may have only one school administrator.
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District administrators and school administrators (with permissions) can create and edit teacher accounts at any 
time. The following table summarizes the account tasks of each user role will typically perform:

NOTE    For more information about permissions in Odyssey, see Permissions on page 
253. For details about creating class and student accounts, see Classes and Students on 
page 27.

Depending on your user role, you will make account changes with the appropriate Profile dialog box. District 
administrators use the District Administrator Profile dialog box to make changes to their own or another district 
administrator’s profile.

NOTE    To create new administrator accounts, contact CompassLearning Support.

Changes to a school administrator’s account are made with the Administrator Profile dialog box. District 
administrators can change contact information and permissions; school administrators can change contact 

User Tasks

District administrator • Edit own account.

• Edit school administrator’s account.

• Create and edit teacher accounts.

• Create and edit class and student accounts.

District reports 
administrator

Generates district‐wide reports only. This user does not perform 
tasks related to user accounts.

School administrator • Edit own account.

• Create and edit teacher accounts.

• With permission, create and edit class and student accounts.

Teacher • Edit own account.

• With permission, create and edit class and students accounts.

A checkmark denotes a district reports administrator, a 
user who generates district‐wide reports. This user has 
access only to the Reports module. 
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information only. District administrators and school administrators use the New Teacher dialog box to create new 
teacher accounts. When the account is created, teachers can edit their own accounts.

BEST PRACTICE    Avoid using special characters in user names, first names, and last 
names. Special characters include @  ‘  ”  %  $  ~  !  _  ~  . (period).
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User Profiles

You will use the Administrator Profile and New Teacher (or Teacher Profile) dialog boxes to define user profiles. 

User Field Description

District 
Administrator
School 
Administrator
Teacher

First Name Required field. First names can be up to 30 characters in length. 
Avoid using special characters in user names, first names, and last names. Special 
characters include @  ‘  ”  %  $  ~  !  _  ~  . (period).

Middle Initial Optional one‐character field.

Last Name Required field. Last names can be up to 30 characters in length.
Avoid using special characters in user names, first names, and last names. Special 
characters include @  ‘  ”  %  $  ~  !  _  ~  . (period).

User Name Required field. 
User names can be up to 30 characters in length and must be unique.
Avoid using special characters in user names, first names, and last names. Special 
characters include @  ‘  ”  %  $  ~  !  _  ~  . (period).
Simple user names—such as first initial and last name (e.g., jsmith)—are more likely to 
cause problems (because of duplicates) during the import than full names (e.g., 
josephdsmith). 

Password Required field. 
Passwords cannot contain special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  etc.; periods. 
• Teacher passwords must contain a minimum of two letters and two numbers and can 
be up to 30 characters in length. Passwords are not required to be unique.

• School and district administrator passwords must contain a minimum of six letters and 
two numbers and can be up to 30 characters in length. 

Email Address Optional field. The email address must be valid.

Teacher Grade Required field. From the dropdown list, select one value from PreK through High School.
NOTE: A teacher’s access to curriculum is determined by the site’s licenses, not the 
Grade.
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User Access

You will use the Administrator Profile and New Teacher (or Teacher Profile) dialog boxes to specify which areas 
of Odyssey users will be able to access. 

User Field Description

School 
administrator
Teacher

Add Personal 
Information

Grants permission to view and add to Personal Information fields in a student’s profile. 
By default, this feature is turned on.
When unchecked, the user cannot add a new student—the New Student button in the 
Student Index and the Add New Student button in My School or My Classes are not 
available.

Edit Personal 
Information

Grants permission to change Personal Information fields in a student’s profile. By 
default, this feature is turned on.

View Attributes Grants permission to view and attach attributes to a student’s profile. By default, this 
feature is turned on.
When checked, the attributes group is enabled in the Student Index and the Students 
screen when generating a Progress Summary Report. 
When unchecked, the Edit Attributes check box (below) is automatically cleared. In 
addition, the attributes selection is skipped when creating a new student, and hidden in 
the Student Index. Also, the attributes selection is disabled on the Students screen when 
generating a Progress Summary Report.

Edit Attributes Grants permission to edit student profiles. By default, this feature is turned on.
When checked, the attributes group is enabled in the Student Index and Students screen 
when generating a Progress Summary Report. 
When unchecked, the attributes selection is skipped while creating a new student and 
the Attach Attributes button is unavailable in the Student Index.

Edit Subject Level 
Access

Grants permission to specify a student’s subject‐level access in Odyssey. By default, this 
feature is turned on.
When unchecked, all selections on the Subject Level Access and Class Information 
screen are disabled when creating a new student.

Delete Students Grants permission to delete student accounts. By default, this feature is turned off.

Add/Edit Class 
Information

Grants permission to add a new class and edit class information. By default, this feature is 
turned on.
When unchecked, the Edit button for the class account is disabled and the Delete and 
New Class buttons are unavailable. 

Add/Edit Class 
Rosters

Grants permission to add and edit class rosters. By default, this feature is turned on.
When unchecked, the Add to Class button does not appear in the Student Index and the 
Remove and Add Student buttons are unavailable.
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Updating a District Administrator Account

For District Administrators

1 Log into Odyssey as district administrator.

2 From the Welcome screen, select Setup>My Schools.

The grid on the right displays information about the district, including names for the District Account and 
Administrator near the top of the screen.

3 Next to the administrator’s name, click Edit.

4 With the District Administrator Profile dialog box displayed, make your changes.

5 When finished, click Save.

Updating a School Administrator Account

For School and District Administrators

1 Log into Odyssey as district or school administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

Teacher Save assignments • My School allows a teacher to save assignments to the My School location for sharing 
with other teachers in the school. By default, My School is checked for all teachers. 

• My District allows a teacher to save assignments to the district (if in a district) for 
sharing with other teachers in the district. By default, My District is unchecked. Only 
district administrators can enable My District.

Manage 
assessments 
(available for 
licensed schools)

• Print Tests allows a teacher to view and print PDFs of objective‐based tests for offline 
administration.

• Scan Results allows a teacher to import the results of objective‐based tests 
administered offline. 

For more information, see Offline Tests on page 268.
• Custom Assessment Features gives a teacher access to Item Bank, Item Builder, and 
Objective Builder. With School checked, a teacher can save custom objectives and 
custom test items to the school standard set or item bank. With District checked, a 
teacher can save custom objectives and custom test items to the district standard set or 
item bank.

Save Odyssey 
Writer Projects 
(available for 
licensed schools)

• School allows a teacher to save Odyssey Writer projects to the school location for 
sharing with other teachers in the school. The default setting is unchecked. 

• District allows a teacher to save Odyssey Writer projects to the district location for 
sharing with other teachers in the district. The default setting is unchecked.

User Field Description

Clicking the bottom Edit button displays the 
District Administrator Profile dialog box.
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3 From the displayed tree, locate the desired school and click the school name.

The grid on the right displays information about the selected school, including names for the Account and 
Administrator near the top of the screen. 

4 Next to the administrator’s name, click Edit.

5 With the Administrator Profile dialog box displayed, make your changes. School administrators can make 
changes to their login information; district administrators can make changes to login information and 
permissions.

6 When finished, click Save.

Creating a New Teacher Account

For School and District Administrators

1 Log into Odyssey as school or district administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

3 From the displayed tree, locate the desired school and click the school name.

4 Above the grid listing the school’s teachers, click New Teacher. 

5 In the New Teacher dialog box, enter the teacher’s login information and permissions.

6 When finished, click Save. 

BEST PRACTICE    When creating more than five teacher accounts, consider using the 
teacher import feature. See Teacher and Student Data Import on page 224.

Deleting a Teacher Account

BEST PRACTICE    Before you delete a teacher’s account, review which assignments made 
by the teacher will be deleted and unassigned and which assignments will remain 
available for students and reporting.

For School and District Administrators

1 Log into Odyssey as school or district administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

3 District administrators: From the displayed tree, locate the desired school and click the school name.

4 With teacher names displayed in the grid on the right, check one or multiple teachers and click Delete. 

You will see a message asking you to confirm the deletion. Deleting a teacher’s account also deletes any of 
that teacher’s work in progress in the Item Bank and Objective Builder.

Clicking the bottom Edit button displays the Administrator Profile 
dialog box to make changes to the school administrator’s account.
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5 To delete the teacher’s account, click OK. To cancel the deletion, click Cancel.

A second messages asks you whether to unassign all assignments made by the teacher.

6 To unassign all assignments made by the teacher, click OK.

OR

To continue to make the assignments available for students and reporting, click Cancel.

NOTE    With the teacher account deleted and any assignments still assigned, the 
Assignment Status will show that the assignment is NOT OWNED. 

Updating a Teacher Account

1 Log into Odyssey.

2 From the Welcome screen, depending on your role, select Setup>My Classes (teacher), Setup>My School 
(school administrator), or Setup>My Schools (district administrator).

3 From the displayed tree, locate the desired teacher and click the teacher name.

4 Above the grid listing the teacher’s classes and next to the teacher’s name, click Edit. 

5 With the Teacher Profile dialog box displayed, make your changes. Teachers can make changes to their login 
information; school and district administrators can make changes to login information and permissions.

6 When finished, click Save.

NOTE    Changes made to teacher permissions may take several hours to take effect.

Local School ID Codes

For School and District Administrators

A school’s local ID code is unique to each school in the district and may be used to identify the school when you 
import data into Odyssey. 

Creating a Local School ID Code

BEST PRACTICE    Use a four‐digit number for your local school ID.

1 Log into Odyssey as school administrator or district administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.
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3 From the displayed tree, locate the desired school and click the school name.

The grid on the right displays information about the selected school, including names for the Account and 
Administrator near the top of the screen.

4 Next to the Account name for the school, click Edit.

The Contact page displays account information for the school.

5 In the Local School ID Code field, type a unique code and then Next.

6 Click Next until you reach the Confirmation screen. 

7 From the Confirmation screen, click Save.

Time Zones

For School and District Administrators

Odyssey includes a worldwide list of 73 times zones. District administrators set time zones and Daylight Saving 
Time (DST) for districts and schools. School administrators can override time zone and DST settings for their own 
schools. After the time zone and DST for a school is set, all locations in the Odyssey application that display start 
times or completion times display the correct time for that time zone.

NOTE    DST is enabled by default.

Setting the Time Zone and DST

1 Log into Odyssey as school administrator or district administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

3 From the displayed tree, locate the desired school and click the school name.

The grid on the right displays information about the selected school, including names for the Account and 
Administrator near the top of the screen.

4 Next to the Account name for the school, click Edit.

The Contact page displays account information for the school.

5 From the Time Zone dropdown list, select the desired time zone.

6 Set Daylight Saving Time to correspond to your local observance and then Next.

7 Click Next until you reach the Confirmation screen. 

Clicking Edit displays account 
information for the school.
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8 From the Confirmation screen, click Save.

NOTE    Time changes may take several hours to take effect.

Progress Alert Passwords

For School and District Administrators

A decision point on a scored learning activity may include a progress alert as an option for nonmastery of the 
activity. In this case, if the student does not master (or pass) the activity, the folder is locked and a progress alert 
is displayed on the student’s screen. Teachers unlock a progress alert at the student’s workstation or by logging in 
with their teacher user name and password and using the Assignment Status screen. Unlocking a progress alert 
at a student’s workstation requires a progress alert password.

The default progress alert password is unlock99.

District administrators set progress alert passwords for individual schools in the district. School administrators 
can set the passwords for their own schools. Passwords must be alphanumeric and contain at least two alpha and 
two numeric characters. The system will not accept accented characters, punctuation marks, special symbols 
(e.g., %, #, @, >, +), or spaces in passwords.

BEST PRACTICE    To maintain security, consider changing this password periodically. 
Because this change affects an entire school, ensure that you have a communication plan 
in place to notify all users in the school that the progress alert password has changed.

Setting the Progress Alert Password

NOTE    When Odyssey is first installed, the password to unlock a progress alert is 
unlock99. 

1 Log into Odyssey as school administrator or district administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

3 From the displayed tree, locate the desired school and click the school name.

The grid on the right displays information about the selected school, including names for the Account and 
Administrator near the top of the screen.

4 Next to the Account name for the school, click Edit.
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5 From the Contact page, click Next.

The License page displays account information for the school.

6 In the Enter Password field, highlight the default password and enter a unique password, remembering that 
passwords must be alphanumeric and contain at least two alpha and two numeric characters. The system will 
not accept accented characters, punctuation marks, special symbols, or spaces in passwords. 

7 Enter the same password in Confirm Password and then Next.

8 Click Next until you reach the Confirmation screen. 

9 From the Confirmation screen, click Save.

Mastery Level

For School and District Administrators

The mastery level is the passing percentage for a scored activity, lesson quiz, objective‐based test, or chapter 
test. School and district administrators can change the mastery level—termed Passing Percentage in the school 
account’s License screen—for a school. Mastery levels are set also on decision points and objectives in custom 
objective‐based tests.

NOTE    A mastery level set on an individual decision point or for objectives in a custom 
objective‐based test (built with Test Builder) overrides the mastery level (Passing 
Percentage) set at the school level. 

Enter and confirm a new 
progress alert password for 
the school.
CompassLearning® Odyssey User’s Guide



Setup and Configuration 220
Update History
Changing the Mastery Level for a School 

1 Log into Odyssey as school administrator or district administrator.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

3 From the displayed tree, locate the desired school and click the school name.

The grid on the right displays information about the selected school, including names for the Account and 
Administrator near the top of the screen.

4 Next to the Account name for the school, click Edit.

5 From the Contact page, click Next.

The License page displays account information for the school.

6 In the Passing Percentage field, change the value. 

7 Click Next until you reach the Confirmation screen. 

8 From the Confirmation screen, click Save.

Update History

For School and District Administrators

District administrators and school administrators can display the Account Changes Report to list details about 
the account. Whenever a change is made to the account, a new row is added to the report at the top of the 
appropriate area of the report, which is organized into three sections—basic account and licensing information, 
district administrator information, and activation and reactivation information. To see changes, compare 
columns in a previous row with the columns in the newly added row.

Basic account information and licensing information

Date and Time User School District Account Name School Code

Local School ID Code Lab Number Address 1 City Zip Code

State Country Time Zone Daylight Saving Time Phone Number

District Level Licenses Number of Licenses Type of License Active Account Enterprise Account

Enrollment Period Enrollment Start Date Enrollment End Date Service End Date State Standard

Lesson Quiz % Chapter Test% Local Content Server Referred by OW Storage

Changed Progress 
Alert Password

Account Permissions Content Permissions EAS NWEA EAS STATE

CAHSEE CSTGM LDAP Authentication LDAP Path LDAP SSL

DN Prefix DN Suffix LDAP Authentication 
Admin

LDAP Authentication 
Teacher

LDAP Authentication 
Student

LDAP Authentication 
Parent

District administrator information

ID Date and Time Admin First Name Admin Last Name Admin User Name

Changed Admin 
Password

Admin Email Address
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The Account Changes Report displays licensed curriculum content in the Content Permissions column. The 
following table defines the three‐part code: 

Activation and reactivation information

ID Lab Number Account ID Version First Activation Time

Last Activation Time User Name

Attribute One Attribute Two Attribute Three

Code Definition Code Definition Code Definition

1
2
3
4

Active Curriculum
Active assessment Explorer
Active assessment Explorer Florida
Active assessment Explorer Texas

A1
A2
AL
BI
BB
CH
EE
ES
E1
E2
E3
E4
FA
FM
GE
LA
LE
ME
SM
MA
MC
PS
PH
PB
SP
SC
SS
TP
TR
GV
H1
HS
WH

Algebra I
Algebra II
Honors Algebra
Biology
Brain Buzzers
Chemistry
ELL Elementary
ELL Secondary
English I
English II
English III
English IV
Focus Algebra
Focus Math
Geometry
Language Arts
Language Arts Extensions
Macroeconomics
MATEMATICAS
Math
Microeconomics
Physical Science
Physics
Playbox Theme Time
Public Speaking
Science
Social Studies
Thematic Projects
Trigonometry
US Government
US History I
US History II
World History

‐2
‐1
0
1
2
3
4
5
6
7
8
13

All grades
PreKindergarten
Kindergarten
First grade
Second grade
Third grade
Fourth grade
Fifth grade
Sixth grade
Seventh grade
Eighth grade
High school
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Consider these examples of codes in the Account Changes Report: 

NOTE    If a district is licensed for all core and additional curriculum and assessment, the 
Content Permissions column in the Account Changes Report will be empty.

The coded descriptions correspond to the curriculum displayed on the account’s two Product License screens. 
The first Product License screen displays account information for K‐8 curriculum and options for Odyssey Writer, 
printing and scanning, and test translator. 

3,MA,8 Explorer Florida, Math, Eighth grade

1,AL,‐2 Honors Algebra

1,LA,0 Language Arts, Kindergarten
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The second Product License screen displays high school curriculum. 

Displaying Update History

1 Log into Odyssey as school or district administrator.

2 From the Welcome screen, select Setup>My School or Setup>My Schools.

The grid on the right displays information about the school or district, including names for the Account and 
Administrator near the top of the screen.

3 Next to the Account name for the school or district, click Edit.

4 From the Contact screen, click Show Update History.

The Account Changes Report is displayed in a new window.

School account 
(school administrator 
user).

District account 
(district administrator user).
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9 Teacher and Student Data Import
For School and District Administrators

With the Import tool, you can create or update teacher and student records directly from a comma‐separated 
value (CSV) file. Importing teachers and students is a two‐part process, including these general tasks:

Task 1: Verifying the CSV File Format

Task 2: Importing Teacher and Student Data

When you use the Import tool to update records, the two Maintain Profile values control the import as follows: 

• Yes adds new information to an existing record without making other changes to the record.

• No overwrites an existing record with the information in the import file.

NOTE    You are unable to update a user name through an import. 

Consider the following example of updating student passwords through an import:

The passwords for all of the students in Odyssey must be changed. In the CSV import file, change the Password 
column for all students. To ensure all other fields in the student records remain the same, set Maintain Profile to 
Yes.

NOTE    All imports are performed offline. Large imports are queued for off‐peak load 
time.

CSV Import Files

CSV files are ASCII text files with one record per line and a comma separating the fields. To ensure that your 
import file is in the proper format, use the Teacherimport and Studentimport templates on the Resources page 
(under Support). These template CSV files are packaged in separate zipped directories along with checklists. The 
checklists are also available as an appendix in this manual: Data Import Checklists on page 259 and online in the 
Import tool wizard. 

BEST PRACTICE    Rename your import files to include teacher‐import and student‐
import in the name.

To minimize the potential for error, consider breaking up larger import files into one or 
multiple smaller CSV files. 
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Task 1: Verifying the CSV File Format

Before importing the CSV file into Odyssey, verify that the file contains all required columns, as well as any 
optional columns you want to import. The file does not need to contain all optional columns available in the 
template. 

Teacher Import File

The following table lists the columns in the teacher import file. Asterisks denote columns that require data. 
Include and populate any of the optional columns necessary for your import.

BEST PRACTICE    Avoid using special characters in user names, first names, and last 
names. Special characters include @  ‘  ”  %  $  ~  !  _  ~  . (period). 

Teacher import column  Description

* User Name Required field. 
User names can be up to 30 characters in length and must be unique.
Simple user names—such as first initial and last name (e.g., jsmith)—are more likely to 
cause problems (because of duplicates) during the import than full names (e.g., 
josephdsmith). 

* Password Required field. 
Teacher passwords must contain a minimum of two letters and two numbers and can be 
up to 30 characters in length. 
Passwords cannot contain special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  etc.; 
periods. 
Passwords are not required to be unique.

* First Name Required field. First names can be up to 30 characters in length.

Middle Initial One‐character optional field.

* Last Name Required field. Last names can be up to 30 characters in length.

* Grade Required field. Enter one of the following:
‐1 for PreK
0 for Kindergarten
1 through 8 for grades 1–8 
13 for high school
NOTE: A teacher’s access to curriculum is determined by the site’s licenses, not the 
Grade.

My School Y or y; or empty. 
This setting lets teachers save their assignments to the My School folder so that other 
teachers in the school can access the assignments.

My District Y or y; or empty. 
This setting lets teachers save their assignments to the My District folder so that 
teachers at other schools within the same district can access the assignments.

Email Valid email address.

School Custom Assessment 
Features

Y or y; or empty. 
The school must be licensed for custom assessment features.

District Custom 
Assessment Features

Y or y; or empty. 
The school must be licensed for custom assessment features and be in a district. 
CompassLearning® Odyssey User’s Guide



Teacher and Student Data Import 226
CSV Import Files
Print Tests Y or y; or empty. 
The school must be licensed for printing/scanning.

Scan Results Y or y; or empty. 
The school must be licensed for printing/scanning.

School Odyssey Writer 
Project Permissions

Y or y; or empty. 
This setting lets other teachers in the school access the custom Odyssey Writer projects.

District Odyssey Writer 
Project Permissions

Y or y; or empty. The school must be in a district. 
This setting lets other teachers in the school district access the custom Odyssey Writer 
projects. 

Add Personal Information Y or y; or empty. 

Edit Personal Information Y or y; or empty. 

View Attributes Y or y; or empty. 

Edit Attributes Y or y; or empty. 

Edit Subject Level Access Y or y; or empty. 

Delete Students Y or y; or empty. 

Add Edit Class Information Y or y; or empty. 

Add Edit Class Rosters Y or y; or empty. 

Classes Creates a new class for this teacher.
NOTE: You can create one new class per teacher through the import. To create 
additional classes for a teacher, use the Setup module in Odyssey Manager.

Lab Number Destination school ID.
Use this field if you are importing teachers from multiple schools. The Lab Number 
column must contain the Lab Number for the destination school, with an entry for each 
teacher record.
NOTE: An empty cell in the Lab Number column causes the import to stop or fail.
If you do not use the Lab Number column, a separate import file is required for each 
school. If you are importing data for an individual school—logged in as a school 
administrator, for example—delete the empty Lab Number column from the data file. 
School administrators will perform data imports for individual schools only. Typically, 
district administrators will perform data imports for multiple schools, requiring Lab 
Number values.

Operation Type If you do not specify an Operation Type, Odyssey examines existing records and, for 
each line in the import file, adds a new, unique record or updates an existing record. 

If you specify Operation Type, use one of the following values:

• A or a for add. If Odyssey finds an existing, matching teacher record, that line in the 
import file is not processed. 

• D or d for delete. Exercise caution when you use the delete operation. The delete 
operation cannot be undone.

• U or u for update. If Odyssey does not find an existing, matching record, that line in 
the import file is not processed. 

Teacher import column  Description
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Student Import File

The following table lists the columns in the student import file. Asterisks denote columns that require data. 
Include and populate any of the optional columns necessary for your import.

BEST PRACTICE    Avoid using special characters in user names, first names, and last 
names. Special characters include @  ‘  ”  %  $  ~  !  _  ~  . (period).

Student import column Description

* User Name Required field. The student uses the User Name to log into Odyssey.
User names can be up to 30 characters in length and must be unique.
Consider using the Student School ID for the user name.
Simple user names—such as first initial and last name (e.g., jsmith)—are more likely to 
cause problems (because of duplicates) during the import than full names (e.g., 
josephdsmith).

* Password Required field. Passwords can be as short as one character and up to 30 characters in 
length. 
Passwords cannot contain special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  etc.; 
periods. 
Although passwords are not required to be unique, setting up unique passwords helps 
to ensure that the account is not accessed by someone other than the user.

First Name Optional but strongly recommended. 
First names can be up to 30 characters in length.

Middle Initial Optional one‐character field.

Last Name Optional but strongly recommended. 
Last names can be up to 30 characters in length.

* Grade Required field. Enter one of the following:
‐1 for PreK
0 for Kindergarten
1 through 8 for grades 1–8
13 for high school

Student School ID Each student’s Student School ID must be unique and can be up to 256 characters in 
length. An example of a common value is the student’s social security number. No 
special formatting is required. Values for the Student School ID column are optional.
NOTE: For sites using the Test Translator, the Student School ID is required.

SIF Provided Student ID Schools Interoperability Framework (SIF) numbers are generated by an external 
program and cannot be manually created. SIF Provided Teacher ID numbers must be 
unique and 36 characters in length with four embedded dashes, as in the following 
example: 
0CE365AD‐D45E‐44d1‐ 83E1‐31479CAF2F76F

Parent User Name Unique user name. For security, each parent use name connects to only one student.

Parent Password Unique password.

Gender M or m or F or f.

Nationality Enter Y or y for only one of the following nationalities:
• American Indian/Alaskan Native

• Asian/Pacific Islander

• Hispanic

• Black/Non‐Hispanic

• White/Non‐Hispanic

• Other Race or Ethnicity
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ESL/ESOL/ELL/LEP Y or y; or empty. 

Title I Math Y or y; or empty.

Title I Reading Y or y; or empty.

Speech Y or y; or empty. 

LD Y or y; or empty.

Physically Challenged Y or y; or empty.

ESE/Special Needs Y or y; or empty.

Attendance Concern Y or y; or empty.

Free or Reduced Lunch Y or y; or empty.

Hearing Impaired Y or y; or empty.

Economically 
Disadvantaged

Y or y; or empty.

Migrant Y or y; or empty.

Continuous Enrollment Y or y; or empty.

Gifted Y or y; or empty.

After School Programs Y or y; or empty.

Intervention 1 or 2 or 3. 

Class Name Name of an existing class in the target school.

Lab Number Destination school ID.
Use this field if you are importing teachers from multiple schools. The Lab Number 
column must contain the Lab Number for the destination school, with an entry for each 
teacher record.
NOTE: An empty cell in the Lab Number column causes the import to stop or fail.
If you do not use the Lab Number column, a separate import file is required for each 
school. If you are importing data for an individual school—logged in as a school 
administrator, for example—delete the empty Lab Number column from the data file. 
School administrators will perform data imports for individual schools only. Typically, 
district administrators will perform data imports for multiple schools, requiring Lab 
Number values.

Operation Type If you do not specify an Operation Type, Odyssey examines existing records and, for 
each line in the import file, adds a new, unique record or updates an existing record. 

If you specify Operation Type, use one of the following values:

• A or a for add. If Odyssey finds an existing, matching student record, that line in the 
import file is not processed. 

• D or d for delete. Exercise caution when you use the delete operation. The delete 
operation cannot be undone.

• U or u for update. If Odyssey does not find an existing, matching record, that line in 
the import file is not processed. 

• T or t for transfer. Use this value only if you are preparing the file to use with 
Odyssey’s auto import tool.

Student import column Description
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Task 2: Importing Teacher and Student Data

NOTE    You can also use the CompassLearning import client to import teacher and 
student data into Odyssey Manager. See Import Client on page 265.

Importing Teacher Data

NOTE    You are unable to update a teacher’s user name by importing a CSV file. To update 
a teacher’s user name, edit the teacher’s profile in Odyssey Manager.

1 In the navigation bar, select Setup>Tools.

2 At the Tools home page, click Import.

3 District administrators: From the Select School screen, select a school from the dropdown list. Or, select 
School is specified in file to be imported. When finished, click Next.

4 From the Select File screen, select Teacher Data from the Import Type dropdown.

5 To import new teacher records or to update teacher records, adding to existing data without overwriting, 
leave the default Yes selected for Maintain Profile. 

OR

To overwrite data in the teacher records, set Maintain Profile to No. 

6 To select the CSV file you want to import, click Browse and navigate to the desired file. 

7 With the desired CSV file displayed, double‐click the file name and then Next.

8 When finished, click Next. 

9 The Confirmation screen displays teacher data in the grid. To import the data, click Import.

Odyssey queues the import for offline processing. 

10 Click Done.

You are returned to the Tools home page. 

Importing Student Data

NOTE    You are unable to update a student’s user name by importing a CSV file. To update 
a student’s user name, edit the student’s profile in Odyssey Manager.

1 In the navigation bar, select Setup>Tools.

2 At the Tools home page, click Import.

3 District administrators: From the Select School screen, select a school from the dropdown list. Or, select 
School is specified in file to be imported. When finished, click Next.

4 From the Select File screen, select Student Data from the Import Type dropdown.
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5 To import new student records or to update student records, adding to existing data without overwriting, 
leave the default Yes selected for Maintain Profile. 

OR

To overwrite data in the student records, set Maintain Profile to No. 

6 To select the CSV file you want to import, click Browse and navigate to the desired file. 

7 With the desired CSV file displayed, double‐click the file name and then Next.

8 When finished, click Next. 

9 The Confirmation screen displays student data in the grid. To import the data, click Import.

Odyssey queues the import for offline processing. 

10 Click Done.

You are returned to the Tools home page. 

Displaying Import History

1 From the Tools home page, click Import. 

2 District administrators: From the Select School screen, select the school name from the dropdown and then 
Next.

3 From the Select File screen, click Show History.

4 The Data Import History window displays import history. To display details about an individual import, click 
the link.
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For School and District Administrators

The Odyssey Transfer tool lets administrators transfer students’ demographic and performance data—including 
assignments, assessments, and customized curriculum—to a different school. Additionally, you can use the 
Transfer tool to transfer assignments and assessments. Transferring assignments and assessments may be useful 
for districts that require separate servers.

NOTE    District administrators may transfer students between schools in the district. 
School administrators may transfer students out of and into their school only.

The following diagram illustrates transferring student data from one school to another in the same district. In the 
top scenario, School A transfers the student data out, and School B transfers the student data in. School 
administrators from both schools may perform the tasks for their respective school. Alternately, the district 
administrator might transfer student data directly from School A to School B as shown in the bottom scenario. 

School District 1

School A

Odyssey Server

Task 2. 
School B transfers 
student data in.

Task 1. 
School A transfers 
student data out.

Odyssey Manager 
prepares a transfer 
package and places it on 
the server.

School A

Transfer 
Package

School District 1

School A

Odyssey Server

One Task. The district administrator transfers student data directly from School A to School B.

School A

Transfer 
Package
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When the originating and destination schools are managed by separate Odyssey servers, the administrator will 
download the transfer file and move it to the destination server before importing the transfer file into the 
destination school or district. The following diagram illustrates this process.  

NOTE    You can transfer student records individually or in groups.

Odyssey manages students’ assignments differently depending on the district of the originating and destination 
schools. 

When students transfer  Their assignments

to a different district become inactive in the originating school and are not affected by subsequent changes 
at the originating school. Any matching assignments are updated to match the 
assignments in the destination school.

between schools within the 
same district

are still owned by and are active in the originating school. Any changes to them in the 
originating school will be seen by the student. For continuity, the student is still linked 
to the original assignments, Odyssey Writer projects, and objective‐based tests.

Administrator’s 
Workstation

School District 1

School A

Odyssey Server 1

School B

Task 2. 
A district or school administrator downloads 
the transfer file to a workstation.

Task 1. 
School A transfers 
student data out.

Transfer 
Package

Odyssey Manager 
prepares a transfer 
package and places it 
on the server.

School C

School District 2

School X

Odyssey Server 2

School Y

Transfer 
Package

School Z Task 3. 
The administrator moves the transfer file—
through email, a jump drive, a shared drive, 
ftp site, or another method—to the 
destination Odyssey server. 

NOTE: Moving the transfer file is not 
required if the administrator’s workstation 
has direct access to the destination Odyssey 
server.

Task 4. 
School X transfers 
student data in.
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Rules for transfers

• Transfers are limited to 100 MB per file. The maximum number of students, assignments, or assessments you 
can transfer depends on the amount of data associated with each record.

• Complete student transfers before you begin end‐of‐year procedures.

• To facilitate data searches and storage, perform exports before transferring student records.

• Performance data for transferred students remains in the Odyssey database—marked inactive at the 
originating school. You are able to export this data. 

• If you are transferring students within the district, student records are linked to their previous assignments. To 
include previous assignment results in reports, ensure that you instruct Odyssey to include data from previous 
schools and, if applicable, select reporting By Type (instead of By Assignment). Exception: if the assignment is 
a district assignment that both schools share, the previous restriction does not apply.

NOTE    For aggregated reports, only district‐level assignments are available.

Student Transfer

Transferring Student Records out of a District or School

BEST PRACTICE    Transfer student records out of a district or school at a time when they 
are not and will not be logged into Odyssey until the transfer is completed.

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 The Select Transfer Type screen is displayed with the default Students selected. Click Next. 

4 District administrators: With the default Out of your district selected, select a school from the dropdown list. 
This school is the originating school out of which students will transfer. When finished, click Next.

OR

School administrators: With the default Out of your school selected, click Next.

5 From the Select Data screen, search for the student records you want to transfer. Select the desired search 
criteria and then Search. 

6 The grid displays student records matching your criteria. Check the students you want to transfer and then 
Next. 

7 Give the transfer a name and enter a password and email address. When finished, click Next.

NOTE    Use alphanumeric characters only—a–z, A–Z, and 0–9—when you create the 
password. Passwords cannot contain spaces.

8 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.
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9 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 7. Additionally, the student record is marked inactive in the originating school or 
district.

10 If the originating and destination schools are managed by the same Odyssey server, transfer the student 
records into the destination school. See Transferring Student Records into a District or School below.

OR

If the target and destination schools are managed by separate Odyssey servers, do the following:

• Download the transfer file. See Downloading a Transfer File on page 240.

• Provide the destination school with the transfer file.

• At the destination school, transfer the students records into the destination school. See Transferring 
Student Records into a District or School below.

Transferring Student Records into a District or School

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 The Select Transfer Type screen is displayed with the default Students selected. Click Next. 

4 District administrators: Select Into your district and the desired destination school from the dropdown list. 

OR

School administrators: Select Into your school and then Next.

5 If the originating and destination schools are managed by the same Odyssey server, you will not upload data. 
Select No and enter the transfer ID and password you received in the notification email. 

OR

If the originating and destination schools are managed by separate Odyssey servers, select Yes and browse to 
the file you want to upload. Finally, enter the password you received in the notification email.

6 When finished, click Next. 

7 Choose whether students will continue working on previous assignments.

8 Enter one or multiple email addresses for transfer notification and then Next.

9 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.

10 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 8.
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Transferring Student Records between Schools in a District

For District Administrators

When you transfer student records to another school in the same district, the student record is linked to previous 
assignments. Changes made to assignments, Odyssey Writer projects, and objective‐based tests are reflected in 
the newly transferred student’s record.

BEST PRACTICE    Transfer student records between district schools at a time when they 
are not and will not be logged into Odyssey until the transfer is completed.

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 The Select Transfer Type screen is displayed with the default Students selected. Click Next. 

4 Select Between schools in your district and an originating school and a destination school from the two 
dropdown lists. 

5 When finished, click Next.

6 From the Select Data screen, search for the students records you want to transfer. Select the desired search 
criteria and then Search. 

7 The grid displays student records matching your criteria. Check the students you want to transfer and then 
Next. 

8 Choose whether students will continue working on previous assignments.

9 Enter one or multiple email addresses for transfer notification and then Next.

10 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.

11 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 9.

NOTE    Student records are marked active in the destination school but are no longer 
available at the originating school.

Assignment Transfer

Use the Transfer tool to package one or multiple assignments into a transfer file. Assignments that are 
transferred into a school or district are marked as Not Owned.

NOTE    The destination account must have the correct curriculum and assessment 
licenses to receive the transfer.
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Transferring Assignments out of a District or School

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 From the Select Transfer Type screen, select Assignments and then Next. 

4 District administrators: With the default Out of your district selected, select the district or a school from the 
dropdown list. This selection is the location of the folder to which the assignment is saved. When finished, 
click Next.

OR

School administrators: With the default Out of your school selected, click Next.

5 From the Select Data screen, search for the assignments you want to transfer. Select the desired search 
criteria and then Search. 

6 The grid displays assignments matching your criteria. Check the assignments you want to transfer and then 
Next. 

7 Give the transfer a name and enter a password and one or multiple email addresses. When finished, click 
Next.

NOTE    Use alphanumeric characters only—a–z, A–Z, and 0–9—when you create the 
password. Passwords cannot contain spaces.

8 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.

9 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 7.

10 If the originating and destination schools are managed by the same Odyssey server, transfer assignments into 
the destination school. See Transferring Assignments into a District or School below.

OR

If the target and destination schools are managed by separate Odyssey servers, do the following:

• Download the transfer file. See Downloading a Transfer File on page 240.

• Provide the destination school with the transfer file.

• At the destination school, use the following procedure to transfer the assignments into the destination 
school. See Transferring Assignments into a District or School below.

Transferring Assignments into a District or School

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 From the Select Transfer Type screen, select Assignments and then Next. 
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4 District administrators: Select Into your district and the district or a school from the dropdown list. This 
selection is the location of the folder to which the assignment will be saved. 

OR

School administrators: Select Into your school and then Next.

5 If the originating and destination schools are managed by the same Odyssey server, you will not upload data. 
Select No and enter the transfer ID and password you received in the notification email. 

OR

If the originating and destination schools are managed by separate Odyssey servers, select Yes and browse to 
the file you want to upload. Finally, enter the password you received in the notification email.

6 When finished, click Next. 

7 Choose whether transferred assignments should overwrite existing assignments.

8 Enter one or multiple email addresses for transfer notification and then Next.

9 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.

10 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 8.

Assessment Transfer

Odyssey packages test items by grade level or an entire standard set with all associated items into a transfer file.

NOTE    The destination account must have the correct curriculum and assessment 
licenses to receive the transfer.

Transferring Assessments out of a District or School

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 From the Select Transfer Type screen, select Assessments and then Next. 

4 District administrators: With the default Out of your district selected, select the district or a school from the 
dropdown list. This selection is the district or school standard set or item bank. When finished, click Next.

OR

School administrators: With the default Out of your school selected, click Next.

5 Select the desired standard set and then Next.

OR

Select test items, subject and grade level, and then Next. 
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Assessment Transfer
6 Give the transfer a name and enter a password and one or multiple email addresses. When finished, click 
Next.

NOTE    Use alphanumeric characters only—a–z, A–Z, and 0–9—when you create the 
password. Passwords cannot contain spaces.

7 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.

8 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 6.

9 If the originating and destination schools are managed by the same Odyssey server, transfer the assessments 
into the destination school. See Transferring Assessments into a District or School below.

OR

If the target and destination schools are managed by separate Odyssey servers, do the following:

• Download the transfer file. See Downloading a Transfer File on page 240.

• Provide the destination school with the transfer file.

• At the destination school, transfer the assessments into the destination school. See Transferring 
Assessments into a District or School below.

Transferring Assessments into a District or School

1 In the navigation bar, select Setup>Tools.

2 From the Tools main page, click Transfer.

3 From the Select Transfer Type screen, select Assessments and then Next. 

4 District administrators: Select Into your district and the district or a school from the dropdown list. This 
selection is the location at which the standard set or test items will be saved. 

OR

School administrators: Select Into your school and then Next.

5 If the originating and destination schools are managed by the same Odyssey server, you will not upload data. 
Select No and enter the transfer ID and password you received in the notification email. 

OR

If the originating and destination schools are managed by separate Odyssey servers, select Yes and browse to 
the file you want to upload. Finally, enter the password you received in the notification email.

6 When finished, click Next. 

7 If you are transferring a standard set, define the standard set as the new active standard set or a read‐only 
standard set. If desired, rename the standard set.

OR

If you are transferring test items, choose whether the transferred test items should overwrite existing test 
items.

8 Enter one or multiple email addresses for transfer notification and then Next.
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Transfer History
9 From the Confirmation screen, review the transfer’s definition. To make changes, click the desired Edit 
button. Make your change and then click Next until you reach the Confirmation screen.

10 Click Run and then Done. 

Odyssey queues the transfer file for offline processing. When the transfer is complete, Odyssey emails a 
transfer notification that includes the file transfer name, internally generated ID, and password to the email 
addresses supplied in step 8.

Transfer History

Transfer history displays summary information about transfers performed in the past 30 days. District 
administrators can view transfer history for the district; school administrators can view transfer history for their 
own school. 

Displaying Transfer History

1 In the navigation bar, select Setup>Tools and then Transfer.

2 Select the transfer type—Students, Assignments, or Assessments—and then Next.

3 Select the direction of the transfer:

District administrators:

• Out of your district

• Into your district

• Between schools in your district

School administrators:

• Out of your school

Clicking the link in the 
Status column 
displays details.
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Transfer Download
• Into your school

4 Click Show History.

5 The History window displays a transfer summary. To view details about a transfer, click the link in the Status 
column.

Transfer files that have been exported in the previous 30 days are displayed. The status of your transfer file 
will be one of the following:

Queued. Transfer file queued for offline processing.

Completed. Transfer file exported successfully.

Completed*. Transfer file exported with errors. 

Failed. Transfer file export was unsuccessful.

Transfer Download

You will use the Transfer History Details window to download transfer files. 

NOTE    Transfer files are saved on the Odyssey server for ten days. 

Downloading a Transfer File

1 In the navigation bar, select Setup>Tools and then Transfer.

2 Select the transfer type—Students, Assignments, or Assessments—and then Next.

3 Select the direction of the transfer:

District administrators:

• Out of your district

• Into your district

Clicking Download 
moves the transfer file 
to your local machine.
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Transfer Retry
• Between schools in your district

School administrators:

• Out of your school

• Into your school

4 Click Show History.

5 The History window displays a transfer summary. From the summary line for the transfer file you want to 
download, click the link in the Status column.

6 From the Transfer History Details window, click Download and open the file or save it to your local drive.

Transfer Retry

You will use the Transfer History Details window to retry failed transfers. A transfer may not complete if a match 
is detected between incoming and existing components. The Retry option lets you review the transfer before 
overwriting components.

NOTE    Retrying a transfer overwrites existing components. 

Retrying a Transfer 

1 In the navigation bar, select Setup>Tools and then Transfer.

2 Select the transfer type—Students, Assignments, or Assessments—and then Next.

3 Select the direction of the transfer:

District administrators:

• Out of your district

• Into your district

Clicking 
Retry 
initiates 
the 
transfer 
process 
for the 
checked 
items.

No items were available to process for 
this grade level and subject.
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Transfer Retry
• Between schools in your district

School administrators:

• Out of your school

• Into your school

4 Click Show History.

5 The History window displays a transfer summary. From the summary line for the transfer you want to retry, 
click the link in the Status column.

6 From the Transfer History Details window, check the items you want to transfer.

7 When finished, click Retry.
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11 Data Export
For School and District Administrators

Use the Export tool for exporting student data into a CSV file for you to manipulate in Excel, Access, or another 
data warehouse tool. 

BEST PRACTICE    District administrators may export student data on the entire district. 
Because of Excel’s row limitation, consider breaking up the export if the number of 
student records exceed 3500. 

When you download the file to your desktop, the export file is saved in the ZIP format. Note the date of the 
download in the following example:

Odysseyexport‐Saved02252009.zip

Extract the ZIP file to see the export file in the CSV format. The date of the export is in the file name, as in the 
following example:

OdysseyExport‐Created02252009.csv 

NOTE    Exported student data cannot be imported into a different Odyssey account.

The following table identifies fields that are available to be exported:

Field Description

Account_ID Internally generated account number.

Account_Name Name of the account.

First_Name Student’s first name in the student’s record.

Last_Name Student’s last name in the student’s record.

User_Name Student’s user name in the student’s record.

Grade Grade level in the student’s record. In addition to numerals, this field may include P for PreK, K 
for Kindergarten, and HS for High School.

UserID Value of the Student School ID field of the student’s record.

Type • chapter test

• external test

• external goal

• learning activity

• lesson quiz

• objective

• objective‐based test

• Odyssey Writer
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Exporting Student Data
Summarize data one line per student: When data is summarized one line per student, the following fields are 
available for export for each subject:

Objective‐based test results: When exporting objective‐based test results, the following fields are available for 
export for each test:

Exporting Student Data

1 In the navigation bar, select Setup>Tools and then Export.

2 From the Export Type screen, choose to export Activities or Objective‐based Test Results.

3 When finished, click Next.

4 From the Students screen, search for the students whose data you want to export. Select the desired filters 
and then Search.

5 With the search results displayed, check the desired students and then Next.

Subject • Algebra I

• Algebra II

• Biology

• Brain Buzzers

• Chemistry

• ELL Elementary

• ELL Secondary

• English I

• English II

• English III

• English IV

• Focus Algebra

• Focus Math

• Geometry

• Honors Algebra

• Language Arts

• Language Arts 
Extensions

• Macroeconomics

• Matematicas

• Math

• Microeconomics

• Physical Science

• Physics

• PlayBox Theme 
Time

• Public Speaking

• Science

• Social Studies

• Thematic projects

• Trigonometry

• US Government

• US History I

• US History II

• World History

Level Grade level of the learning activity, lesson quiz, or chapter test.

Objective_Code Numeric code of the objective. For example, EX1MA.1.1.01 is the objective code for the 
Explorer Level 1 Math objective Compare.

Title Title of the learning activity, objective‐based test, objective, chapter test, lesson quiz, or 
Odyssey Writer project.

Test _GUID Internally generated unique ID (GUID). Objective‐based tests, chapter tests, and lesson quizzes 
have a unique test GUID. The test GUID for all objectives in an objective‐based test is the same 
as the test GUID of the objective‐based test.

Score Score of learning activities, chapter tests, lesson quizzes, and objective‐based tests.

Start_Time Start date and time for learning activities, objective‐based tests, chapter tests, and lesson 
quizzes. The start date and time for all objectives in an objective‐based test is the same as the 
start time for the objective‐based test.

Duration Duration, in hhhh:mm:ss, of the activity. An objective does not have a value for duration.

• Account_ID • First_Name • User_Name • UserID • Average score

• Account_Name • Last_Name • Grade • Number of 
activities by type

• Total duration in 
hh:mm:ss

• Pre‐test score • Post‐test score • Percentage gain

Field Description
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Downloading the Exported File
6 From the Curriculum screen, select one or multiple subjects from which to export data, remembering that 
selecting all subjects may exceed the maximum number of allowed columns that common spreadsheet 
applications can handle.

7 Activity data exports only: Check one or multiple types of activity data to export.

8 When finished, click Next.

9 From the Options screen, define the date range of the data to export.

10 Activity data exports only: Check whether to Summarize data one line per student. If desired, check 
Summarize by school and Include an attendance summary. 

11 Objective‐based test results exports only: Summarize data one line per student is checked by default. If 
desired, check Summarize by school. 

12 Activity data exports only: Check whether to include activities that are Scored Only. With this option checked, 
you can specify a Greater than mastery score, if desired.

13 When finished, click Next.

14 In the Confirmation screen, review the definition of the export. To make changes, click Back until you reach 
the desired screen. Make your change and then click Next until you reach the Confirmation screen.

15 When finished, click Export.

Odyssey queues the data for offline processing.

16 Click Done.

The Tools home page is displayed. 

Downloading the Exported File

1 In the navigation bar, select Setup>Tools and then Export.

2 From the Export Type screen, click Show History.

Data files that have been exported in the previous 30 days are displayed.

3 To view status details, click the status link of the export file.

Data files that have been exported in the previous 30 days are displayed. The status of your export file will be 
one of the following:

Queued. Data file queued for offline processing.

Completed. Data file exported successfully.

Completed*. Data file exported with errors. A typical error is to include over 256 columns of data.

Failed. Data file export was unsuccessful.

NOTE    Data files are saved on the Odyssey server for ten days.

4 To download a completed export file, click the status link.

The Export History Details dialog box displays details about the selected file.

5 To download the file, click Download.
CompassLearning® Odyssey User’s Guide



Data Export 246
Downloading the Exported File
6 You are prompted to open the file or save it to your local drive.

When you download the file to your desktop, the export file is saved in the ZIP format with a name similar to 
the following, where Date is the date of the download:

Odysseyexport‐SavedDate.zip

Extract the ZIP file to see the export file in the CSV format with a name similar to the following, where Date is 
the date of the export:

OdysseyExport‐CreatedDate.csv 

NOTE    Each export creates one CSV file. Downloading the same export file on multiple 
days creates multiple ZIP files—one per day.
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12 End of Year
For School and District Administrators

Odyssey’s End of Year tool lets you manage promotion, graduation, assignments, and class enrollment. School 
administrators will use the End of Year tool for students at their school. District administrators will use the tool 
for students at schools in their district.

Graduation and promotion are separate functions in Odyssey. When you select a grade to graduate, Odyssey 
graduates selected students in that grade level only and does not process any other grade levels. When you 
select the highest grade level to promote, Odyssey promotes selected students in that grade level and all grade 
levels below.

• Graduation moves a student out of a school in the Odyssey system. Although student data for graduated 
students is not available for standard reports, the data is available to export.

• Promotion advances a student to the next grade level in the same school. When a student is promoted, the 
student’s subject level access is changed to match the default of their new grade level. Students in all grade 
levels except High School can advance a level and thereby remain in the Odyssey system. For example, if a 
student is in grade 12, selecting Promote to the next grade advances the student out of grade 12 but leaves 
the student in the Odyssey system—at the High School grade level. (Selecting Stay in the same grade keeps 
High School students in the Odyssey system.) 

Additionally, when students advance to the next grade level, Odyssey offers the option of deleting or retaining 
their assignments and class enrollment.

• Student records include assignment and class enrollment information. You can use End of Year tool to delete 
a student’s assignments and/or class enrollment independent of promoting or graduating the student. For 
example, to delete a student’s assignments without promoting the student or changing the student’s class 
enrollment, select Stay in the same grade; check the Assignments box; and deselect the Class Enrollment 
box. 

BEST PRACTICE    Determine in advance who will perform the end‐of‐year procedures — 
the school administrator or the district administrator.
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The following diagram illustrates the end‐of‐year process for a middle school with Grades 6, 7, and 8. Note that 
you will start the process at the highest grade in the school.

BEST PRACTICE    Apply end‐of‐year changes one at a time for each grade level in a 
school. You may use the End of Year tool for individual students as well.

If district schools spanning K–12 all use Odyssey, it is important to coordinate end‐of‐year processes to ensure 
that all students are enrolled in the correct school and grade level for the next academic year. The following 
diagram illustrates the end‐of‐year process for an elementary, middle, and high school in the same school 
district. In this scenario, the Transfer tool is used to transfer Grade 5 and 8 students to their new school. Next, the 
End of Year tool is used to graduate Grade 12 students out of High School. Finally, the End of Year tool is used to 
promote students, starting with the highest remaining grade level in each school, to the next grade level. 

Middle School

Grade 6 Grade 7 Grade 8

Task 2. 
Promote Grade 7 
students.

Task 3. 
Promote Grade 6 
students.

StudentsStudentsStudents Task 1. 
Graduate Grade 8 
students.

Elementary School

Kindergarten

Grade 1

Grade 2

Grade 3

Grade 4

Grade 5

Students

Middle School

Grade 6

Grade 7

Grade 8

Students

High School

Grade 9

Grade 10

Grade 11

Grade 12

Students

Task 1. 
Use the Transfer tool to transfer Grade 5 students 
into Middle School and Grade 8 students into High 
School. These students will remain at the same 
level—Grade 5 and Grade 8—in the new school 
until they are promoted in Task 3. 

Task 2. 
Use the End of Year tool to graduate Grade 12 students.

Task 3. 
Starting with students in the highest remaining grade level at 
each school—Grade 4, Grade 7, and Grade 11—use the End of 
Year tool to promote students to the next level.
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Before You Begin
You will use the following screen in the End of Year wizard to select options for end‐of‐year changes: 

Before You Begin

Before you initiate the end‐of‐year procedures, complete the following tasks:

• Generate all reports on all students required to meet any district implementation plans.

• Ensure that all student transfers have been completed.

• Deactivate students who no longer use Odyssey. Examples are students who have moved out of the district or 
who have special needs and have not been using the program. Authorized users can deactivate student 
records by deleting them from the Student Index.

• For easier data search and storage, it is recommended that you run any necessary exports before performing 
end‐of‐year procedures.

End of Year Rules

BEST PRACTICE    Run the End of Year tool by grade level, starting with the highest grade 
level of students who are graduating, then working your way down.

• You can graduate only one grade level at a time. You can promote multiple grade levels at a time.

• Run the End of Year tool on a day when no other users are on the system. Results from learning activities or 
tests completed on the day End of Year is run may be lost.

No changes are made to students in 
grade levels higher than the specified level.

With Graduate selected, only students in the 
highest selected grade level are graduated.

To apply end‐of‐year changes to a different 
grade level, run the End of Year tool again.

Because High School is the highest grade 
selected for end‐of‐year changes, Promote is 
grayed and unavailable.

To delete a student’s assignments and class enrollment without 
changing their grade level:

1. Select Stay in the same grade.
2. Check the Assignments and Class Enrollment boxes.
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• Students added to a class while End of Year is queued to run will be moved up to the next grade level.

• An End of Year promotion run while an earlier promotion is still queued to run will fail.

• If promoting by class, a student in multiple classes will be promoted multiple times.

• Subject‐level access for a promoted student is set to the default subjects for the new grade level. Access to 
some subjects, such as Algebra, Honors Algebra, ELL, and Matemáticas, must be set in the Student Profile 
after the end‐of‐year changes are applied.

Managing the End of Year Process

As part of end‐of‐year procedures, you will perform the following tasks:

• Applying End of Year Changes below

• Displaying End of Year History on page 251

Applying End of Year Changes

For School and District Administrators

1 In the navigation bar, select Setup>Tools. 

2 From the Tools home page, click End of Year.

3 District administrators: select a school in which to apply end‐of‐year changes and then Next.

4 If you are applying end‐of‐year changes to all students in the school, click Yes and then Next.

OR

If some, but not all, students will be processed, click No and then Next. 

The Select Students screen displays search criteria for you to locate the students. Specify the search criteria 
and click Search. Then, check one or multiple students.

5 From the Options screen, select the highest grade level of the students for end‐of‐year changes. No changes 
will be made to students in grade levels higher than the level you specify. 

6 Select the end‐of‐year action to apply—Graduate; Promote to the next grade; or Stay in the same grade, 
remembering the following:

• If you choose Graduate, you may graduate only one grade level at a time—the grade level selected from 
the Highest grade for the End of Year changes dropdown.

• If the highest grade level selected is High School, the Promote to the next grade option is grayed and 
unavailable.

• If you choose Promote to the next grade, Odyssey promotes the grade level selected from the Highest 
grade for the End of Year changes and all grade levels below.
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7 Choose to delete assignments or class enrollment, or both. To delete a student’s assignments and/or class 
enrollment without promoting or graduating the student, ensure that you select Stay in the same grade.

With Assignments checked, existing assignments for the selected students will be deleted from their launch 
pads.

With Class Enrollment checked, the selected students remain in the Odyssey system but do not belong to any 
classes. (Students retain their existing assignments—unless Assignments is also checked.)

NOTE    If you are graduating a grade level, assignment and class enrollment deletion 
applies to the graduating grade level only. 

8 When finished, click Next.

9 Confirm your settings, making any changes needed using the Back button.

10 When finished, click Run.

11 If End of Year has been run within the last six months, a warning message notes the date of the last time the 
tool was used. To proceed, click OK. Otherwise, cancel the procedure by clicking Cancel.

Odyssey queues the process to be run offline. 

12 Click Done.

Displaying End of Year History

1 In the navigation bar, select Setup>Tools and then End of Year.

2 From the Tools home page, click End of Year.

3 District administrators: select a school in which to run End of Year and then Next.

4 Click Show History.

5 The End of Year History window displays a summary.
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13 Data Deletion
For School and District Administrators

CAUTION    Data deletion is permanent. Ensure that the files to delete are not required or 
in use.

School and district administrators use the Delete Data tool to delete the following Odyssey items for selected 
students:

• Learning activity bookmarks. These do not include bookmarks in chapter tests or objective‐based tests. By 
default, this item is checked.

• Completed Odyssey Writer papers. Papers that students have turned in to their teacher and papers that are 
graded by a teacher and returned to a student. By default, this item is checked.

• Unused Odyssey Writer images. Unused images stored in the Odyssey Writer image bank. By default, this 
item is unchecked.

NOTE    Deleting unused files may improve performance.

Deleting Data

1 In the navigation bar, select Setup>Tools. 

2 From the Tools home page, click Delete Data.

3 District administrators: From the Select School screen, select a school from the dropdown and then Next.

4 From the Select Students screen, specify search criteria:

• Active limits your search to active students. 

• Inactive limits your search to inactive students.

• Class, Grade Level, Name, and Attributes further define your search.

5 When you have specified the search criteria, click Search. 

6 Select the desired students from the grid and then Next. 

7 From the Options screen, check the types of data you want to delete—Learning Activity Bookmarks, 
Completed Odyssey Writer Papers, or Unused Odyssey Writer Images—and then Next.

8 In the Confirmation screen, review your selections. To make changes, click Back until you reach the desired 
screen and then Next until you return to the Confirmation screen.

9 When finished, click Run.

A message informs you that the deletion will be completed within 24 hours.

10 Click Done.
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Access to features in Odyssey Manager is based on user role. The district administrator grants special permissions 
to school administrator and teacher users. 

For District Administrators

Key considerations as you plan permissions in your organization are assignment and data integrity. Consider and 
record the following:

• Who receives the permissions?

• How many people receive those permissions?

• Which Odyssey functionality will each person be allowed to access?

NOTE    Permissions for the district reports administrator are limited to district reports 
only and cannot be changed.

The following table summarizes how Odyssey access is set. Several Odyssey permissions are linked together. For 
example, if Add Personal Information is turned off, the Edit Personal Information and Edit Subject Level Access 
permissions are also turned off.

NOTE    A standard user has access permission by default; a special user must be granted 
permission. 

Functional 
Area

Feature
District 
Administrator

School 
Administrator

Teacher

Assignments Saving assignments to 
My Assignments folder.

Not available Not available Standard user

Saving assignments to 
My School folder.

Grants permission Grants permission Special user

Saving assignments to 
My District folder.

Grants permission Not available Special user

Assessments Using Test Builder. Not available Not available Standard user

Printing tests. Grants permission Not available Special user

Scanning test results. Grants permission Not available Special user

Using custom assessment tools. Grants permission Not available Special user

Saving test items in the school’s 
item bank.

Grants permission Grants permission Special user

Saving test items in the district’s 
item bank.

Grants permission Not available Special user
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Permissions Use Cases

Example: Review Process for Custom Test Items in a District

Consider setting Odyssey permissions as part of creating a review process for a district to develop custom test 
items.

1 Grant permission to a group of teachers to write custom test items for specific grade levels. They might save 
them in the Item Bank or associate them with new objectives within Objective Builder.

2 Grant permission to the Director of Assessment (or another designated person or group) to review the newly 
developed test items and objectives.

3 After the test items and objectives are created, the Director of Assessment may create tests that can be saved 
for use across the district.

Odyssey 
Writer

Saving Odyssey Writer projects 
for own use.

Not available Not available Standard user

Saving Odyssey Writer projects 
for school use.

Grants permission Grants permission Special user

Saving Odyssey Writer projects 
for district use.

Grants permission Not available Special user

Tools Importing student and teacher 
data.

Standard user Standard user Not available

Transferring student records. Standard user Standard user Not available

Performing end‐of‐year tasks. Standard user Standard user Not available

Deleting data. Standard user Standard user Not available

Allocating school licenses. Standard user Not available Not available

Exporting student data. Standard user Standard user Not available

Student 
profiles

Adding personal information. Grants permission Grants permission
Special user

Special user

Editing personal information. Grants permission Grants permission
Special user

Special user

Viewing attributes. Grants permission Grants permission
Special user

Special user

Editing student attributes. Grants permission Grants permission
Special user

Special user

Editing a student’s subject and 
level access.

Grants permission Grants permission
Special user

Special user

Deleting students. Grants permission Grants permission
Special user

Special user

Class profiles Adding and editing class 
information.

Grants permission Grants permission
Special user

Special user

Adding and editing class rosters. Grants permission Grants permission
Special user

Special user

Functional 
Area

Feature
District 
Administrator

School 
Administrator

Teacher
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Example: Sharing Objectives and Assessments Across the District

Grant permission to the Curriculum Director (or another designated person or group) to determine which 
objectives and assessments will be used. Centralizing this function may ensure consistency across the district.

Example: Printing Tests

NOTE    To maintain the integrity of test items, it is strongly recommended that printing 
permissions be limited to key, strategic personnel at the district level.

A district may want to offer testing in the same format as high‐stakes testing. Or, a district may want to allow 
large‐scale testing when students’ access to computers is limited.

CAUTION    Do not use printed test items for instructional purposes. Using test items for 
instruction negates the item’s ability to test an objective. Test items cannot be printed 
separately. Test items may only be printed in the context of a complete test.

Example: Scanning Tests

To collect accurate test scores and Odyssey prescriptions, consider granting scanning permission to one or two 
Teacher Specialists in each curriculum area. The Teacher Specialists may be working directly with the 
Accountability Director to perform the scanning and importing process (which includes a results review). 

For example, School A administers a test online. School B administers the same test offline (paper version) and 
scans the results back into the Odyssey Manager. With the ability to print tests and scan in the results, the district 
can aggregate and disaggregate data simultaneously for accountability reports. As a result, both School A and 
School B have individualized learning paths for all students who took the test—online and offline.
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Consistent use of naming conventions across your organization is critical for tracking student and teacher 
information, classes, and assessment pieces. 

Classes

Consistently named classes help administrators locate the classes for reporting. Additionally, class names that are 
consistent across the district are critical for interpreting data across the district.

NOTE    To ensure that the entire class name is displayed in all reports, limit the name to 
no more than 35 characters. 

Consider the following two best practices for class names: 

Tests and Assignments

Following naming conventions ensures that all users can locate tests and assignments more easily. This is 
especially critical when tests and assignments are shared.

For tests or assignments, the recommended naming convention is:

test creator or school name.subject.grade.topic 

Scenario Example Elements

A teacher is assigned to only one class, but teaches 
multiple subjects. 
This format will be used more often in the lower 
grade levels.

4Jones‐Central 4: Grade
Jones: Teacher Name
Central: School Name

A teacher is assigned to more than one class and in 
multiple subject areas, or multiple classes of the 
same subject area. 

MA4Smith‐Westwood MA: Subject (Math)
4: Grade
Smith: Teacher Name
Westwood: School Name

MA4Smith‐Westwood‐ESL MA: Subject (Math)
4: Grade
Smith: Teacher Name
Westwood: School Name
ESL: Specialty Class ID
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Reports
Consider the following example test names: 

Reports

When saving reports settings, predetermined naming conventions allow users to locate a specific report quickly.

NOTE    To ensure that the entire name is displayed in a report, limit the report name to 
no more than 45 characters. 

For reports, the recommended naming convention is:

group date data student‐group 

Consider the following example report names: 

Transfer Files

Transfer files are created when students transfer into, out of, or between schools.

NOTE    Limit the transfer file name to no more than 35 characters.

Use the following naming convention when naming files created during the transfer process.

Scenario Example Elements

A teacher creates a test for grade 7 
language arts.

Smith.RLA.7.Poetic Analysis Smith: Test Creator
RLA: Subject (Reading and Language Arts)
7: Grade
Poetic Analysis: Topic

Pre and Post can be added to test 
names to ensure timely 
administration of required 
benchmarks.

PUSD.MA4.Fractions‐Pre‐test PUSD: School Name
MA: Subject (Math)
4: Grade
Fractions‐Pre‐test: Topic

PUSD.MA4.Fractions‐Post‐test PUSD: School Name
MA: Subject (Math)
4: Grade
Fractions‐Post‐test: Topic

Example Elements

Westwood 082004 – Math Gains on B1‐6 on T1 Westwood: Group (Westwood Elementary)
082004: Date (August 2004)
Math Gains on B1‐6: Data (Math Benchmarks 1‐6)
T1: Student Group (Title 1)

Sunset Dist Nov04 – Geometry overview – M‐FRL Sunset Dist: Group (Sunset Valley District)
Nov04: Date (November 2004)
Geometry overview: Data (Geometry Objectives)
M‐FRL: Student Group (Male, Free/Reduced Lunch)
CompassLearning® Odyssey User’s Guide



Naming Conventions 258
Test Items
school name_data type_ transfer direction_date 

Consider the following example transfer file name:

Test Items

Because custom test items are typically created for a variety of purposes, include a portion of both the question 
and the answer. This strategy assists in both linking the item to objectives and analyzing data from reports. 

If you are creating a custom test item for a specific objective in a district‐wide assessment, use part or all of the 
objective code in the name of the item. In the following example, it is immediately clear that the test item 
belongs to the objectives:

Objectives

Standard sets include three levels of hierarchy, from top to bottom: strand, substrand, and objective.

Numbering strands and substrands and adding a subject code to the objective are recommended. You can use a 
similar format to your state standards or develop a new convention based on custom district curriculum. 
Consider using the following format to name an objective:

Subject.Grade Level_Strand.substrand code.objective number_ Shortened Objective 

Using this naming convention, the standard set is written as follows:

Example Elements

Lakeview_Students_Out_1‐23‐05 Lakeview: School Name
Students: Data Type. Other data types include assignments 
and assessments.
Out: Direction. Direction may also be In and Between.
1‐23‐05: Date

Objective Item

RLA.7_1.2.01_Analyze word choice RLA.7_1.2.01.01_persuasive language

Strand: 1 Reading Analysis

Substrand: 1.1 Informational Texts

Objective: RLA.7_1.1.01_Analyze word choice

Substrand: 1.2 Poetry

Objective: RLA.7_1.2.01_Analyze word choice
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C Data Import Checklists
Use the following checklists to prepare for using the Import tool to import student and teacher data into 
CompassLearning Odyssey. 

NOTE    If you require assistance, please contact Customer Support.

Importing Teacher Data into Odyssey

Who is responsible for providing the teacher data? 

Name 

Phone number 

Email address 

Form completed by 

1 Does the school have a unique 
school code?

� Yes 
� No 

A unique school code minimizes duplicate user names when importing. If 
requesting a change to the code, enter the new code here:

NOTE: Ensure that you provide the school code to CompassLearning and the 
change is made before you import data. Odyssey cannot determine whether 
a school code is in use by another site.

2 Does the data file contain these 
required columns: User Name, 
Password, First Name, Last Name, 
and Grade?

� Yes 
� No

These columns are required to complete the import process. If the import 
file does not contain data in these required columns, the import will fail.

3 Is each value in the User Name 
column unique?

� Yes 
� No 

User names can be up to 30 characters in length and must be unique. 
Avoid using special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  etc.; or 
punctuation marks.
Simple user names—such as first initial and last name (e.g., jsmith)—are 
more likely to cause problems (because of duplicates) during the import than 
full names (e.g., josephdsmith). 

4 Does each password contain a 
minimum of two letters and two 
numbers?

� Yes 
� No 

Teacher passwords must contain a minimum of two letters and two numbers 
and can be up to 30 characters in length. Passwords cannot contain special 
characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  etc.; periods.
Passwords are not required to be unique.

5 Do the First Name and Last Name 
columns contain special 
characters?

� Yes 
� No

First and last names can be up to 30 characters in length.
Avoid using special characters, such as @  ‘  ”  %  $  ~  !  _  ~  etc.; accents; or 
punctuation marks.
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6 Have you copied the data into the 
teacher import template file?

� Yes 
� No

To download an import template file, log into Odyssey Manager as a school 
or district administrator user and select Content>Resources. The student and 
teacher import files are located in the Support section of this page. You may 
also email Customer Support at support@compasslearning.com.

7 Have you copied the data into a 
customer‐created CSV file?

� Yes   � No

8 Have you copied the data into a 
file type other than CSV?

� Yes 
� No

If Yes, please note the file type here:

9 Will teachers need to be able to 
share assignments they create 
with other teachers in the school?

� Yes 
� No

If Yes, the My School column must contain Y or y. This setting lets teachers 
save their assignments to the My School folder so that other teachers in the 
school can access the assignments.

10 Will teachers need to be able to 
share their assignments with other 
teachers in the school district?

� Yes 
� No

If Yes, the My District column must contain Y or y and the school must be in a 
district. This setting lets teachers save their assignments to the My District 
folder so that teachers at other schools within the same district can access 
the assignments.

11 Does the data file include email 
addresses for teachers?

� Yes 
� No

The Email column can contain any valid email address.

12 Will teachers need to be able to 
use the school’s custom 
assessment features in Odyssey 
Manager?

� Yes 
� No

If Yes, the School Custom Assessment Features column must contain Y or y. 
Additionally, the school must be licensed for custom assessment features.

13 Will teachers need to be able to 
use the district’s custom 
assessment features in Odyssey 
Manager?

� Yes 
� No

If Yes, the District Custom Assessment Features column must contain Y or y. 
Additionally, the school must be licensed for custom assessment features and 
be in a district.

14 Will teachers need to be able to 
print printable objective‐based 
tests?

� Yes 
� No

If Yes, the Print Tests column must contain Y or y. Additionally, the school 
must be licensed for printing/scanning.

15 Will teachers need to be able to 
scan in results for objective‐based 
tests administered offline?

� Yes 
� No

If Yes, the Scan Results column must contain Y or y. Additionally, the school 
must be licensed for printing/scanning.

16 Will teachers need to be able to 
create custom Odyssey Writer 
projects for the school?

� Yes 
� No

If Yes, the School Odyssey Writer Project column must contain Y or y. This 
setting lets other teachers in the school access the custom Odyssey Writer 
projects.

17 Will teachers need to be able to 
create custom Odyssey Writer 
projects for the district?

� Yes 
� No

If Yes, the District Odyssey Writer Project column must contain Y or y. 
Additionally, the school must be in a district. This setting lets other teachers 
in the school district access the custom Odyssey Writer projects.

18 Will teachers need to be able to 
edit a student’s Personal 
Information in the student’s 
profile?

� Yes 
� No

If Yes, the Edit Personal Information column must contain Y or y.

19 Will teachers need to be able to 
add Personal Information to a 
student’s profile?

� Yes 
� No

If Yes, the Add Personal Information column must contain Y or y. 

20 Will teachers need to be able to 
view a student’s attributes in the 
student’s profile?

� Yes 
� No

If Yes, the View Attributes column must contain Y or y.

21 Will teachers need to be able to 
edit a student’s attributes in the 
student’s profile?

� Yes 
� No

If Yes, the Edit Attributes column must contain Y or y. With this setting, the 
View Attributes column must also be set to Y or y.

22 Will teachers need to be able to 
edit a student’s subject‐level 
access?

� Yes 
� No

If Yes, the Edit Subject Level Access column must contain Y or y.
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23 Will teachers need to be able to 
delete a student from the school’s 
account?

� Yes 
� No

If Yes, the Delete Students column must contain Y or y.

24 Will teachers need to be able to 
add or edit class names?

� Yes 
� No

If Yes, the Add Edit Class Information column must contain Y or y.

25 Will teachers need to be able to 
add or edit class rosters?

� Yes 
� No

If Yes, the Add Edit Class Rosters column must contain Y or y.
Please list class(es) here:

26 Are you adding a new class for 
each teacher? 

� Yes 
� No

If Yes, the Classes column must contain the name of the class.
NOTE: You can create one new class per teacher through the import. To 
create additional classes for a teacher, use the Setup module in Odyssey 
Manager. 

27 Will teachers from multiple 
schools be included in the import 
file? 

� Yes 
� No

Use the Lab Number column to import teachers into the Lab Number school. 
The Lab Number column must contain the Lab Number for the destination 
school, with an entry for each teacher record.
NOTE: An empty cell in the Lab Number column causes the import to stop or 
fail.
If you do not use the Lab Number column, a separate import file is required 
for each school. If you are importing data for an individual school—logged in 
as a school administrator, for example—delete the empty Lab Number 
column from the data file. School administrators will perform data imports 
for individual schools only. Typically, district administrators will perform data 
imports for multiple schools, requiring Lab Number values.

28 Is Operation Type specified for 
each teacher?

� Yes 
� No

If you do not specify an Operation Type, Odyssey examines existing records 
and, for each line in the import file, adds a new, unique record or updates an 
existing record. 
If you specify Operation Type, use one of the following values:
• A or a for add. If Odyssey finds an existing, matching teacher record, that 
line in the import file is not processed. 

• D or d for delete. Exercise caution when you use the delete operation. The 
delete operation cannot be undone.

• U or u for update. If Odyssey does not find an existing, matching record, 
that line in the import file is not processed. 
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Who is responsible for providing the student data? 

Name 

Phone number 

Email address 

Form completed by 

1 What type of licensing was 
purchased?

� Concurrent licensing  � Subscription licensing

2 If subscription licensing, does the 
import file contain only the 
number of records equal to the 
number of subscription licenses?

� Yes  � No

3 Does the school have a unique 
school code?

� Yes 
� No 

A unique school code minimizes duplicate user names when importing. If 
requesting a change to the code, enter the new code here:

NOTE: Ensure that you provide the school code to CompassLearning and the 
change is made before you import data. Odyssey cannot determine whether 
a school code is in use by another site.

4 Does the data file contain these 
required columns: User Name, 
Password, and Grade?
Are First Name and Last Name 
included?

� Yes 
� No

User Name, Password, and Grade are required to complete the import 
process. If the import file does not contain data in the User Name, 
Password, and Grade columns, the import will fail. 
Values in the First Name and Last Name columns are strongly recommended 
for generating meaningful reports with Odyssey Manager.

5 Are you using the NWEA Test 
Translator with Odyssey?

� Yes 
� No

If Yes, for the NWEA test import to be successful, each student’s record in the 
import file must include the student's unique school ID in the Student School 
ID column.

6 Does the User Name column 
contain special characters?

� Yes 
� No

User names can be up to 30 characters in length. 
Avoid using special characters, such as @  ‘  ”  %  $  ~  !  _  ~  etc.; accents; or 
punctuation marks. 
Consider using the Student School ID for the user name.
Simple user names—such as first initial and last name (e.g., jsmith)—are 
more likely to cause problems (because of duplicates) during the import than 
full names (e.g., josephdsmith).

7 Does the Password column 
contain special characters?

� Yes 
� No

Passwords may be as short as a single character or up to 30 characters in 
length. 
Passwords cannot contain special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  
etc.; accents; or punctuation marks.

8 Do the First Name and Last Name 
columns contain special 
characters?

� Yes 
� No

First and last names can be up to 30 characters in length. 
Avoid using special characters, such as @  ‘  ”  %  $  ~  !  _  ~  etc.; accents; or 
punctuation marks.

9 Have you copied the data into the 
student import template file?

� Yes 
� No

To download an import template file, log into Odyssey Manager as a school 
or district administrator user and select Content>Resources. The student and 
teacher import files are located in the Support section of this page. You may 
also email Customer Support at support@compasslearning.com. 

10 Have you copied the data into a 
customer‐created CSV file?

� Yes  � No
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11 Have you copied the data into a 
file type other than CSV?

� Yes 
� No

If Yes, please note the file type here:

12 Is each student’s Student School 
ID unique?

� Yes 
� No

Each student’s Student School ID must be unique and can be up to 256 
characters in length. An example of a common value is the student’s social 
security number. No special formatting is required. Values for the Student 
School ID column are optional.
NOTE: For sites using the NWEA External Assessment System, the Student 
School ID is required.

13 Are you importing SIF Provided 
Student ID numbers?

� Yes  � No

14 Are the SIF numbers correctly 
formatted and unique for each 
student?

� Yes 
� No

SIF numbers are created by a program and cannot be manually created. SIF 
Provided Student ID numbers must be unique and 36 characters in length 
with four embedded dashes, as in the following example: 
0CE365AD‐D45E‐44d1‐ 83E1‐31479CAF2F76F

15 Will you include a Parent User 
Name and Parent Password for 
parents to view their child’s 
progress?

� Yes 
� No

If a parent has more than one child registered in Odyssey, the parent’s User 
Name must be unique for each child. 
Passwords cannot contain special characters, such as @  ‘  ”  %  $  ~  !  ‐  _  ~  
etc.; accents; or punctuation marks.

16 Does the import file include values 
for the Gender column?

� Yes 
� No

For male, enter M or m. For female, enter F or f. Values for the Gender 
column are optional.

17 Does the import file contain values 
for the ethnicity columns?

� Yes 
� No

The import template file has six separate columns for ethnicity. For each 
student, only one of the six columns can contain a value. Enter a Y or y in the 
column that corresponds to the student’s ethnicity. Any other characters and 
empty cells are ignored.

18 Does the import file include values 
for other attributes, including (but 
not limited to) Title I Math, 
Physically Challenged, or After 
School?

� Yes 
� No

Enter a Y or y in the appropriate column. Other characters and empty cells 
are ignored.

19 Are the intervention tier levels in 
the import file correctly 
formatted?

� Yes 
� No

Enter 1, 2, or 3 in the Intervention column. Other characters and empty cells 
are ignored.

20 Do you want students to be 
assigned to a class?

� Yes 
� No

Use the Class Name column to import the students into the Class Name class 
at the destination school. The Class Name class must exist at the destination 
school.
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21 Will students from multiple 
schools be included in the import 
file?

� Yes 
� No

Use the Lab Number column to import students into the Lab Number school. 
The Lab Number column must contain the Lab Number for the destination 
school, with an entry for each student record.
NOTE: An empty cell in the Lab Number column causes the import to stop or 
fail.
If you do not use the Lab Number column, a separate import file is required 
for each school. If you are importing data for an individual school—logged in 
as a school administrator, for example—delete the empty Lab Number 
column from the data file. School administrators will perform data imports 
for individual schools only. Typically, district administrators will perform data 
imports for multiple schools, requiring Lab Number values.

22 Is Operation Type specified for 
each student?

� Yes 
� No

If you do not specify an Operation Type, Odyssey examines existing records 
and, for each line in the import file, adds a new, unique record or updates an 
existing record. 
If you specify Operation Type, use one of the following values:
• A or a for add. If Odyssey finds an existing, matching student record, that 
line in the import file is not processed. 

• D or d for delete. Exercise caution when you use the delete operation. The 
delete operation cannot be undone.

• U or u for update. If Odyssey does not find an existing, matching record, 
that line in the import file is not processed. 

• T or t for transfer. Use this value only if you are preparing the file to use 
with Odyssey’s auto import tool.
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The CompassLearning import client checks for the following types of data to import into Odyssey Manager:

• External test results

• Teacher and student records

When you install the client, you will specify the frequency at which the client performs automatic checks. When 
the client performs a check and data is available, the client initiates an import. 

Installing the Import Client

You can install the import client from the Odyssey Manager media or from the Customer Support website.

1 If you are installing from media: Insert the Odyssey Manager media into the drive and do one of the 
following:

• If the Update Odyssey query appears, click No to stop the Odyssey update.

• If the Odyssey Setup Welcome window appears, click Cancel to stop the Odyssey setup.

Next, on the media, navigate to the ImportClientSetup folder and open the folder to locate the Setup 
executable.

2 If you are installing from the Customer Support site: Open a browser window and browse to this location:

http://support.compasslearning.com/filecenter/download/178.asp 

From the Support site, download the file to your desktop.

3 Double‐click the Setup executable.

4 From the Welcome screen of import client setup wizard, click Next.

The License Agreement screen is displayed.

5 To agree to the terms and continue with the installation, select I agree and then click Next.

6 From the Configuration Settings page, in the Web Services Location field, enter the URL for the location of 
the Odyssey installation.

7 Note the default setting for Time to execute and Time Interval.

The import client performs an automatic check for downloads every 10 minutes for one hour starting at 
1:00 A.M. every day. You may change the default settings, if desired.

8 Change the Data and Log folder location to the path of your Inbound folder.

9 When finished, click Next. 

10 Accept the installation folder destination, and click Next.

11 At the Confirm page, click Next to start the installation.

The process installs a Windows client and a Windows service.

12 At the Installation Complete page, click Close.
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13 If you are installing from media: Remove the Odyssey Manager media from the drive.

14 From the Start menu, select Programs>CompassLearning Tools>Import Client.

On first use of the client, you must log in with an administrator user name, password, and school code.

15 Log in with the district administrator user name, password, and school code.

Changing the Import Client Configuration

1 From the Start menu, select Programs>CompassLearning Tools>Import Client.

2 From the import client tool, from the Tools menu, choose Configure.

3 Make the desired changes, and click Save Settings.

Importing NWEA Test Results

1 Ensure that the NWEA test results file name includes CL.

2 Save the CSV file to the directory configured to be the source directory for inbound files.

The import client checks for files automatically. The default setting is every 10 minutes for one hour starting 
at 1:00 A.M.

Managing Student and Teacher Records

To use the import client to automatically add, delete, or update student or teacher records, prepare the student 
or teacher import CSV file. Additionally, you may transfer student records with the tool. To ensure that your 
import file is in the proper format, use the Studentimport or Teacherimport template on the Resources page 
under Support. The template CSV file is packaged in a separate zipped directory along with a checklist with 
directions on use. See also Teacher and Student Data Import on page 224.

Depending on the desired operation, you will use one of the following values in the Operation Type field of the 
student import CSV file:

• A or a for add. If Odyssey finds an existing, matching student record, that line in the import file is not 
processed. 

• D or d for delete. Exercise caution when you use the delete operation. The delete operation cannot be 
undone.

• U or u for update. If Odyssey does not find an existing, matching record, that line in the import file is not 
processed. 

• Student records only: T or t for transfer. Use this value only if you are preparing the file to use with Odyssey’s 
auto import tool.

Importing student records with the import client

1 Using a student import template, populate the file with the students’ information, remembering that each 
student record must have a unique student ID.

2 In the CSV file, replace the Lab Number column header with Account ID. 
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3 Populate the Account ID column with the school’s unique ID. If your school does not already have a unique 
ID, you can create one. See Creating a Local School ID Code on page 216.

BEST PRACTICE    Use a four‐digit number for your local school ID.

4 Rename the CSV file to include student and the account ID in the name.

5 Save the CSV file to the directory configured to be the source directory for inbound files.

The import client checks for files automatically. The default setting is every 10 minutes for one hour starting 
at 1:00 A.M.

Importing teacher records with the import client

1 Using a teacher import template, populate the file with the teachers’ information.

2 In the CSV file, replace the Lab Number column header with Account ID. 

3 Populate the Account ID column with the school’s unique ID. If your school does not already have a unique 
ID, you can create one. See Creating a Local School ID Code on page 216.

BEST PRACTICE    Use a four‐digit number for your local school ID.

4 Rename the CSV file to include teacher and the account ID in the name.

5 Save the CSV file to the directory configured to be the source directory for inbound files.

The import client checks for files automatically. The default setting is every 10 minutes for one hour starting 
at 1:00 A.M.
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NOTE    To access the Odyssey offline testing features, a site must be licensed for offline 
tests and a teacher must have permission to print tests and scan results.

For Teachers

Odyssey includes offline testing capability, letting teachers administer printed objective‐based tests and then 
scan the results into Odyssey. Learning paths are then automatically given to students based on the scores that 
are imported into the system. 

BEST PRACTICE    After completing an assignment with an offline objective‐based test, do 
not edit the assignment to make the objective‐based test online. Instead, make a copy of 
the assignment. 

Objective‐based tests meeting certain requirements can be printed and administered offline. The results are 
imported into Odyssey. 

For an assignment to be offline, it must contain one and only one objective‐based test. The test must:

• Contain only multiple‐choice test items.

• Not be randomized.

• Not contain test items that have audio.

NOTE    The results for a test administered offline are displayed in reports and the Student 
Portfolio only after those results are imported into the system. If a learning path is given 
based on a student’s score, it will be displayed on the student’s launch pad only after the 
test results are imported. 

Administering Offline Tests

Administering an offline test includes the following general tasks:

Task 1: Create an Assessment to be Administered Offline below

Task 2: Administer Test on page 269

Task 3: Scan Test Results on page 269

Task 4: Import Offline Test Results on page 269
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Task 1: Create an Assessment to be Administered Offline

1 Using Test Builder, create a custom objective‐based test, remembering that Randomize Items must be turned 
off. For complete instructions, see Building a Custom Objective‐based Test on page 75.

2 Print the test. See Printing an Assessment for Review on page 78.

3 Assignment Builder should be open. To finalize the assignment, click Complete Assignment.

NOTE    The results for a test administered offline are displayed in the Student Portfolio 
only after those results are imported into the system. If a learning path is given based on 
a student’s score, it will be displayed on the student’s launch pad only after the test 
results are imported.

4 Finalize the assignment, remembering to Make objective‐based test offline. See Task 3: Finalize the 
Assignment on page 53.

Task 2: Administer Test

Using the test you printed and the NCS Pearson Answer Sheet (No. 221666), administer the test. Students bubble 
in their names, other identifiers, and answers on the scannable sheets. 

Task 3: Scan Test Results

Run the scan sheets through the Scantron© ScanMark ES2260™ scanner. The scanner digitizes the information 
and saves it to a text file on the host computer.

NOTE    The CLOScanTool must be installed. 

Task 4: Import Offline Test Results

Teachers can upload the results of objective‐based tests that have been scanned into Odyssey Manager. 

1 In the navigation bar, select Setup>Tools.

2 From the Tools home page, click Import Offline Test. 

3 The Select Offline Test screen displays assignments containing offline tests. Select the desired test and then 
Next. 

NOTE    Even if the same test is in more than one assignment, the test name is displayed 
only once. You will choose the desired assignment in a later step in the wizard. 

4 From the Upload File screen, Browse to the Scantron file associated with the desired test. This file was 
created by from the Scantron forms. 

5 From the Choose File dialog box, select the file and then click Open. 

The Upload File screen displays the path and file name in the File to import field.
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6 Verify that the correct path and file name are displayed, and then click Next. 

The Preview Results screen displays the test results. 

7 If the same test is in more than one assignment, all assignments will appear and student names will be 
duplicated. Check students for the assignment associated with the results file you selected in step 4. Uncheck 
all other students.

8 The Information column notes errors the scan encountered. To learn how to correct an error, see Scan Errors 
below. 

9 When finished, click Import. 

CAUTION    No changes can be made after the results file has been imported.

A confirmation screen displays the number of students imported and the number, if any, that failed to 
import. For failures, a list appears, with an explanation of each failure. 

10 Click Close.

Scan Errors

The Preview Results screen displays test results and lets you correct any scan errors. 

Scan errors may include the following:

Name format incorrect. Name may contain no spaces or too many spaces.

Student name is not unique. Student names must be unique.

Student not found. 

Student failed to bubble in full name.
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This student is not assigned.

Multiple assignments. 

Other anomalies are denoted in the Answers column. See above image. 

Missing answer. Counted as incorrect.

Student answered E on a four‐answer item. Counted as incorrect.

Answer cannot be determined (*). Counted as incorrect. If you can discern the student’s intent from the answer 
sheet, you can use the Edit link to supply the answer.

Correcting Scan Errors

To correct a scan error, complete these steps:

1 From the Preview Results screen of the Import Offline Test tool, click the desired Edit link.

The Edit Assignment Results dialog box is displayed. 

2 Correct any student name errors.

Odyssey generates a list of user names, attempting to match known names to an indeterminate name. 
Selecting a name from the dropdown displays the name in the User Name field.

3 Correct any indeterminate scores. 

If a test item has no answer, the student did not answer the question; filled in more than one answer; or 
chose E as an answer.

4 When finished, click OK.

You are returned to the Preview Results screen. 

5 To complete the import, click Import and then Close. 
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For School and District Administrators

The CompassLearning Test Translator allows district and school administrators to import NWEA and state 
external assessment scores, report on the imported data, and prescribe content based on the scores.

CompassLearning and NWEA

CompassLearning and Northwest Evaluation Association (NWEA), a nonprofit organization, have created an 
alliance that provides educators with assessment, curriculum, and data management solutions aligned to state 
and national standards. Together, they provide quality assessment solutions through a combination of formative, 
summative, criterion‐referenced, and norm‐referenced tests, offering comprehensive information about student 
performance and engaging curriculum to help students and teachers succeed.

NWEA assessments measure the academic growth of a student or group of students over time using the RIT 
scale. The RIT scale refers to the Rasch unit, a measure scale developed to simplify the interpretation of test 
scores. The RIT scale employs equal intervals; a change of one unit indicates the same change in growth, 
regardless of numerical values.

NWEA's Measures of Academic Progress (MAP) is a computerized adaptive assessment program that allows 
teachers to quickly place students on the appropriate learning path. Educators have accurate data that can be 
used to:

• Identify the skills and concepts individual students have learned.

• Diagnose instructional needs.

• Make data‐driven decisions at the classroom, school, and district levels.

• Place students into appropriate instructional programs.

• Monitor academic growth over time.

MAP‐normed tests automatically adjust to each student's performance level, providing precise placement of 
students on a continuum of skills in reading, math, and language arts, independent of grade level.

The CompassLearning–NWEA alliance allows educators to move between NWEA's assessments and 
CompassLearning Odyssey's curriculum, enhancing the learning experience for all students. The assessments 
allow teachers to help not only those children who are working within their respective grade levels, but also 
those whose skills are far below or above grade level. The combination of these two solutions ensures that 
educators have the information and resources required to make sound assessment, instruction, and curriculum 
decisions at the school and district levels.

System Requirements

If your site is licensed for NWEA External Assessment and will be using the automated data upload feature, 
ensure that Microsoft .NET Framework 2.0 and WSE 3.0 are installed on the machine used for uploading. The 
.NET Framework requires a Windows operating system. It is not applicable to Mac computers.
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Installing the NWEA Data Agent

The NWEA Data Agent is a required utility installed at the customer’s site for use by NWEA to periodically upload 
external test data files to customers who have purchased NWEA licensing and submitted a school roster to 
NWEA. The uploaded files are used by the CompassLearning import tool for importing the test data into Odyssey 
Manager.

NWEA provides CompassLearning with two ZIP files to be used for installing the Data Agent. The ZIP files are 
available at 

http://support.compasslearning.com/filecenter/download/180.asp

Because the NWEA Data Agent runs as a service, install it on a supported workstation or server that remains on 
at all times to be able to receive uploads from the host server at NWEA.

Preparing for the Installation

1 At the designated computer, log in as a user with administrative privileges.

2 Create a temp folder from which you will run the installation. Use an easily identifiable name, such as 
tempnwea. This folder can be deleted after the installation is completed.

NOTE    All installation builds have the same name. To keep the installation builds 
separate, create a separate temp folder for each build. For example: nweaupload1, 
nweaupload2, and so on.

3 Open a browser window and browse to this location:

http://support.compasslearning.com/filecenter/download/180.asp

4 Download the following ZIP file to your desktop:

NWEADataAgentSetup.zip

5 Continue the installation by completing these tasks:

• Task 1: Installing the Data Agent Core below

• Task 2: Installing the File Mover Plug‐in on page 274

Task 1: Installing the Data Agent Core

1 Unzip NweaDataAgentSetup.zip to the desktop or to a temp folder you created for the installation.

2 From the desktop or the temp folder you created, open the update_core_m‐d‐y folder and double‐click the 
update.exe file.

The Update Manager window displays a progress bar and all the installation steps as the Data Agent Core is 
installed.

When the installation is complete, the Update Manager window closes and you will see a blue icon in the 
system tray. The diagonal line in the icon indicates that the service needs to be authenticated.

3 Right‐click the NWEA Data Agent icon in the system tray and select Properties.

4 From the NWEA Agent Manager Properties dialog box, enter the account number and password provided by 
NWEA, and click Authenticate.
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5 When the Status is Authenticated, click OK.

The installation creates inbound and outbound folders in the C:\nwea directory, where they can be cleaned 
out by technical staff or another application. Use the File Mover plug‐in to move the inbound and outbound 
folders to a secure location on the local hard drive.

Task 2: Installing the File Mover Plug‐in

1 From the desktop or the temp folder you created, open the update_FileMover_m‐d‐y folder and double‐click 
the update.exe file. 

NOTE    When the installation is complete, a second NWEA Data Agent icon may appear 
in the system tray, but it disappears when you mouse‐over one of the icons.

2 Right‐click the NWEA Data Agent icon in the system tray and select Properties.

3 From the NWEA Agent Manager Properties dialog box, click the File Mover tab.

4 In the Value column, change the path for the Inbound and Outbound folders to the desired parent folder on 
the local hard drive and then OK.

Configuring the NWEA Data Agent

Configuring the Data Agent Scheduler

1 Right‐click the NWEA icon on your Task Manager bar and select Properties.

2 From the NWEA Agent Manager Properties dialog box, click the Schedule Manager tab.

3 To schedule the FileMover for an unattended operation, you will add three lines to the config page.

• To add a line, click the last cell in the readOnly column.

• Click in the last cell in the Key column.

• Enter these three additional lines, as shown in the following table:

4 When finished, click OK.

The FileMover operation will initiate every 60 minutes.

Validating the FileMover Operation

1 Right‐click the NWEA icon on your Task Manager bar and select Properties.

2 From the NWEA Agent Manager Properties dialog box, click the File Mover tab.

3 Take note of the folder paths configured for both InboundFolder and OutboundFolder.

4 Create a small text file and save it in the folder that was configured for the OutboundFolder.

Key Value readOnly

ScheduleManager.commandString3 PROCESSFILEMOVES False

ScheduleManager.componentNameString3 FileMoverDataProcessor False

ScheduleManager.intervalMinutes3 60 False
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5 To initiate the FileMover operation, right‐click the NWEA icon on your Task Manager bar and select 
Plug‐ins>Move Files.

When the operation completes, a message on your Task Manager bar informs you that the operation 
finished.

Importing External Test Data

You will use one of two tools to import external test data into Odyssey Manager. The following sections describe 
these two processes.

• Importing Data with Odyssey Manager below. The NWEA and State Test Data tools are included in Odyssey 
Manager if your site is licensed for NWEA and state assessment data.

• Importing Data with the Import Client on page 276. For enterprise customers, the import client is available 
from the Odyssey Manager media. Enterprise and hosted customers can download the client from the 
CompassLearning Support site. The import client must be manually installed and configured. See Import 
Client on page 265.

After external test data is imported, students and teachers can log in to see assignments. If the school is in a 
district, the assignments are stored in the My District folder in the Assignment Archive, with the district 
administrator as the owner of the assignment. If the school is not in a district, the assignments are stored in the 
My School folder. 

NOTE    When you search for assignments by goal in the Assignment Archive, Odyssey lists 
the search results by goal name. If separate tests share the same goal, more than one 
search result may share the same name, when, in fact, they are not duplicates.

Importing Data with Odyssey Manager

Depending on the test data you are importing, you will use the NWEA or State Test Data tool. These tools 
transfer external test data into the Odyssey system.

1 Log into Odyssey Manager as a school or district administrator user.

2 Select Setup>Tools.

3 At the Tools home page, click NWEA Test Data (or State Test Data).

4 Click Import.

5 District administrators: Specify the target school for the import. The test data will be imported into the school 
you specify.

From the Select School dropdown list, select the desired target school and then Next. 

OR

Click School is specified in the file to be imported and then Next. 

6 From the Select File screen, click Browse to locate the file you want to import. 

By default, NWEA test data files are downloaded to C:\nwea\inbound as ZIP or XML files. Your data agent 
configuration may be different.

7 Double‐click the desired file.

8 With the file name and path displayed in the File to Import field, click Next. 
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9 From the Select Profile screen, select the desired profile. To display profile details, click the magnifying glass 
for the profile.

10 When finished, click Next. 

11 From the Select Error Option screen, select one or multiple error options. If you choose to ignore all errors, 
the import will succeed, but the import status on the History page will not indicate if errors were 
encountered during the import. To view all errors, generate a Test Translator Import Log from the Reports 
module.

12 Specify how Odyssey will manage previous NWEA (or state) assignments.

Keep all existing assignments leaves all of the existing NWEA (or state) assignments—both started and not 
started—that students already have on their launch pad. Selecting this option may result in students having 
duplicate assignments—for example, if the new import includes assignments that were assigned in previous 
imports. Use this option to keep all assignments from previous imports. 

NOTE    In previous Odyssey versions, this option was labeled: Don’t unassign any old 
assignments.

Remove all existing assignments removes all of the existing assignments—both started and not started—
that students already have on their launch pad. Use this option when you want students to work on just the 
assignments from the import—not retain existing assignments from previous imports. 

NOTE    In previous Odyssey versions, this option was labeled: Unassign all students’ 
uncompleted assignments. 

Remove assignments with the same goal and RIT range (or learning proficiency) removes only those existing 
assignments—both started and not started—that have the same goal and RIT range (or learning proficiency) 
as the assignments in the current import. Use this option when you want to selectively replace existing 
assignments with those in the current import that match the goal and RIT range (or learning proficiency). 

NOTE    In previous Odyssey versions, this option was labeled: Unassign students’ similar 
uncompleted assignments. 

13 When finished, click Next. 

14 From the Final screen, review the data to be imported and then click Finish. 

15 A message indicates that the upload was successful. Click OK. 

Odyssey sends the upload to be processed offline. To display status, see Displaying Upload History on page 
277.

Importing Data with the Import Client

The import client performs an automatic check for downloads every 10 minutes for an hour starting at 1:00 A.M. 
(or at another time and interval that you specify) every day. If external assessment data is available during the 
automatic checks, it will be downloaded at that time. 
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To run the import client manually between automatic checks, complete these steps:

1 From the Start menu, select Programs>CompassLearning Tools>Import Client.

2 If you are using the tool for the first time, you are asked to log in with a school or district administrator user 
name, password and school code.

3 From the import client menu, select Import>External Assessment.

The Load External Assessment dialog box is displayed. 

4 From the Load Type dropdown menu, select NWEA (or State).

5 Browse to the file that you want to upload.

6 Click Start.

Odyssey sends the upload to be processed offline. When the upload is completed, a message is displayed in 
the taskbar. To display status, see Displaying Upload History below. 

Displaying Upload History 

1 Log into Odyssey Manager as a school or district administrator user.

2 In the navigation bar, select Setup>Tools.

3 At the Tools home page, click NWEA Test Data (or State Test Data). 

4 Click Show History. 

The status of the upload is displayed.

5 To view status details, click the status link of the upload.

NOTE    A status of Completed may not signify that the import completed successfully. 
Ensure that you verify the Test Translator Import Log (Reports>Test Translator>Test 
Translator Import Log).
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Import Error Messages

Aligning NWEA Test Names

CAUTION    Before using the Test Name Aligner, consult with CompassLearning Support. 
All changes made with this tool are permanent and if incorrect could adversely affect 
future imports.

NWEA and Odyssey test names must be aligned for Odyssey to assign the appropriate assignments based on the 
goal name and RIT range of the NWEA test. Use the Test Name Aligner to match NWEA test names with Odyssey 
test names.

Aligning NWEA Test Names with Odyssey Test Names

1 Log into Odyssey Manager as a school or district administrator user.

2 In the navigation bar, select Setup>Tools.

3 At the Tools home page, click NWEA Test Data.

Error message Description

School SchoolName, being processed in the file, does not 
exist or does not have permission to execute EAS 
process.

The school does not exist in the Odyssey system or does 
not have permission to run the import process.

Process has been aborted. The only school SchoolName 
to be processed was not found. Please correct data in the 
file and then try again.

Processing only one school and the school name does not 
match, or the school listed did not purchase NWEA.

School Name: SchoolName: Student ID: StudentID not 
found in database.

• The student exists in the XML file but not in the Odyssey 
system.

• The ID number is mismatched.

• The student has no ID number in Odyssey.

• The student has been transferred to a different school 
within the district.

School SchoolName has 999 students not in the system. 
To import select Ignore student errors. Students missing: 
Student1, Student2, Student3 …

The number of students not in the Odyssey system 
exceeds the allowed number of errors.

RuleSet corresponding to School Name: SchoolName: 
Student ID: StudentID: Test Name: TestName has either 
not been selected or was not present within Test 
Translator wizard.

Odyssey does not support all NWEA tests. If there are 
questions on whether this test is supported, contact 
Customer Support.

Goal Name: GoalName corresponding to the School 
Name: SchoolName: Student ID: StudentID : Test Name: 
TestName either does not match with the ruleset of 
corresponding test or does not exist in the database.

The goal name in the file does not exist in the Odyssey 
system.

LP Assignment LPAssignmentName does not exist in the 
database.

The assignment to be given to the student was removed 
from the system.

Process has been aborted due to the number of items 
processed with errors exceeding the maximum allowed 
errors. Please correct data in the file and then try again.

The Test Translator process stopped due to errors 
exceeding the maximum allowed.
CompassLearning® Odyssey User’s Guide



Test Translator 279
Aligning NWEA Test Names
4 Click Test Name Aligner.

A warning message is displayed, advising you that changes made to test names cannot be reversed.

5 To continue, click OK.

The Tools screen displays the aligned tests for the selected state and version.

6 From the System Test Name dropdown, select a system test. This is the name of the test in Odyssey.

7 In the NWEA Test Name field, enter a new NWEA test name. This is the name of the test in the XML file that 
does not match the system name. 

8 To align the test names, click Add.

NOTE    Clicking Cancel returns you to the Tools screen for NWEA.

The newly added NWEA test name is displayed in the grid.

Deleting a Test Name Alignment

1 Log into Odyssey Manager as a school or district administrator user.

2 In the navigation bar, select Setup>Tools.

3 At the Tools home page, click NWEA Test Data.

4 Click Test Name Aligner.

A warning message is displayed, advising you that changes made to test names cannot be reversed.

5 To continue, click OK.

The Tools screen displays the aligned tests for the selected state and version.

NOTE    A test name alignment created by CompassLearning cannot be deleted. 

6 From the grid, select the test name alignment that you want to delete.

NOTE    Clicking Cancel returns you to the Tools screen for NWEA.

7 Click Delete. 

A warning message is displayed, advising you that the deletion is permanent.

8 To continue, click OK. 
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G LDAP Authentication
For School and District Administrators

Lightweight Directory Access Protocol (LDAP) is a client‐server protocol that defines a uniform method for 
accessing and updating information. Programs can use LDAP to locate organizations, individuals, and other 
resources such as files, printers, encryption certificates, and devices on a network server. A primary benefit of 
LDAP is to provide single sign‐on, which means that one password for a user is shared between many services. 

As a protocol, LDAP does not define how programs work on either the client or server side. LDAP defines the 
language used for client programs to talk to servers, or servers to talk with other servers. To be able to use LDAP, 
your web server must be configured with LDAP, and your school must be licensed to use LDAP. 

NOTE    Your CompassLearning representative enables LDAP authentication.

With LDAP enabled, school and district administrators can edit the LDAP authentication settings, including 
setting LDAP authentication for teachers, students, and parents.

NOTE    With LDAP authentication enabled, you will be unable to automatically import 
users into Odyssey. Use the import templates or manually enter user information to add 
and update user records. LDAP authentication is only used as an added security to verify 
login credentials. Additionally, user passwords cannot be edited manually through the 
user interface. To update user passwords after they have been changed in the LDAP 
server, import the updates into Odyssey.

You will use the Administration screen from the school’s account pages to edit LDAP authentication for the 
school. 

The following table describes the settings available with LDAP authentication in Odyssey Manager:

Field Description

Path (URI) Server that performs the LDAP authentication.

SSL When checked, allows secure encrypted communication between the browser and the web 
server and between the web server and the LDAP server.
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Setting LDAP Authentication

1 Log into Odyssey as a school administrator or district administrator user.

2 From the Welcome screen, depending on your role, select Setup>My School or Setup>My Schools.

3 From the displayed tree, locate the desired school and click the school name.

The grid on the right displays information about the selected school, including names for the Account and 
Administrator near the top of the screen.

4 From the Contact screen, click Next.

The License screen displays account information. With LDAP enabled, you will see a checkmark in the LDAP 
Authentication box.

5 From the Contact screen and the next screen—Curriculum Licenses—click Next.

6 From the Administration screen, specify the LDAP Settings.

7 Set LDAP authentication for the desired user roles—Teacher, Student, Parent—by checking the boxes.

8 When finished, click Next.

9 From the Confirmation screen, click Save.

DN Prefix • If the LDAP server has only LDAP users such as Active Directory Application Mode (ADAM), the 
DN prefix is required. 

• If Microsoft Active Directory Services is employed and users have Windows logins, this setting 
should be left blank. 

• If Active Directory Services is employed and all users are under one domain, the DN prefix can 
contain a domain such as the following:

MySchoolDomain\

DN Suffix • If the LDAP server has only LDAP users such as ADAM, the DN suffix is required. 

• If Active Directory Services is employed and the users have Windows logins, this setting should 
be blank.

Field Description
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activity

General term for all Odyssey tasks included in an assignment. An activity may be a learning activity, scored learning 
activity, chapter test, lesson quiz, Odyssey Writer project, among others.

alignment

The degree to which state standards and curriculum agree and guide students to learn what they are expected know. 

All Sessions

Attendance report that lists, by student, the total number of logins.

assessment

A basis for measuring the skill, knowledge, intelligence, capabilities, or aptitudes of a student or group.

assignment

A collection of one or multiple learning activities, quizzes, and tests.

Assignment Archive

Manages assignments for district and school administrators and teachers. Access to Assignment Archive features depends 
on your user role. All users can access all assignments in the system, viewing the name, subject, level, owner, and 
modification date. Administrators can edit assignment properties and delete assignments. Teachers can edit and delete 
their own assignments and give assignments to their students.

auto‐launch order

Assignment order that presents tasks to a student in the defined order, without returning to the student’s launch pad after 
each task.

AYP

Adequate Yearly Progress. A statewide accountability system mandated by the No Child Left Behind Act (NCLB). An 
individual state’s AYP measures progress toward a goal of 100 percent of students achieving state academic standards in a 
minimum of reading/language arts and math.

Completed Session Times

Attendance report that lists, by student, the total number of logins and total session time (in hh:mm:ss format) for all 
completed sessions. A completed session is a successful login that is followed by a successful logout.

concurrent‐user subscription licensing

Licensing model that limits the number of users logged in but does not limit the total number of users. For example, with a 
license purchased for 25 concurrent users, additional users may register to use the product, but only 25 may be logged in 
at any given time. See also single‐user subscription licensing on page 285.

Curriculum Index

Use the Curriculum Index to browse Odyssey curriculum and assessment material before you create an assignment. 
Browse curriculum by sequences, skills, or state standards. As you plan your assignment, use the index to view the 
contents of prescriptive folders and learning paths and preview specific learning activities, lesson quizzes, and chapter 
tests.
CompassLearning® Odyssey User’s Guide



Glossary 283
decision point

Defines a custom set of required remediation activities if the student does not meet the mastery level for a scored activity. 
Teachers can insert one or multiple decision points in a scored activity to serve as benchmarks for performance‐based 
progress. Options include repeating the scored activity; repeating the remediated set a specified number of times; 
restarting the folder; and manual interaction by the teacher.

DOK

Depth of Knowledge (DOK) is a four‐level scale measuring required cognitive processing and is used to align standards with 
assessments. Educators assign DOK levels to objectives within standards and to test items within assessments to help 
ensure that the standards and assessments match. The four DOK levels include (1) recall; (2) skills and concepts; (3) 
strategic thinking; (4) extended thinking.

disaggregate data

Disaggregation of data is available when student records are defined according to individual subgroups, such as race/
ethnicity, gender, economic status, special educational services, disability, or a combination of these. Odyssey reports can 
be run for these individual subgroups to help educators address critical aspects of the NCLB legislation and verify that their 
students are on the path to achievement.

distractor

One of the incorrect answers presented as a choice in a multiple‐choice test. 

ELL

English Language Learners.

ESE

Exceptional Student Education. An exceptional student is any child or youth who requires special instruction or related 
services and is enrolled in or eligible for enrollment in the public schools of a district. 

ESL

English as a Second Language.

ESOL

English for Speakers of Other Languages.

Incomplete Sessions

Attendance report that lists, by student, the number of successful logins without a successful logout.

Item Builder

Tool for creating custom test items for custom objective‐based tests.

LD

Learning Disabled.

learning activity

A type of Odyssey activity included in an assignment. A learning activity may be scored or nonscored.

learning path

A type of assignment that includes activities Odyssey identifies to cover the objectives a student has not mastered in an 
objective‐based test. 

LEP

Limited English Proficiency.

Lightweight Directory Access Protocol (LDAP)

LDAP is a client‐server protocol that defines a uniform method for accessing and updating information. Programs can use 
LDAP to locate organizations, individuals, and other resources such as files, printers, encryption certificates, and devices on 
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a network server. A primary benefit of LDAP is to provide single sign‐on, which means that one password for a user is 
shared between many services.

MAP

Measures of Academic Progress from NWEA; tests measuring students’ growth and achievement. MAP scores are used to 
develop targeted instructional strategies.

mastery level

Passing percentage defined for a school. The mastery level applies to scored activities, including lesson quizzes, objective‐
based tests, and chapter tests. School and district administrators can change the mastery level for a school. A mastery level 
set on an individual decision point or for objectives in a custom objective‐based test (built with Test Builder) overrides the 
mastery level set at the school level. 

module

Functional area of Odyssey Manager. Modules include Setup, Assignments, Assessment, Reports, and Content.

NCLB

No Child Left Behind Act that mandates increased accountability, more rigorous assessment, demand for high quality 
educators, and research‐based practices. 

No Sessions

Attendance report that lists who have not logged into the system.

NWEA

Northwest Evaluation Association. NWEA assessments measure the academic growth of a student or group of students 
over time using the RIT scale. See RIT on page 285.

objective

A measurable educational task that students should be able to complete after having received instruction. A learning 
activity may teach to one or multiple objectives. 

objective‐based test

Evaluates each objective against the passing score to diagnose a student’s strengths and weakness. Within Odyssey 
Explorer: If an objective‐based test is included in an assignment with a learning path folder, diagnostic‐prescriptive 
behavior is invoked. That is, Odyssey Manager prescribes the objective folders within the learning path folder that 
correspond to the failed objectives. None of the activities that are in the objective folders that correspond to passed 
objectives are delivered to the student. If a learning path is assigned without its accompanying objective‐based test, the 
learning path folder becomes a regular folder and all activities from within all objective folders within the learning path are 
delivered to the student.

Odyssey Writer

A customizable writing tool in Odyssey Manager that helps educators in all disciplines teach the writing process to their K‐
12 students. Designed to improve narrative, persuasive, informative, and fiction and nonfiction writing skills, Odyssey 
Writer lets teachers create and assign writing assignments and guides students through the entire writing process.

Parent Login

Attendance report that lists, by parent, the number of successful logins and total session time (in hh:mm:ss format).

Passing Percentage

Setting in a school account’s License screen that defines the passing score for a scored activity, lesson quiz, objective‐based 
test, or chapter test. School and district administrators can change the Passing Percentage. See also mastery level.

progress alert

Decision point option for nonmastery of a scored activity. A progress alert locks the objective folder and opens the 
progress alert dialog box, which prompts the teacher for a password and action to take. 
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report

Odyssey Manager provides a wide variety of reports for teachers and administrators to create detailed and summary 
snapshots of student achievement, both in the classroom and on state‐mandated testing. Options include using 
aggregated and disaggregated data, multi‐school administration data, pre‐test versus post‐test comparisons, and 
individual student progress data.

RIT

Rasch Unit. A measure scale developed to simplify the interpretation of test scores. The RIT scale employs equal intervals; 
a change of one unit indicates the same change in growth, regardless of numerical values.

Session Times

Attendance report that lists, by student, the time of login (your local time) and total session time (in hh:mm:ss format).

self‐select order

Assignment order that lets a student perform tasks in any order.

sequence

Ordered collection of lesson folders, each containing one or multiple learning activities, quizzes, and tests.

sequential order

Assignment order that presents tasks to a student in the defined order, returning to the student’s launch pad after each 
task.

standards

Objectives that are grouped together based on instructional content.

strands

A high‐level goal. A strand groups items—substrands and objectives—of similar subject matter or skill. Strands appear as 
test names. Reading Analysis and Reading Comprehension are two examples of strands.

single‐user subscription licensing

Licensing model that limits the number of users logged in to the number of subscriptions purchased. For example, with a 
license purchased for 25 subscription users, a maximum number of 25 users may be registered in that account and a 
maximum number of 25 users may be online at one time. See also concurrent‐user subscription licensing on page 282.

substrand

A detailed version of the strand, or high‐level goal. Informational Analysis and Poetry are two examples of substrands that 
might be included in the Reading Analysis strand.

suppression

Assignment option that controls the activities that are presented to a student. Suppression ensures that duplicate 
objectives are not included in a student’s learning path. If a student passes a scored activity or completes a non‐scored 
activity, all duplicates of the completed activity within the same assignment are marked as complete. 

task

General term for all Odyssey activities included in an assignment. An activity may be a learning activity, scored learning 
activity, chapter test, lesson quiz, Odyssey Writer project, among others.

Teacher Login

Attendance report that lists, by teacher, the number of successful logins and total session time (in hh:mm:ss format).

test item

Item Bank stores test items you can use to create custom objective‐based tests. The Odyssey Practice Items bank contains 
test items created by CompassLearning. You can use these test items as is, or you can paste a copy of a test item into 
School Items or District Items and make changes to the copied test item. Initially, the School Items and District Items banks 
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will not contain test items. These repositories are populated with test items that district and school administrators and 
teachers create.

unlimited licensing

Licensing model that allows unlimited student logins to Odyssey. 
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Index
A
Account Changes Report, 221
Active Directory Application Mode

See ADAM
active mode, 60
activities

selecting for assignments, 43
ADAM, 281
Add New Student button, 32
Add Personal Information permission, 213, 226
Add Student button, 32
Add/Edit Class Information permission, 213, 226
Add/Edit Class Rosters permission, 213, 226
Administration reports

Assignment Status, 119
Attendance, 108
Duration, 113
Enrollment, 116
list of, 98
Utilization, 106

administrator, overview of tasks, 2
After School Programs, 30
Alignment formatting option, 207
All Sessions Attendance report, 108
annotations, in Odyssey Writer, 191, 192
Assessment reports

list of, 99
Objective Score, 150
Objective‐based Test Results, 138
Test Item Summary, 144
Test Summary by Objective, 147

assessments
building custom, 74
downloading transfer file, 240
overview, 4
permissions, 253
permissions for custom features, 214
printing, 78
retrying transfer, 241
transferring

into a district or school, 238
out of a district or school, 237

Assignment Archive
assigning, 56
overview, 37

Assignment Status
report, 119
unlocking progress alert, 67

assignments
adding curriculum, 51
adding decision points, 52, 65
assigning, 54
availability, 53
deleting, 55, 247
displaying class progress, 70
downloading transfer file, 240
editing, 58
finalizing, 53
modes, 13, 60
naming conventions, 256
order, 53
overview, 4
overview for students, 13
owners, 60
permissions, 253
retrying transfer, 241
status

displaying, 71
student portfolio, 18, 21

transferring
into a district or school, 236
out of a district or school, 236

unassigning, 57
attendance concern, 30
Attendance report, 108

for parents, 22
authentic tasks, creating, 49
auto‐launch mode, 13
AYP, 101

B
bookmarks, deleting, 252
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C
caution statement, xiii
Chapter Questions report, 180
class enrollment, deleting at end of year, 247
class progress

by assignment, 70
by student, 71
overview, 69

classes
adding students, 33
creating, 32
deleting, 35
naming conventions, 256
permission to update records, 254
removing a student, 34
specifying at import, 228
updating name, 35

color formatting option, 207
comments, adding in Odyssey Writer, 191
CompassLearning, support, xiii
Complete Assignment dialog box, 53
Completed Session Times Attendance report, 108
concurrent‐user subscription licensing, 209
content permissions, 221
Continue, decision point option, 62
continuous enrollment, 30, 228
curriculum

introduction, 43
selecting for assignments, 43

Curriculum Index
browsing, 38

Curriculum report, 178
custom activity, creating, 187
custom annotations, in Odyssey Writer, 192
Custom Assessment Features permission, 214, 225
Cycle, decision point option, 62

D
Data Agent, 273
Data Agent Scheduler, 274
Daylight Saving Time, 217
Decision Point Options dialog box, 61
decision points

adding, 52, 65
definition, 60
deleting, 66
editing, 65
progress alert password, 218
rules, 64

Delete Students permission, 213, 226

disaggregation of data, 101
district administrator

changing profile, 210, 214
overview of tasks, 2

District Items, 80
district reports administrator, 2, 101
DN Prefix, 281
DN Suffix, 281
draft mode, 54, 60, 77
drafting stage of writing, 185, 198
DST. See Daylight Saving Time
Duration report, 113

for parents, 23

E
early turn in, 77
Edit Attributes permission, 213, 226
Edit Personal Information permission, 213, 226
Edit Subject Level Access permission, 213, 226
editing stage of writing, 185, 205
ELL, 30, 228
end of year

applying changes, 250
displaying history, 251
rules, 249

English for Speakers of Other Languages
See ESOL

English Language Learners
See ELL

English Second Language
See ESL

Enrollment report, 116
Equation Editor, 83, 87
equations

including in Odyssey Writer projects, 189
inserting in Odyssey Writer, 200
tips for Odyssey Writer, 200

ESE, 30, 228
ESL, 30, 228
ESOL, 30, 228
evaluated projects in Odyssey Writer, 203
Exceptional Student Education

See ESE
Exit, decision point option, 62
Explorer

browsing curriculum, 47
overview, 74

exported data, downloading, 245
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F
fiction, 184
File Move Plug‐in, 274
folders

creating in an assignment, 51
order of activities in an assignment, 52

Font formatting option, 206
Font Size formatting option, 206
Font Style formatting option, 206
formatting options in Odyssey Writer, 206

G
gains, measuring, 56
gifted, 30
Goal Score report, 158
Goal‐based Test Results report, 153
grade level

for students, 227
teachers, 225

grade, assigning in Odyssey Writer, 191
graduation

applying end‐of‐year changes, 250
definition, 247

Graphic Organizer tool
adding an idea box, 196
deleting an idea box, 197
linking idea boxes, 196
moving an idea box, 197
overview, 195
pasting to draft, 197

grid, 6

H
Hand‐In button, 207
hearing impaired, 30
history

displaying
for accounts, 223
for data exports, 245
for imports, 230
for test data uploads, 277
for transfers, 239

hyperlink
inserting in Odyssey Writer, 199

I
icons

for decision points, 62
for Item Bank and Objective Builder, 79
overview, 8

idea boxes
adding, 196
deleting, 197
linking, 196
moving, 197

images
in Odyssey Writer, 199
in test items, 85
including in Odyssey Writer projects, 189
tips for Odyssey Writer, 200

import
checklists, 259
displaying history, 230
offline tests, 269
operation type, 226, 228
permissions, 254
students, 229
teachers, 229
templates, 224

Incomplete Sessions Attendance report, 108
informative writing form, 184
Insert Hyperlink, 189
Insert New Page command, 199
Instructions window, 198
intervention, 30
Item Bank, 79
Item Builder, 82

K
keywords, browsing curriculum by, 39

L
Lab Number value, 226
launch pad

for students, 10, 11
Odyssey Manager, 4

LDAP, 281
learning disabled, 30
Learning Path Status report, 134
learning paths

browsing, 47
definition, 14, 37

LEP, 30, 228
Lesson Questions report, 179
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Lesson vs. Learning Activities report, 178
licensed curriculum, 221
licensing

overview, 209
Lightweight Directory Access Protocol

See LDAP
Limited English Proficiency

See LEP
local school ID, 216
lock mode, 60
login

FAQs, 25
how to, 5
screen, 3

logout, 25
Longitudinal Goal Score Analysis, 164

M
mastery level, 219
mastery score, 77
Measures of Academic Progress, 272
migrant, 30
modes, 60
My Assignments folder, 53, 253
My District assignment folder, 53, 214, 225, 253
My School assignment folder, 53, 214, 225, 253

N
narrative writing form, 184
nationality, 29
navigating

allowing in test, 77
Odyssey Manager, 6
student launch pad, 11

NCLB, 101
No Sessions Attendance report, 108
nonfiction, 184
NWEA

aligning test names, 278
browsing RIT range learning paths, 48
Data Agent, 273
displaying upload history, 277
importing test data, 275
Learning Path Status report, 168
overview, 272

Northwest Evaluation Association
See NWEA, 48

Note Cards tool
adding a note card, 196
deleting a note card, 196
moving a note card, 196
overview, 194
pasting to draft, 197

notes
adding in Odyssey Writer, 192

O
Objective Score report, 150
Objective‐based Test Results report, 138
objective‐based tests

browsing, 47
creating, 75
definition, 74

objectives
adding test items, 95
creating, 95
modes, 60
naming conventions, 258
overview, 89
selecting for custom test, 76

Odyssey Practice Items, 80
Odyssey Writer

assigning projects, 186
creating a project, 50, 187
deleting a project, 205, 252
editing a project, 206
evaluating projects, 189
formatting projects, 206
handing in a project, 207
inserting a hyperlink, 199
inserting an equation, 200
inserting an image, 199
opening a project, 202
outline, 197
overview, 11
permissions, 214, 226, 254
reports

list of, 99
Student Writing Portfolio, 172
Writing Summary, 175

returning evaluation to student, 193
spellcheck, 205

offline processing for reports, 103
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offline tests
criteria for, 268
defining in Assignment Builder, 54
errors, 270
importing results, 269
permissions, 214, 226, 253
printing, 269
scanning results, 269

opening an Odyssey Writer project, 202
operation type, 226, 228
outline in Odyssey Writer, 197
overview, 1
owners, 60

P
Parent Login Attendance report, 108
parents

access, 19
FAQs, 25
reports, 21
user name and password, 29, 227

Passing Percentage, 219
passwords

for parents, 227
for students, 29, 227
for teachers, 225
setting for progress alert, 218

permissions, 253
persuasive writing form, 184
physically challenged, 30
pinpoint text, 195
portfolio, student, 16
prewriting stage of writing, 185, 194
Print Tests permission, 214, 226
Privacy Policy, 5
Product License screens, 222
progress alerts

default password, 218
setting password, 218
unlocking, 66

Progress reports
Learning Path Status, 134
list of, 98
Progress Summary, 130
Student Progress, 125

Progress Summary report, 130
promotion

applying end‐of‐year changes, 250
definition, 247

prompt, teacher, in Odyssey Writer, 198

publishing
stage of writing, 185, 206

R
randomizing test items, 77
Recent Work tab, student portfolio, 17, 19
reports, 5

Assignment Status, 119
Attendance, 108

student portfolio, 22
by category, 98
by education strategy, 100
Curriculum, 178
Duration, 113

student portfolio, 23
Enrollment, 116
Goal Score, 158
Goal‐based Test Results, 153
Learning Path Status, 134
Longitudinal Goal Score Analysis, 164
naming conventions, 257
NWEA Learning Path Status, 168
Objective Score, 150
Objective‐based Test Results, 138
offline processing, 103
Progress Summary, 130
State Correlation, 182
State Learning Path Status, 170
Student Progress, 125
Student Score

student portfolio, 18, 24
Student Writing Portfolio, 172
Test Item Summary, 144
Test Summary by Goal, 156
Test Summary by Objective, 147
Test Translator Import Log, 161
Utilization, 106
Writing Summary, 175

repositories for test items, 80
Resources reports

Curriculum, 178
list of, 99
State Correlation, 182

Restart Folder, decision point option, 62
revising

definition, 185
overview, 201

rubrics
creating new in Odyssey Writer, 188
using existing in Odyssey Writer, 188
using to evaluate an Odyssey Writer project, 191
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S
Scan Results permission, 214, 226
Scantron, 269
school administrator

changing profile, 210, 214
overview of tasks, 2

school ID code, 216
School Items, 80
search

assignment archive, 55
overview, 9
student index, 27

Self‐Assessment tool, 201
self‐select mode, 13
sequences, 39, 44
sequential mode, 13
Session Times Attendance report, 108
setup, 4
Show Resources setting, 54
SIF Provided Student ID, 227
single‐user subscription licensing, 209
skills, 41, 45
sound files, in test items, 86
Spacing formatting option, 207
special needs, 30
spellcheck, 205
standard sets

creating, 75
modes, 60
naming conventions, 92

State Correlation report, 182
State Learning Path Status report, 170
state standards, 42, 46
strands

copying, 93
creating, 93

Student Index, 27
student portfolio

Assignments tab, 18
overview, 16
Recent Work tab, 17

Student Portfolio reports
Attendance, 22
Duration, 23
list of, 99
Student Score, 24

Student Progress report, 125
Student School ID, 29, 227
Student Score report

parent view, 24
student view, 18

Student Writing Portfolio report, 172
students

adding to a class, 33
attributes, 101
creating, 28, 30
deleting, 31
displaying assignment status, 73
displaying class progress, 71
downloading transfer file, 240
exporting data, 243
import checklists, 259
importing, 227, 229
index of, 27
overview, 27
permission update records, 254
removing from class, 34
retrying transfer, 241
sociological/economic attributes, 30
transferring

between schools in a district, 235
into a district or school, 234
naming conventions for transfer files, 257
out of a district or school, 233

updating, 31
user names, 29

subject area activities, 16
Submitted Projects dialog box, 190
subscription licensing

concurrent user, 209
single‐user, 209

substrands, 94
support, contacting CompassLearning, xiii
suppression, 53, 68

T
Teacher Login Attendance report, 108
teachers

building assignments, 43
changing profile, 211, 216
creating user, 215
deleting account, 215
displaying assignment status, 71
displaying class progress, 69
import checklists, 259
importing, 225, 229
overview of tasks, 2

templates, in Odyssey Writer, 199
templates, using for Odyssey Writer, 188
Terms and Condition Agreement, 5
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Test Builder
overview, 74
permissions, 253

Test Item Summary report, 144
test items, naming conventions, 258
Test Summary by Goal report, 156
Test Summary by Objective report, 147
Test Translator Import Log, 161
Test Translator reports

Goal Score, 158
Goal‐based Test Results, 153
list of, 99
Longitudinal Goal Score Analysis, 164
NWEA Learning Path Status, 168
State Learning Path Status, 170
Test Summary by Goal, 156
Test Translator Import Log, 161

tests
adding custom items to an objective, 95
building custom, 74
creating custom test items, 82
modes for custom test items, 60
naming conventions, 256
properties, 76
using items from Item Bank, 79

time zones, 217
Title I Math, 30, 228
Title I Reading, 30, 228
toolkit

definition, 12
displaying on student launch pad, 54

transfer
assessments

into a district or school, 238
out or a district or school, 237

assignments
into a district or school, 236
out of a district or school, 236

displaying history, 239
downloading, 240
naming conventions for files, 257
overview, 231
permissions, 254
retrying, 241
rules, 233
students

between schools in a district, 235
in, 234
out, 233

tree, 6
typographic conventions, xiii

U
unassigning, 57
unlimited licensing, 209
update history

displaying, 223
overview, 220

user accounts, 209
Utilization report, 106

V
View Attributes permission, 213, 226

W
warning statement, xiii
web links, including in Odyssey Writer projects, 189
worksheets, 54
writing process, stages, 185
Writing Summary report, 175

Z
zones, time, 217
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